I understand that there is currently no library for the hardware cipher accelerator for TEENSY 4.0.
Also, the "i.MX RT1060 Processor Reference Manual" of NXP does not give details about the security...