Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: guzu

Search: Search took 0.00 seconds.

  1. Thank you very much KurtE for following up on...

    Thank you very much KurtE for following up on this.
  2. I changed the code as you mentioned and IT WORKS!...

    I changed the code as you mentioned and IT WORKS! I changed the spi_mode = 3. Thank you very much.
    What did it change? Just to know what is been eating my days :)

    I am sorry that is was such a...
  3. This ...

    This is the display I bought.
    Here you can find another link to the same display sold by another vendor.
    Here is a link to some documentation.

    Thank you for looking into this.

    One question...
  4. So after many discussions and tests, it seems...

    So after many discussions and tests, it seems that this is a problem with the HW SPI code for the Teensy 4.0.
    If I use the exact same pins (SCK 13, MOSI 11, etc) with the SW SPI constructor to...
  5. Thank you KurtE. I will do that. And thank you...

    Thank you KurtE. I will do that. And thank you for all the inlut. It really helped me.
  6. I tried to test the Oled using the other pins and...

    I tried to test the Oled using the other pins and it had the same issue with the u8g2 Library. However, it seems that the Sparkfun SSD1309 library IS WORKING JUST FINE. :D
    Thank you very much. Now I...
  7. Replies
    5
    Views
    125

    If you do not have a short between the 3.3V and...

    If you do not have a short between the 3.3V and GND rails, you probably have a different issue with the board than mine. The reset option mentioned by KurtE could be useful to you.




    @KurtE...
  8. I tried to underclock the Teensy all the way to...

    I tried to underclock the Teensy all the way to 24MHz. (Using the Arduino IDE > Tools > CPU Speed option.) The horizontal lines are still there.

    @KurtE The mention regarding u8g2 Library working...
  9. Replies
    5
    Views
    125

    Hi. I seem to have the same problem. You can...

    Hi.
    I seem to have the same problem.
    You can find my post here.
    Check if the GND and 3.3V rails are shorted. Mine seem to have 0 Ohm resistance between them.
    If you find what is wrong, please...
  10. Thank you for the reply. The u8g2 Library has a...

    Thank you for the reply.
    The u8g2 Library has a constructor for SSD1309 oleds. But it gives the same result.
    I use the SPI setup.
    VCC - 3.3V
    GND - GND
    SCL - 13 (SCK)
    SDA - 11 (MOSI)
    RES - 24...
  11. Problem using Teensy 4.0 with 2.42" Oled and u8g2 or Adafruit Library

    Hello.

    I am trying to use an 2.42" Oled display with a Teensy 4.0 and the u8g2 Library.
    No matter how I try, I cannot make the Oled to work properly. When I use the u8g2 Library, I get the...
  12. Replies
    1
    Views
    64

    Hey @weasel, did you get this working with the...

    Hey @weasel, did you get this working with the adafruit library? I want to do something similar.
  13. Replies
    0
    Views
    52

    T4 3.3V rail short to GND

    Hello everyone.

    I have a Teensy 4.0 that I have been using for a hobby project. All worked fine until yesterday when I wanted to power the board with the usb cable and nothing happened.

    After...
  14. Hey Chris, I was just wondering what NRF24L01+...

    Hey Chris,

    I was just wondering what NRF24L01+ library are you using for this project?

    Thanks.
  15. Replies
    16
    Views
    8,173

    Hello. I know I am a bit late to the thread, but...

    Hello. I know I am a bit late to the thread, but has anyone managed to get a .sch and a .brd file for this adapter? Also, will this work with the Teensy 4.0?
    Thank you very much.
Results 1 to 15 of 15