Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.05 seconds.

  1. Replies
    363
    Views
    5,093

    Cool. Sounds like you had fun planting - rainy...

    Cool. Sounds like you had fun planting - rainy and cold here so good day to stay inside.
  2. Replies
    363
    Views
    5,093

    Just tested the mods I just made and it works :) ...

    Just tested the mods I just made and it works :) You want me to push it to you or you can just use what you have - probably the same since I just copied it from ILI9341_t3n
  3. Replies
    363
    Views
    5,093

    Just made the changes for 8 and 4 and was going...

    Just made the changes for 8 and 4 and was going to try out - should have known better :)

    EDIT: Is it posted - I will give it a try
  4. Replies
    363
    Views
    5,093

    @KurtE Looks like we are going to have to edit...

    @KurtE
    Looks like we are going to have to edit the ST7789 library to add in read8pp as well since I don't think it currently supports it.
  5. Replies
    363
    Views
    5,093

    Easy answer - yes. See page 16.

    Easy answer - yes. See page 16.
  6. Replies
    363
    Views
    5,093

    That was the change from last night and this...

    That was the change from last night and this morning. So yes first 2 pixels and last 2 pixels.

    Edit:
    Kurt's original DMA code skipped the 1st 4 pixels and what I went to this morning was using...
  7. Replies
    363
    Views
    5,093

    With the change that Kurt made to the 's' decided...

    With the change that Kurt made to the 's' decided to see if the other frameSizes would work as well:

    /*
    * FRAMESIZE_INVALID = 0,
    * VGA Resolutions
    * FRAMESIZE_QQVGA, // 160x120
    ...
  8. Replies
    363
    Views
    5,093

    @Paul Very cool that you got some life with...

    @Paul
    Very cool that you got some life with using FlexIO. Was looking at Kurt's lib this morning and my head hurt :). Oh just one thing the 4pixels is a 2 pixel border around the actual 320x240...
  9. Replies
    363
    Views
    5,093

    Yeah was going way deeper originally to see what...

    Yeah was going way deeper originally to see what was going on so started with Vsync. Want to see what you did and see I can merge but really distracted. I did remember to update the PDE to 324/244...
  10. Replies
    363
    Views
    5,093

    @KurtE Updates are already pushed to repository,...

    @KurtE
    Updates are already pushed to repository, see post 342, right before yours.

    99% sure that the writeSubImageRect is working correctly because I am now using it for 's'napshot and...
  11. Replies
    363
    Views
    5,093

    Just pushed the current changes using...

    Just pushed the current changes using subWriteRect and QVGA = 324x244. One other thing - took setpixformat out of the sketch and called it directly from init since this camera only supports...
  12. Replies
    363
    Views
    5,093

    Morning @KurtE Yep - tried just making...

    Morning @KurtE

    Yep - tried just making _frame_ignore_cols = 0 but the image messed up. Agree - not sure why you are multiplying by 2 since we only have grayscale. The *2 in the original...
  13. Replies
    363
    Views
    5,093

    @KurtE I found the issue that you were having...

    @KurtE

    I found the issue that you were having with having to skip 4 pixels. Turns out that the actual image size for QQVGA is 324x244 and not 320x240. The extra 4 pixels seem to be just border...
  14. Replies
    363
    Views
    5,093

    @KurtE - @Paul - @defragster - @all More...

    @KurtE - @Paul - @defragster - @all
    More discoveries, realizations and decisions.

    Doing some digging it appears that the framerate is dependent on 3 settings:
    1. clock - osc_div which is done...
  15. Replies
    363
    Views
    5,093

    Just to satisfy my curiosity I put back into the...

    Just to satisfy my curiosity I put back into the loop Paul's vsych timing code and sure enough, whatever combination of settings Sparkfun is using seems off:

    Using the 6Mhz clock and only changing...
  16. Replies
    363
    Views
    5,093

    Did a little bit more testing and one thing I...

    Did a little bit more testing and one thing I noticed is that the framerate when set to 60 seems alot slower using the Sparkfun config rather than the default config. With the default config the...
  17. Replies
    363
    Views
    5,093

    Found it. 3, 0xb1, 0x00, 0x10, // FrameRate...

    Found it.

    3, 0xb1, 0x00, 0x10, // FrameRate Control 119Hz its in both the ILI8341_t3 and _t3n libraries.
  18. Replies
    363
    Views
    5,093

    Hi all @KurtE beat me to it - was going to...

    Hi all
    @KurtE beat me to it - was going to mention that @KurtE did a lot of work with FlexIO and he a library set up for it - not sure where the whole discussion is on the forum anymore

    I'll...
  19. Replies
    363
    Views
    5,093

    @KurtE Can't seem to push the SPI Clock over...

    @KurtE
    Can't seem to push the SPI Clock over 30Mhz for the ILI9341 - just shows a white screen if I do. Just an FYI
  20. Replies
    363
    Views
    5,093

    I'll go ahead and push the changes I have so we...

    I'll go ahead and push the changes I have so we will in synch again. then you can change the handshake. You know never thought about about how fast the screen can update. Don't remember what SPI...
  21. Thanks for the info and update

    Thanks for the info and update
  22. Replies
    363
    Views
    5,093

    @KurtE Changed 2 settings in the default config...

    @KurtE
    Changed 2 settings in the default config and DMA seems to be working without using the Sparkfun:


    {FS_60HZ_L, 0x85},
    {FS_50HZ_L, 0xa0}, Give it a try and...
  23. Replies
    363
    Views
    5,093

    Just merged your PR but looks like DMA mode got...

    Just merged your PR but looks like DMA mode got worse when not using Sparkfun registers.
  24. Replies
    363
    Views
    5,093

    Was actually thinking about something like that...

    Was actually thinking about something like that last night but seems you beat me to it:)

    Anyway's just did a quick experiment and think the MCLK clock has something to do with it. For the...
  25. @Frank B Ok - I know I can't answer this but...

    @Frank B
    Ok - I know I can't answer this but curious since I have no idea what it means. Think you are saying that what lib is included its using software to calculate integer divisions when T4...
  26. Replies
    363
    Views
    5,093

    Nice comparison @KurtE. From the lib I know what...

    Nice comparison @KurtE. From the lib I know what some of those settings are and some get changed with the function calls:

    INTEGRATION_H(202) 2(2) 1(1)
    INTEGRATION_L(203) 133(85) 2(2)...
  27. Replies
    363
    Views
    5,093

    Was wondering why you set it up to have its own...

    Was wondering why you set it up to have its own namespace. Is there anyway to do that with in the core. Reason asking it would be simpler than have to add the files to every library or sketch? ...
  28. Replies
    363
    Views
    5,093

    Morning @KurtE Actually thought about it but...

    Morning @KurtE
    Actually thought about it but forgot. Remember what they say about assume.

    UPDATE: It works:

    Acc [mg]: 21.0 x, -37.0 y, 1055.0 z, 27.5C
    Acc [mg]: 21.0 x, -34.0 y, 1059.0 z,...
  29. Replies
    363
    Views
    5,093

    Good luck with FlexIO for the camera - assuming...

    Good luck with FlexIO for the camera - assuming you mean the 4bit FlexIO? Are you trying it with the library or started it with your initial test sketch - going to assume your initial sketch? If...
  30. Replies
    363
    Views
    5,093

    Was testing a couple more things: 15s Restore: ...

    Was testing a couple more things:
    15s Restore: Works - tested both on the ATP and ML boards.

    Quad Encoder Library: Finally got a chance to test change I made to the T4 Quad Encoder library...
  31. Replies
    363
    Views
    5,093

    On a different note from the HB01B0 camera. Was...

    On a different note from the HB01B0 camera. Was looking at what @luni did and looking at the pins_arduino.h file and was wondering if it would worth it to add @luni's pinouts to the pins_arduino.h...
  32. Replies
    363
    Views
    5,093

    @defragster - getting ready for zzzz's but it has...

    @defragster - getting ready for zzzz's but it has to be something on the PC side. I have it hooked up to my powered hub and its working no problem. I did notice that there is a noticable delay...
  33. Replies
    363
    Views
    5,093

    @KurtE - @defragster - @PaulStoffregen - @All...

    @KurtE - @defragster - @PaulStoffregen - @All
    Decided to take a short break from the camera stuff and see if I could get the the ILI9341_t3n library working with the Sparkfun Display/Input board. ...
  34. Replies
    363
    Views
    5,093

    Try using the sparkfun config by uncommenting the...

    Try using the sparkfun config by uncommenting the use_sparkfun at the begging of the sketch. Think I am using 4 in wires with no problem.

    Ps. Sent about 30 images to the processing sketch from...
  35. Replies
    363
    Views
    5,093

    Very cool Paul that you got it wired up and its...

    Very cool Paul that you got it wired up and its working :) I did incorporate the PR and Thanks for fixing that packed warning message - wasn't sure how to fix that one :)


    Incorporated your PR...
  36. Replies
    363
    Views
    5,093

    That was the only thing I could think off the top...

    That was the only thing I could think off the top of my head. Will have to test it out again soon. Think for the most part I done with changes now time to have fun with Kurt’s smart stuff and the...
  37. Replies
    363
    Views
    5,093

    @defragster You could try changing the baud...

    @defragster
    You could try changing the baud rate in the processing sketch to something much larger than 9600
  38. Replies
    363
    Views
    5,093

    @defragster That comment is from the auto...

    @defragster
    That comment is from the auto calibration function that I extracted from the Sparkfun library. Just tweaked the sketch a bit more after playing with some of the functions and I am not...
  39. Replies
    363
    Views
    5,093

    @KurtE You are going to kill me just pushed up...

    @KurtE
    You are going to kill me just pushed up some minor changes:
    1. fixed pfmt,
    2. #define for monochrome sensor
    and
    3. Some tweaks to the sketch

    Can't wait to see what you did to it :)
  40. You may want to check this video out (Why I put a...

    You may want to check this video out (Why I put a Teensy in Every Project):
    https://www.youtube.com/watch?v=75IvTqRwNsE
  41. Replies
    363
    Views
    5,093

    Almost sure its on the processing side. Had...

    Almost sure its on the processing side. Had similar problems before with processing. Thought most of it would be resolved if we used USB1.
  42. Replies
    363
    Views
    5,093

    Actually what I was thinking was to add a define:...

    Actually what I was thinking was to add a define:

    #define SensorMonochrome 1
    to the .h and then wrap the test in a define. Probably will do that on the next update.
  43. Replies
    363
    Views
    5,093

    @Paul - agree with Kurt - pretty cool to see.

    @Paul - agree with Kurt - pretty cool to see.
  44. Replies
    363
    Views
    5,093

    Not sure whats going on - on my machine it seems...

    Not sure whats going on - on my machine it seems to be working no problem. After I finish play with the lib and sketch maybe will play with the processing code.

    Right now I am playing with the...
  45. Replies
    363
    Views
    5,093

    @KurtE Was just playing with the fix and...

    @KurtE
    Was just playing with the fix and something hit me with readframe. The readFram function was designed to support the color version of the HB01B0 camera so once you fix the error with...
  46. Replies
    363
    Views
    5,093

    Darn it. Fixed it for framesize but forgot to...

    Darn it. Fixed it for framesize but forgot to change it for pixformat. Going to fix it now.
  47. Replies
    363
    Views
    5,093

    About 5minutes after I post the question I...

    About 5minutes after I post the question I remembered that those flags are no longer in use with the SD library. Sometimes hard to remember all the changes :) See the update to the post. Thanks...
  48. Replies
    363
    Views
    5,093

    Morning again Running into a little problem. I...

    Morning again
    Running into a little problem. I the past (Buddabrot) I have used this code snippet to increment the file name if the file already existed on the SD card using the SD library:

    //...
  49. Replies
    363
    Views
    5,093

    Good morning all Been at it again this morning...

    Good morning all
    Been at it again this morning with the camera library. Made some minor updates to the sketch and pushed them up to the repository.
    1. New menu selections:

    ...
  50. Replies
    363
    Views
    5,093

    @defragster Something weird. I just responded...

    @defragster
    Something weird. I just responded to this but maybe forgot to hit post. I just retested with stock ili9431 library and am sending frames to the Processing sketch without an issue. Not...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4