The pawelsky version is pretty much drop-in compatible with the FlexCAN library that comes with the TeensyDuino installation (as far as I know the one that comes with the installation is the teachop...