Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: Elbarfo

Search: Search took 0.00 seconds.

  1. So, it appears a PC reboot brought back the...

    So, it appears a PC reboot brought back the serial. It looks like something hosed the windows serial driver.

    I must have cleared the noise issue coincidentally with the serial dying. Weird...
  2. Yay, new protoboard. This one is significantly...

    Yay, new protoboard. This one is significantly tighter than the old one. I have around 3 feet less cabling now. Should help, I think. Now to figure out how to get consistent encoder readings.......
  3. Now that I think about it, I had to change the...

    Now that I think about it, I had to change the name of one of the functions in the Garmin library too. IIRC they changed the name of the distance function.
  4. My first post is using the Lidar Lite Library on...

    My first post is using the Lidar Lite Library on Garmin's Github. It's the newest version. It appears they updated it after the new HP units were released.

    I had to change every reference to...
  5. That's interesting you're pushing the LL's so...

    That's interesting you're pushing the LL's so fast. I had no idea they'd go so high. Makes me want to try. How many read/s are you getting that way, and does it still maintain accuracy? With...
  6. It's weird. That all went away after not using...

    It's weird. That all went away after not using serial drivers. I'm still using the Raw HID and it's humming along nicely now. Haven't changed a thing on my scopes, wiring or anything. I've now...
  7. OK, here's a weird thing. Somewhere along...

    OK, here's a weird thing.

    Somewhere along the way after so many resets, something went wrong with the serial port on the teensy. I reset it, power failed it, restarted the IDE and serial...
  8. Still looking for a proper opto coupler. May...

    Still looking for a proper opto coupler. May have to settle for an opto inturrupter with nothing interrupting it. In the meantime I did attach the PWM output to a resistive load (an LED with 1K...
  9. duplicate post, sorry

    duplicate post, sorry
  10. It probably isnt a bad idea to put a cap on the...

    It probably isnt a bad idea to put a cap on the spinner to keep the 5V level.

    Initially I had been building this on a nano, who's I2C is measurably less sensitive than the Teensy's it seems. I...
  11. This is the code I'm using now. That Enhanced...

    This is the code I'm using now. That Enhanced lidar library is really nice compared to garmin's default libraries, btw. As long as PWM isn't connected this thing updates at whatever rate I set. ...
  12. I'm running the I2C bus at 400KHz. All I'm using...

    I'm running the I2C bus at 400KHz. All I'm using are the built in pullups on the LidarLites which are 3k. I haven't tried scoping the I2C lines, I suppose I should.

    Here is the Clock prior to...
  13. Thanks for the reply! I have a 1000uF cap...

    Thanks for the reply!

    I have a 1000uF cap across the 5V power supply for the lidarlites. Didn't have a 680.

    Sadly, the I2C dies when the PWM is activated while connected to anything. As long...
  14. I have changed my Lidar code, and still have the...

    I have changed my Lidar code, and still have the same problem.

    I have isolated it a little further though. I can have i2C humming along giving me hudreds of measurements a second now, but as...
  15. Nothing at all? Sigh

    Nothing at all? Sigh
  16. Teensy 3.2 - I2C and PWM issues with Lidar Lite V3

    Hello all,

    I have 2 Lidar Lite v3's connected together in an attempt to make a spinning lidar using a teensy 3.2. I had originally tried this on an Arduino Nano, but it seemed to need a little...
Results 1 to 16 of 16