I don‘t think that there is a reason to continue supporting older versions. Why would people not update their Arduino IDE version, if not for laziness or convenience.
In my eyes, it‘s a good idea to...