Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. Replies
    570
    Views
    9,847

    Just got the new breakout board and gave FlexIO a...

    Just got the new breakout board and gave FlexIO a try and in the image below you can see what the problem is - reading the 4bits but skipping every other one so shading will be off:
    24528
    Not sure...
  2. Replies
    570
    Views
    9,847

    Well that change alone seems to work but the data...

    Well that change alone seems to work but the data transfer has to be modified since its only set up for Bytes. Not sure how to do that one :)

    EDIT: Will push what I have up that I did with the...
  3. Replies
    570
    Views
    9,847

    Cool - glad its working. Now trying to figure...

    Cool - glad its working.

    Now trying to figure this one out:

    FLEXIO_SHIFTCFG_PWIDTH(7); think it just needs to get changed to

    FLEXIO_SHIFTCFG_PWIDTH(3); and of course use only 4 pins.
  4. Replies
    570
    Views
    9,847

    Morning Kurt 4bit mode for me anyway means that...

    Morning Kurt
    4bit mode for me anyway means that it just takes 2 reads to get the 8bits for the each pixel. First transfer gets you the upper 4bits of the pixel and the second transfer gets you the...
  5. Replies
    570
    Views
    9,847

    @KurtE - @defragster Just pushed a bunch of...

    @KurtE - @defragster
    Just pushed a bunch of changes to the API-rework branch to test 4-bit mode in GPIO mode only. Pretty sure its working.

    @defragster - incorporated some your changes - example...
  6. Replies
    570
    Views
    9,847

    Morning @KurtE - well. I can confirm that 4-bit...

    Morning @KurtE - well. I can confirm that 4-bit mode works. Just kludged up my local copy to try 4-bit using GPIO only. Only register that needs to changed it seems is 0x3059 (BIT control) so bit...
  7. Replies
    570
    Views
    9,847

    @defragster I merged your pull request then...

    @defragster
    I merged your pull request then noticed that you deleted some stuff that is needed for GPIO continuous mode. Have to go over it in more detail after I have my coffee.

    EDIT: this is...
  8. Replies
    570
    Views
    9,847

    @luni Thanks for the detailed explanation -...

    @luni
    Thanks for the detailed explanation - learning something new everyday - you know one of these days something like this should be written up and put on the wiki (I know have checked lately)...
  9. Replies
    570
    Views
    9,847

    Yeah didn’t mention it but you can save to sd,...

    Yeah didn’t mention it but you can save to sd, send to the processing sketch or use the arducam app to see the image without the display in all modes selected :) gpio, small or flex
  10. Replies
    570
    Views
    9,847

    Ok trying to figure out how to just read 4-bits...

    Ok trying to figure out how to just read 4-bits instead of 8 and didn't want to admit that I have very little clue what this is doing:

    uint32_t in = (GPIO7_PSR >> 4); // read all bits in parallel...
  11. Replies
    570
    Views
    9,847

    I think the OV camera's work in 4-bit mode...

    I think the OV camera's work in 4-bit mode either. When I was saying common denominator I was talking about between MM, T4.1 and T4.0. I wasn't suggesting between cameras. Personally I like the OV...
  12. Replies
    570
    Views
    9,847

    Evening all. Paul - not a problem. Didn't...

    Evening all.

    Paul - not a problem. Didn't miss much except me playing with library to get a jump on reorganizing.

    You are probably right about 8-bit being redundant but guess will see how...
  13. Replies
    570
    Views
    9,847

    Morning @KurtE :) Funny you should mention...

    Morning @KurtE :)

    Funny you should mention about CSI/OV7670 was just looking at that this morning. Great minds.

    Anyway for now think I have gone about as far as I can go with mods - still...
  14. Replies
    570
    Views
    9,847

    Thanks @defragster. Now that there is some life...

    Thanks @defragster. Now that there is some life I think I may know what the problem may be.

    EDIT: Nope what I thought may be wrong looks correct. But I did add my change to get GPIO 'F' working...
  15. Replies
    570
    Views
    9,847

    Thanks for checking - have to retest. Yes 'f'...

    Thanks for checking - have to retest.

    Yes 'f' only in GPIO-8bit for now - that's on the todo list to fix
    Yep - VID only works in DMA mode as it did before but 'F' and 'f' works with FlexIO as...
  16. Replies
    570
    Views
    9,847

    Yep 'f' - single shot, 'F'-continuous (still not...

    Yep 'f' - single shot, 'F'-continuous (still not working if in DMA_8BIT mode but it does give you what you describe - what about 'V' ideo ? That's the one I am curious about.

    NOTE: I haven't...
  17. Replies
    570
    Views
    9,847

    Thanks would appreciate - all else seems to be...

    Thanks would appreciate - all else seems to be working with DMA though. Already created WIP branch on github: https://github.com/mjs513/TMM-HB01B0...ree/API-Rework
  18. Replies
    570
    Views
    9,847

    Just a quick update. Been trying to figure it...

    Just a quick update. Been trying to figure it out most of the day. Found a couple errors but still no luck with video mode. So I bypassed my readframe's etc and used direct calls but no luck. Not...
  19. Replies
    570
    Views
    9,847

    As a test I just pushed some more changes to the...

    As a test I just pushed some more changes to the API_rework branch: https://github.com/mjs513/TMM-HB01B0-Camera/tree/API-Rework

    I supports 3 cases for the Mircomod only:

    /*
    * ...
  20. Replies
    570
    Views
    9,847

    @KurtE Forgot about the table you have in the...

    @KurtE
    Forgot about the table you have in the FlexIO library - was actually looking to create one - sort of.

    Right now the way it looks is the DMA is used for both for DMA mode and FlexIO mode...
  21. Replies
    570
    Views
    9,847

    Now for instance. For DMA I see that the...

    Now for instance. For DMA I see that the function:

    startReadFrameDMA(bool(*callback)(void *frame_buffer), uint8_t *fb1, uint8_t *fb2)
    does setup framebuffers if fb1 and fb2 are not specified. ...
  22. Replies
    570
    Views
    9,847

    Good Morning all Started work on mods to the...

    Good Morning all
    Started work on mods to the lib. Created the following in the lib:

    typedef enum {
    HM01B0_SPARKFUN_ML_CARRIER = 0,
    HM01B0_TEENSY_MICROMOD_GPIO_8BIT,...
  23. Replies
    570
    Views
    9,847

    @All Good Morning. Decided to play a bit more...

    @All
    Good Morning.

    Decided to play a bit more with the camera so I ported over the CMSIS NN example using CIFAR10 example that identifies several objects. Did have to reduce the size of the...
  24. Replies
    570
    Views
    9,847

    Actually yes, on and off thought about but...

    Actually yes, on and off thought about but something always distracted me. Just took another look and found this one as well: https://create.stephan-brumme.com/toojpeg/ == it has some good...
  25. Replies
    570
    Views
    9,847

    @luni Nice toy. Must be nice to have room for...

    @luni
    Nice toy. Must be nice to have room for things like that :)

    Guess I will have to see about about sending a continuous stream to the PC :)
  26. Replies
    570
    Views
    9,847

    No - you are going to be in trouble if you use...

    No - you are going to be in trouble if you use that one. Down the version I am using from here: https://github.com/ArduCAM/Arduino/tree/master/ArduCAM/examples/host_app/ArduCAM_Host_V2.0_Windows
  27. Replies
    570
    Views
    9,847

    Actually not really. FlexIO is so intertwined...

    Actually not really. FlexIO is so intertwined with the DMA stuff that 98% of its still being called for flexIO dma. :) which I chose to leave in. That caused me some problems when doing that :)
    ...
  28. Replies
    570
    Views
    9,847

    Got it. I wouldn't hold it up either. It does...

    Got it. I wouldn't hold it up either. It does seem to be working.

    @Paul - @defragster
    I did just make a few changes in prep for final release. I add 3 defines (at least for now) in the HM01B01...
  29. Replies
    570
    Views
    9,847

    I just tried it with your change and saw the same...

    I just tried it with your change and saw the same thing but only if I changed the default size "Arial_10_Bold", otherwise it hung after only 1 cycle.
  30. Replies
    570
    Views
    9,847

    Not a problem, just wanted to let you know. Took...

    Not a problem, just wanted to let you know. Took a while to find a display that you didn't test with - saw you tested with the 240x240 and the 320x240.

    One curious thing about the HM01B0. Was...
  31. Replies
    570
    Views
    9,847

    Just tested your latest changes on a T4.1 with a...

    Just tested your latest changes on a T4.1 with a Adafruit 128x128 display. Starts up fine and display looks good however after I toggle updates off screen stops but I can't seem to toggle it back...
  32. Replies
    570
    Views
    9,847

    Morning all @KurtE - Just downloaded your...

    Morning all
    @KurtE - Just downloaded your updates from last night and yep resolved the compile issue. Did you sort out your compile issue?

    @ecurtz
    Your guess was pretty good. With a couple of...
  33. Replies
    570
    Views
    9,847

    @KurtE Think your latest rounds of updates to...

    @KurtE
    Think your latest rounds of updates to the 7735 lib broke something in the HM01b0 library:
    ...
  34. Replies
    570
    Views
    9,847

    @KurtE Ok I give up. Got be doing something...

    @KurtE
    Ok I give up. Got be doing something wrong someplace and not sure where. What I am trying to duplicate is what we did in your CSI_41_main in the send_image function. But just can't seem to...
  35. Replies
    570
    Views
    9,847

    No comment on git :) Any I just compile the...

    No comment on git :)

    Any I just compile the test sketch that you posted with the latest updates to the ST7735 library and got no errors. I tried 7789 only, 9341 only, and both uncommented still...
  36. Replies
    570
    Views
    9,847

    Afternoon @KurtE Thanks for the references on...

    Afternoon @KurtE
    Thanks for the references on the regulators - now have no idea which to put on the breakout board :) Any suggestions. Leaning to the 1.5 amp one just in case :)

    I'll give the...
  37. Replies
    570
    Views
    9,847

    Got a side question on regulators for the T4.1...

    Got a side question on regulators for the T4.1 breakout board.

    Someone gave me a link for 5v VIN reg (https://www.ezsbc.com/product/psu5-2/ or I was looking at...
  38. Replies
    570
    Views
    9,847

    Ok - thats strange would have thought it would...

    Ok - thats strange would have thought it would have worked.

    Not having much luck with my project. Think going to ditch it. Something is off have I can't figure it out.
  39. Replies
    570
    Views
    9,847

    @KurtE - glad all is working. The testing I did...

    @KurtE - glad all is working. The testing I did was on the 320 display and just waiting for the mail to hook it up to the T4.1 display adapter I have. Will let you know when I get it. Rainy cool...
  40. Replies
    570
    Views
    9,847

    Yesterday and this morning was working on sending...

    Yesterday and this morning was working on sending an image to Arducam Imaging App. The app takes images - bmp or video and displays it rathe quickly. But looks like I have to resize from down to...
  41. Replies
    570
    Views
    9,847

    Exact same one - will arrive this afternoon...

    Exact same one - will arrive this afternoon probably :)
  42. Replies
    570
    Views
    9,847

    Morning @KurtE Just got my coffee then...

    Morning @KurtE
    Just got my coffee then downloaded your updated lib and tried on the Micromod - seems to be working as far as I can see - toggled the updates on/off several times and no issues.

    I...
  43. Replies
    570
    Views
    9,847

    You know never thought about looking up the ascii...

    You know never thought about looking up the ascii character - no wonder I was having a problem - thanks :) So obvious after the fact
  44. Replies
    570
    Views
    9,847

    Nope: hm01b0_testv3:503: error: duplicate case...

    Nope:

    hm01b0_testv3:503: error: duplicate case value
    case 48:
    ^
    hm01b0_testv3:489: error: previously used here
    case '0':
    ^
    only wants single characters - maybe redo...
  45. Replies
    570
    Views
    9,847

    @KurtE Just gave your 'V' mode a try with the...

    @KurtE
    Just gave your 'V' mode a try with the ST7789 and....
    1. Sparkfun config - worked very nicely, however when I exited video mode the TMM was basically hung. Could not enter any other...
  46. Replies
    570
    Views
    9,847

    Afternoon all @KurtE - looks like you been busy...

    Afternoon all
    @KurtE - looks like you been busy this morning and afternoon between the new board design and fixing ST7735 lib. Kind of been a bit distracted with running errands again and in...
  47. Replies
    570
    Views
    9,847

    Good luck @KurtE. Be interesting see how it...

    Good luck @KurtE. Be interesting see how it works.

    Thinking about changing the name of the test sketch in prep for release to: HM01B0-KitchenSink :) Then start breaking some of the code out...
  48. Replies
    570
    Views
    9,847

    The last PR incorporated from @KurtE included the...

    The last PR incorporated from @KurtE included the 'V'ideo command.

    Tested with both Sparkfun and non-Sparkfun. Only thing is for DMA video/continuous it does take a while for the image to synch...
  49. Replies
    570
    Views
    9,847

    Good Morning all Just gave our latest set of...

    Good Morning all
    Just gave our latest set of updates a spin. Tested the same as @defragster and agree all is working well. The only thing not tested was the 'z' command.
  50. Replies
    570
    Views
    9,847

    All Had a strange thought - not sure where it...

    All
    Had a strange thought - not sure where it came from must have been a nightmare. With the lack of PSRAM on the MM board is there a way to use the SDIO pins to simulate having a PSRAM and maybe...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4