Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: OhioJim

Search: Search took 0.00 seconds.

  1. Replies
    25
    Views
    693

    Progress! Attached is my latest test sketch. ...

    Progress!

    Attached is my latest test sketch. In the main loop you will see a commented-out section. That is my original code that has problems.

    It appears that the problem has something to do...
  2. Replies
    25
    Views
    693

    That is on my list of things to try. And thanks...

    That is on my list of things to try. And thanks for the link. I will check it out. And don't forget the SCK line. It looks like the L6470 is missing a clock transition. Remember the S100 buss...
  3. Replies
    25
    Views
    693

    I found where the problem is coming from. Now to...

    I found where the problem is coming from. Now to figure out what causes it, and what to do about it.

    My scope is barely able to see the signals, but I wrote a minimalist sketch to initialize the...
  4. Replies
    25
    Views
    693

    It made no difference.

    It made no difference.
  5. Replies
    25
    Views
    693

    Here is the stripped down code. Lots of things...

    Here is the stripped down code. Lots of things commented out, so I hope you can follow it.


    #include <SparkFunAutoDriver.h>
    #include <SparkFundSPINConstants.h>

    #include <SPI.h>

    // Create...
  6. Replies
    25
    Views
    693

    Yes, I did. No response from Sparkfun. Their...

    Yes, I did. No response from Sparkfun. Their forum doesn't seem to be very active.
  7. Replies
    25
    Views
    693

    I stripped the sketch downs so all it does is...

    I stripped the sketch downs so all it does is reset the Autodriver and initialize the SPI.

    Then in the main loop it reads the configuration register over and over and sends it back up the Serial...
  8. Replies
    25
    Views
    693

    I will look into that. My feeling is that the...

    I will look into that.

    My feeling is that the problem has something to do with clocking the data. There is a parameter in the library that has something to do with a SPI clock divider. Not sure...
  9. Replies
    25
    Views
    693

    That is what I meant by "display". Send the...

    That is what I meant by "display". Send the configure register values over the Serial link and display on my desktop.

    There is a 20x4 display in my project but I am not using it for this motor...
  10. Replies
    25
    Views
    693

    I took the last remaining good Autodriver and...

    I took the last remaining good Autodriver and rewired for a single board.

    I also stripped down the sketch so all it does is read and display the configuration register once per second.

    It...
  11. Replies
    25
    Views
    693

    Yes. Verified I found a page in the...

    Yes. Verified


    I found a page in the datasheet for the L6470, which is the chip used on the Autodriver. It appears that there is only one CS, the SPI MOSI pin goes to the first chip SDI pin. ...
  12. Replies
    25
    Views
    693

    I don't have any datasheets, but I will see if I...

    I don't have any datasheets, but I will see if I can find them. All I know is the NEMA designation, which indicates it is a NEMA 14 with 4 wires, and a current rating of 0.4 amps. It was purchased...
  13. Replies
    25
    Views
    693

    Which means there is only one CS pin for both...

    Which means there is only one CS pin for both boards!
  14. Replies
    25
    Views
    693

    Ribbon cables between the Autodriver and the t4.0...

    Ribbon cables between the Autodriver and the t4.0 are about 5 inches. Between the autodrivers and the motors themselves there is a 5 foot coiled microphone type cable. The motors are on the...
  15. Replies
    25
    Views
    693

    Some further information on this.... Added...

    Some further information on this....

    Added some statements to my code to read the autodriver status register and send it up the serial port.

    It indicates that occasionally it misses a step. ...
  16. Replies
    25
    Views
    693

    Sparkfun Autodriver and Teensy 4.0

    My telescope project is nearing completion. The last step is to get the stepper motors working.

    I have 2 Sparkfun L6470 Autodrivers connected to SPI port #2 on the t4.0 and have been trying to...
Results 1 to 16 of 16