Not with the Teensy 4.0, since the bootloader chip isn't available yet, but plenty of people have with the Teensy 3.x. Be sure to read through the links on this page:...