Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. @defragster Interesting results and curious. ...

    @defragster

    Interesting results and curious.

    As for the @KurtE's latest startup sketch you should see 3 berries - yep - sort of green and top reddish/purplish on the bottom. I have two...
  2. @KurtE - @defragster I think I mentioned that...

    @KurtE - @defragster

    I think I mentioned that the new display wouldn't work at all with the existing lib - screen stayed white. I changed the startup sequence to match what we have in the...
  3. @KurtE Well as usual your sketch is a lot better...

    @KurtE
    Well as usual your sketch is a lot better than mine :)

    Anyway on startup the raspberries show correctly with a black background. Which is the top of the screen - the color seems match...
  4. @KurtE - @defragster Sorry - been distracted...

    @KurtE - @defragster

    Sorry - been distracted playing with this crazy display. Nothing seems to work to get it to right without negating the colors. I edited the kedei_simple sketch to pull in...
  5. Since I don't have the raw data what you would...

    Since I don't have the raw data what you would have to do is to lcd_cmd(MOSI) and LCD_DAT(MISO)? or do I have it backwards - please teach me master yoda :)

    EDIT:
    Dummy that I am I just converted...
  6. @KurtE It could very well be. I got my third...

    @KurtE

    It could very well be. I got my third display and tested it on T4 - Ran the graphics test sketch and nothing - screen remained white. So I ran the kedei startup sketch and it displayed...
  7. don't think so was sitting for about 15 minutes...

    don't think so was sitting for about 15 minutes or so - if I type on the keyboard I can see the keystrokes on the screen
  8. @KurtE Ok - download just finished - took a...

    @KurtE

    Ok - download just finished - took a couple of hours man...…

    1. Booted up pi 3 with the 6.3 img I downloaded screen looked good - nice black background with nicely colored raspberries :)...
  9. @KurtE Ok. What image did you use and how...

    @KurtE


    Ok. What image did you use and how do you install it - or point me in the right direction - I do have a raspberry pi 3 sitting around I can test it on.
  10. @KurtE Stop showing off :) Didn't even look...

    @KurtE
    Stop showing off :)

    Didn't even look their - was busy checking the conversions. Any loaded it up with the correction and it ran but my colors are still off - screen is white raspberry is...
  11. @KurtE Tried a couple of things but no go - I...

    @KurtE
    Tried a couple of things but no go - I tried to match what you had with what I had as best I good but they look like a match.
  12. @KurtE Tried lining up what you have with what I...

    @KurtE
    Tried lining up what you have with what I was working on in my spreadsheet - a couple things didn't line up but have to finish doing some chores around the house then I will get back to it. ...
  13. @KurtE The nerd that I am I tried to make it...

    @KurtE
    The nerd that I am I tried to make it work without a lot of manual conversion. If do the delay etc and then do a mass copy and past of all 201K lines work load into the T4 - out of memory. ...
  14. Replies
    3,765
    Views
    389,135

    @Frank B Really don't remember the errors but...

    @Frank B
    Really don't remember the errors but would definitely need to be fixed if Paul updated from GCC 5.4 - not sure if he wants to do this at this point in time - a lot of regression testing...
  15. @KurtE I am as bad as you. I did some...

    @KurtE

    I am as bad as you. I did some massaging of the txt file and added a column for lcd_cmd and lcd_dat, a lot of duplicates ( I did in it excel using if statement). Tell me what you think:
    ...
  16. You can try to use this for your interrupt: ...

    You can try to use this for your interrupt:

    #define RFM95_INT digitalPinToInterrupt(2) as opposed to
    #define RFM95_INT 2
  17. Replies
    3,765
    Views
    389,135

    I have a optoresitor in the loop attached to pin...

    I have a optoresitor in the loop attached to pin A2 but I've run the sketch with one display with and without it attached.... besides on compile/upload it should be an issue until it runs - so it...
  18. Oh boy - hope you had some fun. Yes I know you...

    Oh boy - hope you had some fun.

    Yes I know you will massage it but fair warning there are some blocks that don't follow cmd/data blocks - I was doing that earlier. Then there are a whole bunch of...
  19. Replies
    3,765
    Views
    389,135

    @defragster - @Frank B Running into problem...

    @defragster - @Frank B

    Running into problem with GCC6 - Eigen library that runs fine under GCC7 is now throwing errors so sketch can not compile. Not sure if there will be an impact to anything...
  20. Replies
    3,765
    Views
    389,135

    Yep - replaced it with the contents of arm6 ...

    Yep - replaced it with the contents of arm6

    EDIT = make sure you back it up first
  21. Replies
    3,765
    Views
    389,135

    @defragster Change "arm6" to arm and it will...

    @defragster

    Change "arm6" to arm and it will run. I zipped the present toolchain and then copied arm6 over and renamed it to "arm". I also deleted the 5.3.1 folder.
  22. @KurtE I was beginning to do that before you...

    @KurtE

    I was beginning to do that before you got the initial sketch that we started from working so I just left it at that. Don't know if it worth it at this point to spend that much time going...
  23. Replies
    3,765
    Views
    389,135

    @KurtE Tried several SPI freq lowering it down to...

    @KurtE Tried several SPI freq lowering it down to 8Mhz but no change to the distorted image.

    Note that if I do and include debug_tt it the eyes on both screens display normally.

    It looks...
  24. Replies
    3,765
    Views
    389,135

    @Frank B and @defragster @KurtE Hope you don't...

    @Frank B and @defragster @KurtE

    Hope you don't mind but I just downloaded and installed your GCC 6. Ok don't get the that error anymore but without debug_tt the eyes on the two screens are...
  25. @KurtE Had to make a slight change to get...

    @KurtE

    Had to make a slight change to get colors to match and touchpaint to match what you had:

    // Define at most only one of these...
    //#define RGB_COLORS
    //#define BGR_COLORS
    //#define...
  26. Replies
    3,765
    Views
    389,135

    Isn't it though :). Wonder if it shows the same...

    Isn't it though :). Wonder if it shows the same behavior with other optimizations? Oh - it does work on a T3.6 last I looked.
  27. Replies
    3,765
    Views
    389,135

    Yes - writeRect was added later so definitely...

    Yes - writeRect was added later so definitely need KurtE's fork branch that he referenced in post3723.
  28. Oh wasn't clear - none of them worked. Sorry. ...

    Oh wasn't clear - none of them worked. Sorry.

    I did break down and ordered another display just as a test - I screwed up that second one that I bought. Will get it Thursday. Don't know if its...
  29. @KurtE Just gave it a try and the changing the...

    @KurtE
    Just gave it a try and the changing the madtl does change the colors to the correct ones. The only thing that does it is to invert RGB colors. Then it works as you show. Sorry.

    Strange...
  30. @KurtE - @defragster If you do the following...

    @KurtE - @defragster

    If you do the following in the GITHUB .h file:

    #define RGB_COLORS 1
    // Color definitions
    #ifdef RGB_COLORS
    #define KEDEIRPI35_BLACK 0xFFFF-0x0000 /* 0, 0,...
  31. @KurtE - @defragster Ok in the loop if I change...

    @KurtE - @defragster
    Ok in the loop if I change in your kedei_simple sketch

    lcd_fillframe(0, 0, lcd_w, lcd_h, (colors[color]));
    to

    lcd_fillframe(0, 0, lcd_w, lcd_h, 0xFFFFFF...
  32. @KurtE - @defragster Playing around with the...

    @KurtE - @defragster

    Playing around with the simple kedei sketch in post #386 the colors are still off so I put in a wait for input loop so I can try to match the colors to screen. I got this, it...
  33. @KurtE - @defragster Didn't realize there was...

    @KurtE - @defragster

    Didn't realize there was a white box on the far right - when I hit White the sermon shows black, when I hit black it shows White.
  34. @KurtE No worries about the pic. I just...

    @KurtE

    No worries about the pic. I just checked the back of my display and it has the exact same identification that is on your display:
    17003
  35. Replies
    3,765
    Views
    389,135

    @el_supremo Thanks for the code - I was looking...

    @el_supremo
    Thanks for the code - I was looking at this one to port - but much more complicated: https://github.com/marczych/RayTracer/tree/master/src
  36. @KurtE - @defragster @defragster - was just...

    @KurtE - @defragster

    @defragster - was just letting you know what I had to get it to work. Anyway I just retry mine with the latest updates and this is what I am seeing:

    16998

    Not sure why...
  37. @defragster - that looks exactly like my screen...

    @defragster - that looks exactly like my screen with the exception that touchscreen worked :) I don't have to use the full constructor though to get it to work.
  38. Replies
    3,765
    Views
    389,135

    Ok you peaked my interest - starting to play with...

    Ok you peaked my interest - starting to play with 3d graphics and ray tracing for the T4 - what lib did you port? Started discussing here:...
  39. @Frank B - haven't done 3d graphics since my...

    @Frank B - haven't done 3d graphics since my college days and that was on Apollo computers, IBM360 and PDP11's and of course TRS80 - yes I am old :) So with the T4 going to have some fun. Found a...
  40. @KurtE Just can't help yourself :) Ready to...

    @KurtE

    Just can't help yourself :)

    Ready to do 3d graphics on the T4 and adding to the libs: http://crawlingrobotfortress.blogspot.com/2015/12/, Better 3D graphics on the Arduino: avoiding...
  41. Just tried it and it does work - my colors are...

    Just tried it and it does work - my colors are just off compared to what you have = but that may be my display.
  42. To be honest - I believe so. I should go back to...

    To be honest - I believe so. I should go back to my eigen sketch and rerun it with debug_tt included.

    <edit> but I haven't lost usb except for this sketch in a very long time. Eigen threw it...
  43. Replies
    3
    Views
    144

    @TelephoneBill Hey man - still got one of...

    @TelephoneBill

    Hey man - still got one of those - but didn't start using it in earnest until 1972. Think at that time it was made by K&E as opposed to PRJC :)
  44. Replies
    3,765
    Views
    389,135

    @PaulStoffregen (@KurtE, @defragster) If you...

    @PaulStoffregen (@KurtE, @defragster)

    If you look at the scenario's from what I was doing as well as @KurtE and @defragster, I am seeing the following if I load uncanyeyes on a clean T4 (did a 15s...
  45. @defragster You will need the latest core,...

    @defragster

    You will need the latest core, Kurt's modified Adafruit_GFX library and latest SPI with the writeRect PR (still open). The uncannyeye sketch is in post #353.

    To duplicate load up...
  46. @KurtE Kedei: Think with the Kedei it started...

    @KurtE

    Kedei: Think with the Kedei it started off with the challenge of just getting it working now we just cant help ourselves. :)

    I downloaded your last GitHub - I hope - but my colors are...
  47. @KurtE Here is the exact sketch that I am...

    @KurtE

    Here is the exact sketch that I am using. Problems occur when you comment out @defragster's debug_tt.

    16977
  48. @degragster - @KurtE Yep - got the old screen...

    @degragster - @KurtE

    Yep - got the old screen finally working. New I think I put 5v to one of the other pins by accident and may have fried the chip.

    Runs nice but backlight I very bright...
  49. @KurtE Gave up the RPI display - cant get a...

    @KurtE

    Gave up the RPI display - cant get a damn thing displaying on it. Even tried it on the T3.6. Even tried using pin 9 for CS. I also reinstalled Arduino IDE 1.8.9 and the latest...
  50. @defragster - @KurtE Tried that as well when I...

    @defragster - @KurtE

    Tried that as well when I saw it but no luck - nothing displays.

    But something looks funny with the LA dump I made:
    16975

    and still nothing on the display - have no...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4