Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: wwatson

Page 1 of 7 1 2 3 4

Search: Search took 0.01 seconds.

  1. Replies
    3
    Views
    221

    @luni - This great:) I just got my MSC working in...

    @luni - This great:) I just got my MSC working in a non-blocking way using the EventResponder, Circular_Buffer and IntervalTimer. I originally had them inside massStorageDriver.cpp but found out that...
  2. Replies
    186
    Views
    16,962

    Thanks for the response. I actually have it...

    Thanks for the response. I actually have it working with one transfer just to test. I am using this structure for each data read or write.

    typedef struct {
    uint8_t type = NO_RD_WR; // Used for...
  3. Replies
    186
    Views
    16,962

    @tonton81 - I have started experimenting with...

    @tonton81 - I have started experimenting with your circular_buffer library. I spent the day learning how to use it with MSC using your FlexCAN_t4 library as a guide for implementing it. There is a...
  4. Replies
    13
    Views
    572

    WOW! and I though this was bad: 21543 I...

    WOW! and I though this was bad:

    21543

    I guess you have it all indexed:)
    I don't feel so bad now. That is a lot of stuff. Makes me appreciate what you really do:)
  5. Replies
    9
    Views
    286

    @KurtE - Sorry for this late reply. I did do the...

    @KurtE - Sorry for this late reply. I did do the pull request. Tested all of the examples and came up with the results you and @mjs513 did. Everything works. The font examples I still have to...
  6. Replies
    325
    Views
    9,663

    I hope to have time to test this weekend. I am...

    I hope to have time to test this weekend. I am really curious how works on my 10.1" display. As far a rotation with putPicture() goes probably need to study the guru's code before I can even begin to...
  7. Replies
    325
    Views
    9,663

    @blackketter - I created a second branch in the...

    @blackketter - I created a second branch in the Ra8876LiteTeensy repository the link is here:

    https://github.com/wwatson4506/Ra8876LiteTeensy/tree/Ra8876LiteTeensy-ER-TFTM0874

    Even though I do...
  8. Replies
    325
    Views
    9,663

    Sorry about the backtrack. I think that maybe I...

    Sorry about the backtrack. I think that maybe I need to create a separate branch for testing with the ER-TFT0784 to keep things pure for us that do not have that particular display. I have downloaded...
  9. Replies
    14
    Views
    393

    If you look at the line that says fatal error: ...

    If you look at the line that says fatal error: you are missing the f
    oward slash between "c++" and "config.h". The compiler thinks "c++config.h" if a filename.
  10. Replies
    325
    Views
    9,663

    Decided to upload my working version. Please let...

    Decided to upload my working version. Please let me know if things are working correctly. Then I will do pull requests. Everything you guys have done is working on my display with all examples. No...
  11. Replies
    325
    Views
    9,663

    I done a bad thing again didn't I? Can I revert...

    I done a bad thing again didn't I? Can I revert back to my original library through GitHub or do I need to upload my working version of it and then go from there?
    Sorry for any inconvenience I...
  12. Replies
    325
    Views
    9,663

    @kurtE, @mjs513, @blakketter - I did the pull...

    @kurtE, @mjs513, @blakketter - I did the pull requests. I have not had the time to test yet. I have to back up the original library locally because of the the issues with the scroll function that I...
  13. Replies
    325
    Views
    9,663

    I have updated my GitHub repository. Hope it...

    I have updated my GitHub repository. Hope it works with your displays.

    Headed for work now:(
  14. Replies
    325
    Views
    9,663

    @mjs513 - I have other than the VT100 sketch...

    @mjs513 - I have other than the VT100 sketch working + others on my setup. Can't test the touch screen because mine is not cap touch. I had to make a few changes to make all of the sketches work and...
  15. Replies
    102
    Views
    6,515

    @vjmusik - Dang me! I did not realize your update...

    @vjmusik - Dang me! I did not realize your update for NativeEthernet was 07/02/2020. I thought the update was included in the release of TD 1.53. Off buy one again which was 07/01/2002:)

    Anyway,...
  16. Replies
    102
    Views
    6,515

    Having what I believe is the same problem....

    Having what I believe is the same problem. Working on the Arduino FTP server I am losing packets from server to client if the file size is > 512 bytes. If transfer from client to server there is no...
  17. Replies
    102
    Views
    6,515

    @All - SUCCESS! I now have the T4.1 version of...

    @All - SUCCESS! I now have the T4.1 version of Arduino-Ftp-Server giving me directory listings using FileZilla and gFTP. The library is using NativeEthernet, Arduino-Ftp-Server, Arduino-FatLib, ...
  18. Replies
    158
    Views
    3,903

    @mjs513 @defragster - Got my chips today. Ready...

    @mjs513 @defragster - Got my chips today. Ready to see if I can solder up and test. I have one more T4.1 and the T4.1 beta test board to play with. My humidity Indicator was blue - never seen this...
  19. Replies
    102
    Views
    6,515

    @manitou @vjmuzik - Have lwip_ftpd and...

    @manitou @vjmuzik - Have lwip_ftpd and lwip-ftpd-sd working with NativeEthernet. I originally had this Arduino FTP server working with the T3.6 and WIFISpi....
  20. Replies
    102
    Views
    6,515

    @manitou - Again thanks for responding. You...

    @manitou - Again thanks for responding. You pointed me to a lot of info. I have worked through all of @vjmuzik's FNET examples and tftpd with success. Now to checkout lwIP.

    So many things to...
  21. Replies
    102
    Views
    6,515

    Thanks for responding. I think I will start...

    Thanks for responding. I think I will start playing with the Arduino FTP server program I found and maybe even the ones I used with wifispi. There are some others that I was checking out but never...
  22. Replies
    102
    Views
    6,515

    @vjmuzik - I added the Ethernet kit to my T4.1's...

    @vjmuzik - I added the Ethernet kit to my T4.1's and tested with this library. All works well. Can you recommend a good FTP library to use. On my T3.6 I was using the Adafruit ESP8266 huzzah board...
  23. Replies
    158
    Views
    3,903

    @mjs513 - Can you give me the exact part number...

    @mjs513 - Can you give me the exact part number for the NAND chip you are using? When I looked it up I saw that there were at least three different package types available and I want to make sure...
  24. Replies
    797
    Views
    40,580

    @All - just to let you know I touched up the...

    @All - just to let you know I touched up the soldering job on the extram chips on the one T4.1 board that I was having a problem with. That fixed the the issue I was having with having to add delay's...
  25. Replies
    325
    Views
    9,663

    @All - Worked on several example sketches today....

    @All - Worked on several example sketches today. piptest.ino, scroll.ino and MemoryTransfer.ino. These are working now. MemoryTransfer.ino was just a problem with setup(). Had to do with Serial...
  26. Replies
    325
    Views
    9,663

    @mjs513 - Here is a sketch to demonstrate the...

    @mjs513 - Here is a sketch to demonstrate the issue with drawRect() and printStatusLine().


    #include "Arduino.h"
    #include "RA8876_t3.h"

    #include <math.h>

    #define RA8876_CS 10
    #define...
  27. Replies
    325
    Views
    9,663

    Got it. That was the difference. Completely...

    Got it. That was the difference. Completely missed the fact that you were using graphic fonts. Right now I am working with piptest.ino. Discovered a conflict between drawRect() and printStatusLine()....
  28. Replies
    325
    Views
    9,663

    I did the PR and am playing with the example...

    I did the PR and am playing with the example sketches right now. It blows me away the way you guy's redid the library. It is going to be fun working with a quality library. I did not realize you had...
  29. Replies
    325
    Views
    9,663

    @mjs513, @Kurte - I just got back to...

    @mjs513, @Kurte - I just got back to Ra8876LiteTeensy today. I have been going through all of the work that you guy's did trying to reorient myself to the changes. Did not realize all of the work you...
  30. Replies
    31
    Views
    2,147

    @Silverlock - The other build did not work. I...

    @Silverlock - The other build did not work.
    I think you both are right. I will touch up the soldering and see what happens. I have two more T41's and more psram chips to solder up and test. Will...
  31. Replies
    31
    Views
    2,147

    @Silverlock, Thanks for the the download. I...

    @Silverlock,

    Thanks for the the download. I will upload and test without my mod's to startup.c. I do not have a windows machine so this will help verify the validity of the Linux compiler.
    ...
  32. Replies
    31
    Views
    2,147

    @defragster, @Silverlock, I am running a...

    @defragster, @Silverlock,

    I am running a 600MHz, Optimize Fast, psram purchased directly from PJRC. I have done further testing and found some interesting results.

    Instead of this modification:...
  33. Replies
    31
    Views
    2,147

    Thanks for checking. Will wait for results.

    Thanks for checking. Will wait for results.
  34. Replies
    31
    Views
    2,147

    Linux Ubuntu 18.04.1 Installed on Ardunio...

    Linux Ubuntu 18.04.1

    Installed on Ardunio 1.8.13. So far everything is working well. The only thing I have trouble with is running teensy41_psram_memtest.ino. It still fails unless I modify...
  35. @ftrias - This is so awesome!! It all comes up...

    @ftrias - This is so awesome!! It all comes up and works:) The gdbgui pops up in my Firefox browser after compiling and when I type in step in the command line I see 'mark =' values increasing in the...
  36. Thanks for the link. I will definitely check this...

    Thanks for the link. I will definitely check this out. I remember using 'DDD' as front end to GDB. I also remember using 'make' from within GDB.
  37. I have it working now and changed the terminal...

    I have it working now and changed the terminal program from xterm to mate-terminal in 'teensy_debug'. My eye's need bigger fonts:)
    Anyway it's working and now have to refresh my memory on using gdb....
  38. Thanks for the work around. That worked:)

    Thanks for the work around. That worked:)
  39. @ftrias - Having problems installing TeeensyDebug...

    @ftrias - Having problems installing TeeensyDebug on My Linux laptop.Using Ubuntu 4.4.0. Running './install-linux.sh -i=/home/wwatson/arduino-1.8.13' I got this:


    wwatson@wwatsonl1:~/TeensyDebug$...
  40. Thanks @defragster - I understand now. I am...

    Thanks @defragster - I understand now. I am seeing the 'mark' variable changing values. This brings back cool memories:)
  41. OK I am really embarrassed here:( I was using gdb...

    OK I am really embarrassed here:( I was using gdb with the Motorola 68332 back in the 90's and cannot remember how it all worked. I was part of the EFI332 forum which used the 68332 for a fuel...
  42. Replies
    22
    Views
    646

    Probably the easiest way would be to use the...

    Probably the easiest way would be to use the example programs in the USBHost_t36 library. Maybe try a USB keyboard or mouse.

    Edit: I would be interested this. Looks like it take minimal soldering...
  43. Replies
    8
    Views
    258

    Just had it happen on one of my three Linux...

    Just had it happen on one of my three Linux machines. Backed up the original .arduino15 folder and restarted arduino-1.8.12 with no problem. I use the laptop more than the two desktops and that is...
  44. Replies
    390
    Views
    19,421

    All - Finally got back to working with MSC. In...

    All - Finally got back to working with MSC. In particular trying to speed up write speeds. I have been experimenting with queuing an array of transfers and was hitting a road block with queuing the...
  45. Replies
    325
    Views
    9,663

    I did miss that. If choosing a random number...

    I did miss that. If choosing a random number between 0 and 1023 for width you would not need to subtract 1 from the width. The other thing that pop's into my mind is if the random(...) function would...
  46. Replies
    325
    Views
    9,663

    Thank you for the link. Everything you guys have...

    Thank you for the link. Everything you guys have done so far seems to be working on my display as well at what appears to be 50 MHz. Cool:)

    I am running 'grahpics.ino' and anything to do with...
  47. Replies
    325
    Views
    9,663

    @mjs513 and @ KurtE - I need a little direction...

    @mjs513 and @ KurtE - I need a little direction here. I am so easily confused:) Who's branch of Ra8876Teeny should I be pulling from to keep up with you guy's? I have to take a break from MSC for a...
  48. It all works but on power up of a PC with thumb...

    It all works but on power up of a PC with thumb drive connected to a T4.0 through a HUB the T4.0 hangs in the HUB part of initialization.What you have to do is unplug the T4.0 from the PC after the...
  49. I actually have not tried it with a powered HUB...

    I actually have not tried it with a powered HUB yet. I was using a Belkin and another no name brand HUB that works with the T4.1. The T4.0 board I was testing with was @Paul's original beta breakout...
  50. Replying to my own thread because it was to late...

    Replying to my own thread because it was to late to edit it. Come to find out the problem does not happen on the T4.1. Only the T4.0.
Results 1 to 50 of 305
Page 1 of 7 1 2 3 4