The GUI-based Teensy Loader is not compatible with Raspberry Pi.

The command line version can work on Raspberry Pi, but the officially released version only supports Teensy 2.0.

Here is an...