Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. Replies
    9
    Views
    339

    Looking the schematic I see that you have...

    Looking the schematic I see that you have MISO/MOSI shared between the touch and LCD. Can't remember but you may have a tristate buffer issue. Take a look at step 2 of PJRC's Better SPI Bus Design...
  2. Replies
    401
    Views
    5,557

    @Paul - @KurtE The more I read the more confused...

    @Paul - @KurtE
    The more I read the more confused I get. Was looking at AN12686, pg13 and what @KurtE was DMA stuff. On pg 13 for DMA setup the last 2 bullets:

    • Last destination address...
  3. Replies
    401
    Views
    5,557

    @defragster Going to put the timings back in...

    @defragster
    Going to put the timings back in since I know what to expect now.

    Was driving me crazy when it FPS going down to 16 but think that was display connection issue
  4. Replies
    401
    Views
    5,557

    Set up releases for the library and that code is...

    Set up releases for the library and that code is permanently there as Release v1.0.0. The flexIO changes will be in v1.1 I guess. Just trying to keep what works.
  5. Replies
    401
    Views
    5,557

    @defragster Also think the timing prints were...

    @defragster
    Also think the timing prints were getting me confused. Also playing with some settings for brightness and exposure. With the lights on my image tended to be basically showing glare. ...
  6. Replies
    401
    Views
    5,557

    @defragster Think I was running into the...

    @defragster
    Think I was running into the problems you just described plus issues with the display connections.

    Also I changed the "F" movie function to this


    if ( g_continuous_flex_mode )...
  7. Replies
    401
    Views
    5,557

    As they say keep dreaming :) Just tried it on...

    As they say keep dreaming :)

    Just tried it on the ST7789 and seems to be working there as well. Although trying to use for video don't work too well. Works a bit better on 9341. Think maybe it...
  8. Replies
    401
    Views
    5,557

    Think I agree - doesn't make sense to keep DMA...

    Think I agree - doesn't make sense to keep DMA using GPIO. To be honest I would hold off on trying to get it working with GPIO for the HM01b0
  9. Replies
    401
    Views
    5,557

    @PaulStoffregen Was going through your DMA code...

    @PaulStoffregen
    Was going through your DMA code (you guys are bringing me down another rabbit hole with DMA) :)

    Anyway think this is the function that controls dma h/w trigger:

    // Use a...
  10. Replies
    401
    Views
    5,557

    Thats strange, I only get that when my pin...

    Thats strange, I only get that when my pin assignment is off - know this is going to be a silly question but did you remember (1) to change the pin assignments in the graphicstest, and (2) make sure...
  11. Replies
    401
    Views
    5,557

    Here's what I am using as of this morning after...

    Here's what I am using as of this morning after your changes:

    24424
  12. Replies
    401
    Views
    5,557

    PR was merged. Just downloaded it and see what...

    PR was merged. Just downloaded it and see what you mean. Started reading FlexIO once :) Guess I will have to pull the manual out again.

    For some reason having trouble with @defragsters sketch -...
  13. Replies
    401
    Views
    5,557

    Merge done.

    Merge done.
  14. Replies
    401
    Views
    5,557

    @Paul - @KurtE - @defragster Did a couple more...

    @Paul - @KurtE - @defragster
    Did a couple more tests with FlexIO.
    Test 1: Tried changing the frameRate from 30fps to 60fps. At 30 "F" (flexIO continuous) using @defragster's updated sketch, runs...
  15. Replies
    401
    Views
    5,557

    Morning All Merged the changes into the github...

    Morning All

    Merged the changes into the github repository and just start playing but my display is acting up - wire connections with jumpers Argh!

    Anyway ran 'f'lexio using Sparkfun and...
  16. Was thinking that maybe need to lower the SPI...

    Was thinking that maybe need to lower the SPI Clock setting
  17. Replies
    401
    Views
    5,557

    Was just about to post - but the other one should...

    Was just about to post - but the other one should have worked as well. Going to delete it - probably easier that figuring out the differences.
  18. Replies
    401
    Views
    5,557

    Should just need ILI9341_t3n library. 's' is...

    Should just need ILI9341_t3n library. 's' is pretty standard and seems to have always worked. The latest TMM-HB01B0-Camera is set up for 324x224 but 's' works for Sparkfun or non-Sparkfun configs. ...
  19. Replies
    401
    Views
    5,557

    Probably not the problem but wanted to ask. In...

    Probably not the problem but wanted to ask. In the .h file

    enum {DMABUFFER_SIZE=1280}; // 640x480 so 640*2*2

    the 1280 probably needs to be changed to 324*2*2 = 1296
  20. Replies
    401
    Views
    5,557

    Cool. Sounds like you had fun planting - rainy...

    Cool. Sounds like you had fun planting - rainy and cold here so good day to stay inside.
  21. Replies
    401
    Views
    5,557

    Just tested the mods I just made and it works :) ...

    Just tested the mods I just made and it works :) You want me to push it to you or you can just use what you have - probably the same since I just copied it from ILI9341_t3n
  22. Replies
    401
    Views
    5,557

    Just made the changes for 8 and 4 and was going...

    Just made the changes for 8 and 4 and was going to try out - should have known better :)

    EDIT: Is it posted - I will give it a try
  23. Replies
    401
    Views
    5,557

    @KurtE Looks like we are going to have to edit...

    @KurtE
    Looks like we are going to have to edit the ST7789 library to add in read8pp as well since I don't think it currently supports it.
  24. Replies
    401
    Views
    5,557

    Easy answer - yes. See page 16.

    Easy answer - yes. See page 16.
  25. Replies
    401
    Views
    5,557

    That was the change from last night and this...

    That was the change from last night and this morning. So yes first 2 pixels and last 2 pixels.

    Edit:
    Kurt's original DMA code skipped the 1st 4 pixels and what I went to this morning was using...
  26. Replies
    401
    Views
    5,557

    With the change that Kurt made to the 's' decided...

    With the change that Kurt made to the 's' decided to see if the other frameSizes would work as well:

    /*
    * FRAMESIZE_INVALID = 0,
    * VGA Resolutions
    * FRAMESIZE_QQVGA, // 160x120
    ...
  27. Replies
    401
    Views
    5,557

    @Paul Very cool that you got some life with...

    @Paul
    Very cool that you got some life with using FlexIO. Was looking at Kurt's lib this morning and my head hurt :). Oh just one thing the 4pixels is a 2 pixel border around the actual 320x240...
  28. Replies
    401
    Views
    5,557

    Yeah was going way deeper originally to see what...

    Yeah was going way deeper originally to see what was going on so started with Vsync. Want to see what you did and see I can merge but really distracted. I did remember to update the PDE to 324/244...
  29. Replies
    401
    Views
    5,557

    @KurtE Updates are already pushed to repository,...

    @KurtE
    Updates are already pushed to repository, see post 342, right before yours.

    99% sure that the writeSubImageRect is working correctly because I am now using it for 's'napshot and...
  30. Replies
    401
    Views
    5,557

    Just pushed the current changes using...

    Just pushed the current changes using subWriteRect and QVGA = 324x244. One other thing - took setpixformat out of the sketch and called it directly from init since this camera only supports...
  31. Replies
    401
    Views
    5,557

    Morning @KurtE Yep - tried just making...

    Morning @KurtE

    Yep - tried just making _frame_ignore_cols = 0 but the image messed up. Agree - not sure why you are multiplying by 2 since we only have grayscale. The *2 in the original...
  32. Replies
    401
    Views
    5,557

    @KurtE I found the issue that you were having...

    @KurtE

    I found the issue that you were having with having to skip 4 pixels. Turns out that the actual image size for QQVGA is 324x244 and not 320x240. The extra 4 pixels seem to be just border...
  33. Replies
    401
    Views
    5,557

    @KurtE - @Paul - @defragster - @all More...

    @KurtE - @Paul - @defragster - @all
    More discoveries, realizations and decisions.

    Doing some digging it appears that the framerate is dependent on 3 settings:
    1. clock - osc_div which is done...
  34. Replies
    401
    Views
    5,557

    Just to satisfy my curiosity I put back into the...

    Just to satisfy my curiosity I put back into the loop Paul's vsych timing code and sure enough, whatever combination of settings Sparkfun is using seems off:

    Using the 6Mhz clock and only changing...
  35. Replies
    401
    Views
    5,557

    Did a little bit more testing and one thing I...

    Did a little bit more testing and one thing I noticed is that the framerate when set to 60 seems alot slower using the Sparkfun config rather than the default config. With the default config the...
  36. Replies
    401
    Views
    5,557

    Found it. 3, 0xb1, 0x00, 0x10, // FrameRate...

    Found it.

    3, 0xb1, 0x00, 0x10, // FrameRate Control 119Hz its in both the ILI8341_t3 and _t3n libraries.
  37. Replies
    401
    Views
    5,557

    Hi all @KurtE beat me to it - was going to...

    Hi all
    @KurtE beat me to it - was going to mention that @KurtE did a lot of work with FlexIO and he a library set up for it - not sure where the whole discussion is on the forum anymore

    I'll...
  38. Replies
    401
    Views
    5,557

    @KurtE Can't seem to push the SPI Clock over...

    @KurtE
    Can't seem to push the SPI Clock over 30Mhz for the ILI9341 - just shows a white screen if I do. Just an FYI
  39. Replies
    401
    Views
    5,557

    I'll go ahead and push the changes I have so we...

    I'll go ahead and push the changes I have so we will in synch again. then you can change the handshake. You know never thought about about how fast the screen can update. Don't remember what SPI...
  40. Thanks for the info and update

    Thanks for the info and update
  41. Replies
    401
    Views
    5,557

    @KurtE Changed 2 settings in the default config...

    @KurtE
    Changed 2 settings in the default config and DMA seems to be working without using the Sparkfun:


    {FS_60HZ_L, 0x85},
    {FS_50HZ_L, 0xa0}, Give it a try and...
  42. Replies
    401
    Views
    5,557

    Just merged your PR but looks like DMA mode got...

    Just merged your PR but looks like DMA mode got worse when not using Sparkfun registers.
  43. Replies
    401
    Views
    5,557

    Was actually thinking about something like that...

    Was actually thinking about something like that last night but seems you beat me to it:)

    Anyway's just did a quick experiment and think the MCLK clock has something to do with it. For the...
  44. @Frank B Ok - I know I can't answer this but...

    @Frank B
    Ok - I know I can't answer this but curious since I have no idea what it means. Think you are saying that what lib is included its using software to calculate integer divisions when T4...
  45. Replies
    401
    Views
    5,557

    Nice comparison @KurtE. From the lib I know what...

    Nice comparison @KurtE. From the lib I know what some of those settings are and some get changed with the function calls:

    INTEGRATION_H(202) 2(2) 1(1)
    INTEGRATION_L(203) 133(85) 2(2)...
  46. Replies
    401
    Views
    5,557

    Was wondering why you set it up to have its own...

    Was wondering why you set it up to have its own namespace. Is there anyway to do that with in the core. Reason asking it would be simpler than have to add the files to every library or sketch? ...
  47. Replies
    401
    Views
    5,557

    Morning @KurtE Actually thought about it but...

    Morning @KurtE
    Actually thought about it but forgot. Remember what they say about assume.

    UPDATE: It works:

    Acc [mg]: 21.0 x, -37.0 y, 1055.0 z, 27.5C
    Acc [mg]: 21.0 x, -34.0 y, 1059.0 z,...
  48. Replies
    401
    Views
    5,557

    Good luck with FlexIO for the camera - assuming...

    Good luck with FlexIO for the camera - assuming you mean the 4bit FlexIO? Are you trying it with the library or started it with your initial test sketch - going to assume your initial sketch? If...
  49. Replies
    401
    Views
    5,557

    Was testing a couple more things: 15s Restore: ...

    Was testing a couple more things:
    15s Restore: Works - tested both on the ATP and ML boards.

    Quad Encoder Library: Finally got a chance to test change I made to the T4 Quad Encoder library...
  50. Replies
    401
    Views
    5,557

    On a different note from the HB01B0 camera. Was...

    On a different note from the HB01B0 camera. Was looking at what @luni did and looking at the pins_arduino.h file and was wondering if it would worth it to add @luni's pinouts to the pins_arduino.h...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4