Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.04 seconds.

  1. Replies
    20
    Views
    291

    @ckmiauto What I put together was a kludge to...

    @ckmiauto
    What I put together was a kludge to see where the problems could be. They changes resolve the SYMPTOMS but not the underlining issue. The issue I think lies in the interface itself...
  2. Replies
    20
    Views
    291

    Morning All Think last post on this until @KurtE...

    Morning All
    Think last post on this until @KurtE gets one and tries it out. I did one more update tightening the delayMicroseconds in the sendpacket and receivepacket funtions and raw data sketch...
  3. Replies
    20
    Views
    291

    @KurtE and others Attached is the updated .CPP...

    @KurtE and others
    Attached is the updated .CPP file for the library. I just tested some of the other example sketches and the only one I am able to get to work is the rawdata one as shown in the...
  4. Replies
    20
    Views
    291

    That Qwiic is beginning to grow on me. I picked...

    That Qwiic is beginning to grow on me. I picked up one of the qwiic to dupont connector and works nice. As for the BNO080. Think I got it working. Not sure if its a problem with I2c or the how I2c...
  5. Replies
    20
    Views
    291

    One more note there is a mbed library as well...

    One more note there is a mbed library as well that would like to go over as well: https://os.mbed.com/users/MultipleMonomials/code/BNO080/
  6. Replies
    20
    Views
    291

    I made a slight modification to your sketch to...

    I made a slight modification to your sketch to see if it would get through:



    #include <Wire.h>

    TwoWire *_i2cPort;

    uint8_t _deviceAddress;
  7. @KurtE Cool that you got FlexIO Serial working. ...

    @KurtE
    Cool that you got FlexIO Serial working. I read that section a couple of times and still gets me confused. :) Nothing new :)

    Yeah - FlexCAN seems to need LPUART enabled to work for some...
  8. Try reducing the SPI clock in the ILI9341_t3n...

    Try reducing the SPI clock in the ILI9341_t3n lib, think its configure for #define ILI9341_SPICLOCK 600000000u, try reducing it to 20Mhz as a start. Forgot what I had it set at.
  9. Replies
    20
    Views
    291

    Yep you are right - got confused looking at the...

    Yep you are right - got confused looking at the code on my phone.

    I did just order one from Amazon but wont have it until Sunday now.
  10. I have a hacked up version that I did to get this...

    I have a hacked up version that I did to get this working: https://www.youtube.com/watch?v=Fp0MW_M013o It does use @KurtE's ILI9341_t3n library.
  11. Just tested your non-mailbox sketch going from...

    Just tested your non-mailbox sketch going from CAN3 to CAN3 in legacy mode and seems to be sending the data without an issue. This is what I am getting on the receiving T4:

    MB 99 LEN: 8 EXT: 0...
  12. @KurtE I loaded up the interrupt SDK example on...

    @KurtE
    I loaded up the interrupt SDK example on the 1062EVKB and saw a couple of things. First, the way the sdk is set up is it transmits on one pin and recieives on another. So I hooked up the...
  13. @KurtE Confused is the normal state for me :) ...

    @KurtE
    Confused is the normal state for me :) Guess I will have to go back to the manual and bounce the two off each other. Either that or I can run the SDK interrupt example on the 1062EVKB and...
  14. Replies
    7
    Views
    211

    @RichardG - have you thought about porting your...

    @RichardG - have you thought about porting your changes over to the existing Wire library so there are not 2 I2C libraries?
  15. Replies
    20
    Views
    291

    Looking at the i2c commands in the getData and...

    Looking at the i2c commands in the getData and sendPacket functions of the library you might have to modify the code to use beginTransaction and endTransaction commands instead of...
  16. I converted that piece from the SDK code frag I...

    I converted that piece from the SDK code frag I posted:
    kFLEXIO_UART_TxDataRegEmptyFlag & status. In the SDK its was specified as
    kFLEXIO_UART_TxDataRegEmptyFlag = 0x1U, /*!< Transmit buffer...
  17. @KurtE Started playing again this morning and I...

    @KurtE
    Started playing again this morning and I did add a couple more debug prints to your callback function. In the SDK it has this as a test:

    /* Send data register empty and the interrupt...
  18. Thread: TeensyCAN

    by mjs513
    Replies
    3
    Views
    171

    Nice work Tony.

    Nice work Tony.
  19. Yeah, that's kind of what I wanted to check. It...

    Yeah, that's kind of what I wanted to check. It is strange. Its almost like you have to flush the last character or send a 0xff or 0x00 just to complete the sequence - think I saw that someplace but...
  20. @KurtE Know this is going to sound strange but...

    @KurtE
    Know this is going to sound strange but could you put you LA on it again using these prints:

    SerialFlex.print ("Flex112345");
    SerialFlex2.print("Flex2 More");
    …...

    ...
  21. @KurtE Have to go do a couple of errands -...

    @KurtE
    Have to go do a couple of errands - didn't get a chance to test if the same thing happens on other pins as well. I assume you did though knowing you. :)
  22. Replies
    20
    Views
    291

    Know this is going to sound obvious - but did you...

    Know this is going to sound obvious - but did you to change wire.setClock to 100000? Just as a test. Also are you using the latest Teensyduino 1.48 - Paul did put some fixes in for the issue with...
  23. Morning @KurtE Been playing the lib most of the...

    Morning @KurtE
    Been playing the lib most of the morning. Reading = checking - trying and just can't see why it continues to send. Unless when you test for head = tail in the write you have to zero...
  24. Evening @KurtE Thanks - just updated the lib. ...

    Evening @KurtE
    Thanks - just updated the lib. Started looking though the manual and the flex-uart example from the SDK for starts - then tomorrow will play more.

    I did put a scope on pin 3 of...
  25. Not for me - usually helps more with the...

    Not for me - usually helps more with the debugging.

    Yeah - DELEETED my error -------------- Like I said - have to read or at least skim FlexIO chapter of the manual.

    Thanks much appreciated...
  26. Here is part 2. If I try T=1 and S=0 on pin 5...

    Here is part 2. If I try T=1 and S=0 on pin 5 and sending HI

    pin 3 maps to: 20000b30, port: 401ac000(FLEXIO1) pin 5
    timer index: 0 shifter index: 1 mask: 2
    Before configure flexio
    CCM_CDCDR:...
  27. @KurtE Have a question for you on how FlexIO...

    @KurtE
    Have a question for you on how FlexIO works. Using T=0 and S=1. I will see what I guess you would expect jumping pin 3 to pin 0:

    pin 3 maps to: 20000b30, port: 401ac000(FLEXIO1) pin 5...
  28. That should be simple enough for nxp :)

    That should be simple enough for nxp :)
  29. @KurtE Now that I am up and running again and...

    @KurtE
    Now that I am up and running again and looking at the output I am getting confused on the pin mapping. If I am reading this right you are using pins 6, 18 and 19?
    On the output I am seeing:...
  30. Just starting to play with this now - have to go...

    Just starting to play with this now - have to go through it somewhat. The last character is getting me. This is just me walking through and then for debugging - it Tx's the right characters until...
  31. @KurtE - this was the post I was referencing...

    @KurtE - this was the post I was referencing about FlexIO3: https://community.nxp.com/thread/514359

    EDIT: I just downloaded your latest repository and gave you sketch a try along with the change...
  32. Replies
    100
    Views
    2,667

    @KurtE - @manitou @KurtE - I went ahead and...

    @KurtE - @manitou

    @KurtE - I went ahead and updated the Readme with the added info to match what you have in your readme which is a good idea.

    @manitou - very cool that you got down counting...
  33. Replies
    100
    Views
    2,667

    UPDATE: Incorporated the changes into the...

    UPDATE:

    Incorporated the changes into the pulseposition main lib using the approach that @KurtE suggested. Gave it a quick spin and test using the loopback example with no problem. I issued a PR...
  34. Replies
    100
    Views
    2,667

    @KurtE - @manitou …. Just finished testing. ...

    @KurtE - @manitou ….

    Just finished testing. Had a slight bug for implementing framePin but all is good now. Want to change digitalWrites to digitalWriteFast for final version.

    Also I just...
  35. Replies
    100
    Views
    2,667

    @KurtE Will go the route u suggest, better that...

    @KurtE
    Will go the route u suggest, better that way.

    Have a couple more tests to run
    (1) frame pin and
    (2).rising and falling for polarity

    Know polarity works for tx cause I had a scope on...
  36. Replies
    100
    Views
    2,667

    Shoot - forgot about that we everything else...

    Shoot - forgot about that we everything else going on - working it now.

    EDIT: Done:

    18052

    Still have to test but off for an errand now will do when I get back.
  37. Replies
    100
    Views
    2,667

    Well that's 2 major things that are errors within...

    Well that's 2 major things that are errors within the 1060! This and flexcan-FD FIFO.

    At least we know it wasn't something we all were doing wrong.
  38. Replies
    100
    Views
    2,667

    @KurtE Wow - I just back on the computer and...

    @KurtE

    Wow - I just back on the computer and its all done :)

    Just did a couple of tests. (1) using 2 T4's all pins are receiving and transmitting (only tested 3 really)… The receive pins are...
  39. Replies
    100
    Views
    2,667

    @KurtE ;) If you are going to test pin 19...

    @KurtE
    ;)

    If you are going to test pin 19 make sure you add: IOMUXC_QTIMER3_TIMER0_SELECT_INPUT = 0x02; //pin 19 to the begin.

    I just tried - no more hangs but no data showing up either. It...
  40. Replies
    100
    Views
    2,667

    @manitou - tried both ways with no luck - I also...

    @manitou - tried both ways with no luck - I also tried to set it directly with (IOMUXC_SW_MUX_CTL_PAD_GPIO_B0_01) but that didn't work either. Something strange going on or preventing it from...
  41. Replies
    100
    Views
    2,667

    RE: FOUND THE HANG FOR PINS OTHER THAN 11 ...

    RE: FOUND THE HANG FOR PINS OTHER THAN 11

    Hangs on this line:

    //set Mux for Tx Pin - all timers on ALT1
    *(portConfigRegister(rxPin)) = 1;

    Yes I changed pin variable name. Works if you...
  42. Replies
    100
    Views
    2,667

    @manitou - @KurtE That's what I get for...

    @manitou - @KurtE

    That's what I get for playing with this when I can't sleep at 2 in the morning:) Knew it was channel but still put pin, argh.

    Anyway, what to try the input example with...
  43. Replies
    100
    Views
    2,667

    @KurtE Did some experimenting using loopback and...

    @KurtE
    Did some experimenting using loopback and pin 14 for the Rx pin. In our lib I added IOMUXC_QTIMER3_TIMER2_SELECT_INPUT = 0x01; //pin 14 to the begin function and it hung the T4 - then it...
  44. Replies
    100
    Views
    2,667

    Don't need the hint - was looking for the daisy...

    Don't need the hint - was looking for the daisy chain earlier on but when I did the search I didn't come across it - must be losing it in my old age ;)

    EDIT: Not all pins are available for input...
  45. Replies
    100
    Views
    2,667

    @KurtE Been playing.... @KurtE …. See...

    @KurtE
    Been playing....



    @KurtE ….
    See been busy while I was out --- really simplified the code using that base class. Have to digest it a bit more though.

    Just ran a couple of quick...
  46. Replies
    100
    Views
    2,667

    @KurtE and others... I just used the lib to...

    @KurtE and others...
    I just used the lib to setup output on pin 9 in @manitou's original pulsepositioninput sketch. Pin 9 is outputting 600.03 and the sketch is reading 600.08. Heres the sketch for...
  47. Replies
    100
    Views
    2,667

    @KurtE It seems to be better when using T4 -...

    @KurtE

    It seems to be better when using T4 - T4. Just tried loopback as well on 1 T4 with the version I have from this morning with just 1 output frequency and its seems to be always in the 2XXX...
  48. Replies
    100
    Views
    2,667

    @KurtE You and me both :). Keep going through...

    @KurtE

    You and me both :). Keep going through the manual and trying things as I am reading but still confused.

    In one of the earlier messages @manitou wrote:
    Have to digest this one.
    ...
  49. Replies
    100
    Views
    2,667

    Not a problem - tried it both ways and no change...

    Not a problem - tried it both ways and no change in what I am seeing.
  50. Replies
    100
    Views
    2,667

    @KurtE - Makes absolute sense in what you...

    @KurtE - Makes absolute sense in what you propose. Notice we were duplicating that between Input and output.

    @manitou - made the changes in your post.

    Ok. Made one change to the ISR flags...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4