Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: AshPowers

Page 1 of 2 1 2

Search: Search took 0.00 seconds.

  1. T4 w/ ILI9341_t3n: Interrupt Question >>

    As the title states, I'm using the T4 with the ILI9341_t3n driver for a 2.8" TFT.

    I am using Framebuffering.

    My question is: The tft.updatescreen event takes about 27ms to complete.

    I have...
  2. Replies
    6
    Views
    688

    As a follow up to this question.. I have...

    As a follow up to this question.. I have another section of code where I am calculating the torque and horsepower produced by the engine based on the change in vehicle speed over the change in...
  3. Replies
    6
    Views
    688

    T4 - ISR Handling Confusions!

    I'm having a bit of difficulty wrapping my head around what happens when ISRs are used when there is another process which consumes more time than the rate at which ISR triggers are known to be...
  4. Replies
    17
    Views
    1,765

    OK. I changed the digital.c file to include the...

    OK. I changed the digital.c file to include the hysteresis for the pinMode "INPUT" and it works as expected. :)
  5. Replies
    17
    Views
    1,765

    Coming back around to this.. I have not been...

    Coming back around to this.. I have not been able to locate a file by the name you state... pins_digital.c does not exist on my system whatsoever. I've been dealing with the hysteresis issue by...
  6. Replies
    17
    Views
    1,765

    Frank, I figured it would be something along...

    Frank,
    I figured it would be something along those lines as to what the difference is... I just wasn't sure where to look for it.. :)
  7. Replies
    17
    Views
    1,765

    Heh, you must not have much experience with ISRs...

    Heh, you must not have much experience with ISRs then... I'm not the only one having the issue with false ISR triggers.

    I have spent 4 days doing nothing other than studying this problem. Trying...
  8. Replies
    17
    Views
    1,765

    I changed the resistor divider on my circuit to...

    I changed the resistor divider on my circuit to level shift the signal from 0-3.3V. That didn't fix the problem nor did it change the "shape" of the signal other than it was peaking at 3.3V rather...
  9. Replies
    17
    Views
    1,765

    OK Guys, I FINALLY figured out how to completely...

    OK Guys, I FINALLY figured out how to completely eradicate the false triggers on the ISRs... You MUST declare the pinmode with either a PULLUP or PULLDOWN!!

    <code>
    pinMode(REF1, INPUT_PULLUP);...
  10. Replies
    17
    Views
    1,765

    T4.0 ISR Rising Edge Voltage Trigger Level?

    Automotive digital tachometer signal - 0-5v square wave - rising edge at each cylinder TDC on ignition stroke. 6 cylinder engine will produce 3 rising edges per crankshaft rotation (each 4-cycle...
  11. Replies
    4
    Views
    767

    Nevermind, LOL! I got it to work! Thank you...

    Nevermind, LOL! I got it to work! Thank you again!!
  12. Replies
    4
    Views
    767

    THanks for the reply again, Kris! ...

    THanks for the reply again, Kris!

    Unfortunately my simple example fails to work in the actual application. I am wanting a string of text to shade up from black to white on a black background. I...
  13. Replies
    4
    Views
    767

    ILI9341 Color Values / grayscale..

    Hi!

    I'm trying to understand the 0xXXXX color values that are used in this library but not having a lot of luck searching for what I specifically am trying to do.

    As a very simple example: I...
  14. Replies
    6
    Views
    798

    FYI, when using this font maker with the...

    FYI, when using this font maker with the ili9341_t3n library, you MUST go into the "font".h file and change the #include <ILI9341_t3.h> and add in the "n" after the "3"....
  15. Replies
    6
    Views
    798

    When creating a custom font and placing it into...

    When creating a custom font and placing it into my ili9341_t3n library folder with the other fonts used in this project, I get a slew of errors when I compile.. :-(

    <code>

    In file included from...
  16. Replies
    6
    Views
    798

    Is this compatible with the ILI9341-T3N library?

    Is this compatible with the ILI9341-T3N library?
  17. Replies
    6
    Views
    798

    Nevermind. I found it in your youtube page as a...

    Nevermind. I found it in your youtube page as a link on another thread over here on pjrc. :)
  18. Replies
    6
    Views
    798

    Hi Kris! Thanks for the reply, however, when I...

    Hi Kris!
    Thanks for the reply, however, when I go to that website there are only 3 programs available and none of them appear to be something that would do this conversion. :-( Please advise.
    -Ash
  19. Replies
    6
    Views
    798

    ILI9341 Ethnocentric Font

    Hi Guys,

    A search for this font revealed no results and am hoping someone else has this available or can shed some light on how to go about getting this font to work with the ili9341. Finishing...
  20. Replies
    24
    Views
    2,351

    BTW, here is a video of the setup I've built... ...

    BTW, here is a video of the setup I've built...

    https://youtu.be/wk2FauuPKqk
  21. Replies
    24
    Views
    2,351

    I did not give them a file extension so I think...

    I did not give them a file extension so I think that is where the problem came into play... What is the decision making process involved between naming them "*.h" or "*.cpp" files?
  22. Replies
    24
    Views
    2,351

    OK, I split my code out to several different tabs...

    OK, I split my code out to several different tabs and it still worked just fine, no issues. However, after saving this project and then re-opening the IDE and the main .ino file, we have a problem. ...
  23. Replies
    24
    Views
    2,351

    Awesome! Thanks so much for the tips!

    Awesome! Thanks so much for the tips!
  24. Replies
    24
    Views
    2,351

    Well that's new, LOL. I wasn't aware of this. ...

    Well that's new, LOL. I wasn't aware of this.

    How do I make calls to these new tabs from the main code?
  25. Replies
    24
    Views
    2,351

    Do I need to create my own libraries?

    Hi All,

    I have a project using a T4 with a 2.8" TFT w/touch and it is heavily menu driven. The length of the code is stacking up really quick just to create the different screen layouts, touch...
  26. Replies
    4
    Views
    774

    Hi Kurt! I *just* managed to get this all...

    Hi Kurt!

    I *just* managed to get this all working and just saw your message posted, LOL.

    I found that example and tweaked it for my setup and it works wonderfully. The updateScreenAsync(); is...
  27. Replies
    4
    Views
    774

    I'm using the ST7735_t3 library here: ...

    I'm using the ST7735_t3 library here:
    https://github.com/PaulStoffregen/ST7735_t3

    The videotest example code is what I used.

    In setup, I am writing out the top header (AshSPEC and SDT...
  28. Replies
    4
    Views
    774

    T4 w/ST7735 1.44" TFT - Lag time >>>

    Hi,
    I'm running a t4 with the 1.44" ST7735 display via the SPI port. The T4 is being used as a Speed Density Translator in an automotive application to eliminate the MAF and employ a pressure...
  29. Replies
    23
    Views
    3,065

    BTW, this T4 is absolutely killer. :) Speed...

    BTW, this T4 is absolutely killer. :)

    Speed Density Translator that replaces a mass-airflow sensor setup. FAR better air metering stability and complete tunability of fuel delivery. ...
  30. Replies
    23
    Views
    3,065

    tycmd will more than likely suffice for what I...

    tycmd will more than likely suffice for what I need with this product. Thanks!

    I would still like an answer as to what the methodology is to put the T4 into programming mode and how to write to...
  31. Replies
    23
    Views
    3,065

    OK, I have put some time here on the suggestions...

    OK, I have put some time here on the suggestions posted.

    The HEX file export can be opened within the Arduino IDE and the source code is clear as day. When I said "secure" I was referring to not...
  32. Replies
    23
    Views
    3,065

    Teensy 4.0 Secure Firmware Updating

    Hi All!

    I have developed a couple of products based on this device and I would like to make it possible to offer firmware updates for the product that customers can reflash the T4 to enable new...
  33. Teensy 4.0 -> OPEN-SMART 3.0 TFT Parallel IF Driver IC: R61509V

    I purchased this nice 3" TFT, 400X240 with touchscreen:
    https://www.amazon.com/gp/product/B07YC52GDT/ref=ppx_yo_dt_b_asin_image_o00_s00?ie=UTF8&psc=1

    I haven't been able to find any info on a...
  34. Replies
    1
    Views
    692

    Teensy 4.0 & ILI9341_t3n

    I'm running this display on a T4 that I am using interrupts on for timing events, etc.. When using the tft.updateScreen(); function, the amount of time it takes to process is far too long for the...
  35. In an interesting twist, the replacement TFT I...

    In an interesting twist, the replacement TFT I just received actually works with the T4. I changed nothing in the wiring at all - simply removed the original TFT from the breadboard, plugged in the...
  36. Frank, too long? Why does it work just fine with...

    Frank, too long? Why does it work just fine with the T3.5 then?

    As for removing the LEDs, I only put them in there for testing purposes. I have tried it both with and without the LEDs in the...
  37. Replies
    6
    Views
    2,413

    1of9: I'm a little late coming to this thread...

    1of9:

    I'm a little late coming to this thread but it is of direct interest to me as I'm trying to get an ili9341 chipset TFT to work with the T4.

    Do you happen to have an example of your...
  38. Wow. 4/24/19 was the last update on this thread?...

    Wow. 4/24/19 was the last update on this thread?

    What about T4 and ili9341_t3? Is there an ILI9341_t4 I'm missing somewhere?
  39. I have connected my digital analyzer to the 4...

    I have connected my digital analyzer to the 4 main lines to see the difference in signals.

    T3.5
    SCLK: 143KHz stable in the first ~40ms and then it bounces around from 20KHz to 400KHz.

    T4:...
  40. OK, I have put together a video showing my setup....

    OK, I have put together a video showing my setup. I downloaded the library from Paul's GITHUB page here:
    https://github.com/PaulStoffregen/ILI9341_t3

    I removed all other instances of the t3...
  41. You are right, I didnt' see that pin 10 was being...

    You are right, I didnt' see that pin 10 was being used.

    So I changed the pin settings to your recommendation with the T3.5 connected and it works like a champ. I also found that you can hook...
  42. Well, while waiting for the replacement screen to...

    Well, while waiting for the replacement screen to show up I figured I'd connect the T3.5 back in and give it a final test... And behold! The TFT is just fine...

    What a total pain in my arse. ...
  43. You can do that with the T4.0? I thought you HAD...

    You can do that with the T4.0? I thought you HAD to use the only CS pin on the T4, pin 10.

    I gave it a shot using pin 6... No dice...
  44. Additionally, Some odd behavior in the...

    Additionally, Some odd behavior in the graphicstest examples..

    Running the Adafruit ili9341 library, serial monitor reveals this:



    Display Power Mode: 0x4

    MADCTL Mode: 0x48
  45. I have a videos of my rig running on the T3.5...

    I have a videos of my rig running on the T3.5 using the ili9341_t3n library. I was using limiting resistors between the TFT and T3.5 for obvious reason. The new setup simply has the T4.0 in the...
  46. Kurt, I did give your suggestions a try. I...

    Kurt,
    I did give your suggestions a try. I dropped the SPI clock freq to 20^6Hz and still no dice. I also downloaded the beta TDI but from what I Can tell, no changes were made to the ili9341_t3...
  47. I appreciate the help guys. I'm going to order...

    I appreciate the help guys. I'm going to order up another display as I may have damaged this one when wiring it up. It doesn't seem like this should be so difficult and I've tried so many different...
  48. Andy, Using the graphicstest example, calling...

    Andy,

    Using the graphicstest example, calling ili9341_t3.h, and replacing code with yours, it will not communicate with the LCD. When using the adafruit ili9341 lib, it at least gets back some...
  49. Using the Adafruit ili9341 library, it appears to...

    Using the Adafruit ili9341 library, it appears to be communicating with the display. The graphicstest example is consistently returning the following:

    Display Power Mode: 0x94
    MADCTL Mode: 0x48...
  50. Update: I Resolved these errors by deleting an...

    Update: I Resolved these errors by deleting an ILI9341-T3 directory within the c:\users\....library folder. It was trying to use that one and apparently it is the wrong one.

    However, I'm still...
Results 1 to 50 of 68
Page 1 of 2 1 2