That looks like a compiler error, not anything to do with avrdude.

But no Teensy boards use avrdude, not even Teensy 2.0 or even (long discontinued) Teensy 1.0. They all use Teensy Loader, never...