Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. Replies
    4,318
    Views
    459,951

    @KurtE - @defragster I made the clock change....

    @KurtE - @defragster

    I made the clock change.

    At 100khz I am reading on the scope 227khz so its as I suspected - need to change the other timings as well but it does work at 100khz so just have...
  2. Replies
    5
    Views
    63

    Since I was playing I tried various clock...

    Since I was playing I tried various clock settings using just one setArmClock call. It seems to start going off below 200Mhz. At 180Mhz am seeing:

    50 50001
    50 50000
    50 50000
    50 50000
    50...
  3. Replies
    4,318
    Views
    459,951

    @KurtE Was going through the manual (Argh! my...

    @KurtE

    Was going through the manual (Argh! my new favorite word when reading the manual) and checking the clock settings. But one other thing that needs to be verified otherwise we may run into...
  4. Think going the route of adding a memory chip on...

    Think going the route of adding a memory chip on the bottom side would be a good idea.

    Good luck on the routing.
  5. Replies
    31
    Views
    255

    Sorry I didn't post yesterday but had a retiree...

    Sorry I didn't post yesterday but had a retiree reunion to go to. Not an expert here but going through the freameasure lib yesterday morning and this morning and bouncing against the manual did not...
  6. Replies
    4,318
    Views
    459,951

    @KurtE Believe that @manitou developed that...

    @KurtE

    Believe that @manitou developed that section of code for setClock, way back when. For an explanation see post #403 in this thread. Also you can check the manual about page 2877 for LPI2C
  7. Replies
    31
    Views
    255

    Have it running here now with .begins and .ends...

    Have it running here now with .begins and .ends and it doesn't seem to have any problems. When you say no dice what exactly is occurring?
  8. Replies
    2
    Views
    55

    @analog&RFmodels Just checked - you are right...

    @analog&RFmodels

    Just checked - you are right for the 1062 the end function is missing. I just added with the following PR: https://github.com/PaulStoffregen/FreqCount/pull/16.

    Just remember...
  9. Replies
    4,318
    Views
    459,951

    @defragster - could drop it but probably better...

    @defragster - could drop it but probably better just not have it as a option. Think we verified at above 960Mhz we are running into operating issues. At 1Ghz 65C will get reached rather rapidly.
  10. The Teensy 4.0 does indeed have three CAN busses:...

    The Teensy 4.0 does indeed have three CAN busses:

    CAN1 on pins 0,1 and CAN2 on pins 22,23 are CAN 2.0 while CAN-FD (CAN3) is on pins 30, 31. Note that CAN-FD can be operated in CAN2.0 legacy mode...
  11. Replies
    3
    Views
    66

    @tonton81 also just posted that he updated the...

    @tonton81 also just posted that he updated the FlexCAN_t4 library to work on the T3.x's. So would suggest you start with that library.
  12. Replies
    3
    Views
    66

    @RoboticsDolphin Well first you haven't told...

    @RoboticsDolphin

    Well first you haven't told us what Flexcan library you are using and showed us the examples you are using. Usually the FlexCan libs have examples for reading and writing.

    As...
  13. @Slapstick Ok confused here are 2 questions...

    @Slapstick

    Ok confused here are 2 questions that should clarify the situation:
    1) HX8357 works with both Adafruit touchscreen.h and their HX8357 driver? From your description you said it was...
  14. Replies
    60
    Views
    2,180

    Nice work @tonton81. Have to break out all my...

    Nice work @tonton81. Have to break out all my boards again and test :)
  15. @Slapstick Think I mentioned this before but...

    @Slapstick

    Think I mentioned this before but the ILI9488 driver was designed for the ILI9488 controller not the HX8357 controller. There are differences at the controller level that may be...
  16. Never used a hx8357d display and suprised that...

    Never used a hx8357d display and suprised that the ILI9488 library works with that controller. I did read on the Adafruit site for that display:
  17. @KurtE Just got back to reading posts. For...

    @KurtE

    Just got back to reading posts. For some strange reason not getting notified from GitHub. I will go do it right now.
  18. Replies
    29
    Views
    570

    Nice Board - but you are out of stock on the...

    Nice Board - but you are out of stock on the battery charger and coin cell?
  19. Replies
    0
    Views
    51

    T4 TimerOne vs TimerThree

    Right now it seems that TimerOne has been ported over for the T4. The Timer1 is using flexPWM so I believe those are pins 0,1,24,15, I think.

    I am trying to figure out what the differences are...
  20. @KurtE - @Slapstick Never ran into that...

    @KurtE - @Slapstick

    Never ran into that problem before so something new for me as well. @Slapstick - you could reduce the SPI clock as @KurtE suggested but looking through the data sheet if you...
  21. @slapstick Oops sorry just reread your post -...

    @slapstick
    Oops sorry just reread your post - using a touch screen without a controller on a T3.6.

    I don't have a display like yours to test with. But just looking at the library I see no reason...
  22. Replies
    29
    Views
    570

    Was actually thinking about starting from an...

    Was actually thinking about starting from an initial layout like this:
    17863
    It would need some rearranging but its a start. Oh btw the header is for a ili9341/9488 display on SPI.
  23. Replies
    29
    Views
    570

    @PaulStoffregen That was the approach I was...

    @PaulStoffregen

    That was the approach I was taking. The rationale for that approach was a couple fold was mainly for expandability and customization almost like the Arduino concept of stacking...
  24. Replies
    29
    Views
    570

    That is one possibility, would be simpler for one...

    That is one possibility, would be simpler for one or 2 modules but if you have a few different ones... Was thinking actually thinking of having the modules plug into themselves then you can daisy...
  25. Replies
    58
    Views
    1,906

    Video and camera really sounds like cool features...

    Video and camera really sounds like cool features to add to the system. But would like to see maybe a beefier power supply and the sd card on the next revision.

    Had a radical idea for you - maybe...
  26. Replies
    29
    Views
    570

    One of things that I did with most of my...

    One of things that I did with most of my breakouts for the t3.5/6 and the T4 was use the Arduino shield concept so I could stack custom shields or already available shields but that has some...
  27. Replies
    60
    Views
    2,218

    Sticky: @KurtE - thanks - 1st pic with new phone :) ...

    @KurtE - thanks - 1st pic with new phone :)

    Running sketch with no heatsink on one of my breakout boards. Just ran it at 816 and getting pretty much the same temp as you about 58 degC.
    17847
  28. Replies
    60
    Views
    2,218

    Sticky: @defragster Sat here a while this morning...

    @defragster

    Sat here a while this morning watching clk pin while sketch was running at 600Mhz and 996Mhz. Run the 996Mhz up to 71degC without issue. Nothing obvious on my scope with the SPI...
  29. Replies
    60
    Views
    2,218

    Sticky: @defragster I modified my tempmon_t4 sketch to...

    @defragster

    I modified my tempmon_t4 sketch to include the drawing the Buddabrot on a ILI9341 display - ISRs never tripped but at 1Ghz the T4 hung at about 74.5 degC:

    Test results:

    @600Mhz -...
  30. Sorry - when I posted my question there were no...

    Sorry - when I posted my question there were no edits in you post #261.

    So - glad you got it working :)
  31. Scrolltest has issues with the ST7789 probably...

    Scrolltest has issues with the ST7789 probably should delete that function but hoping to figure out how to readpixels from the display. Please try and run the graphicstest.ino sketch.

    EDIT: did...
  32. Replies
    60
    Views
    2,218

    Sticky: @defragster Just ran a simple test sketch that...

    @defragster

    Just ran a simple test sketch that prints out the temp every 2 seconds with the T4 @1Ghz. TempMon does work - it shuts the T4 down at 90degC so now going to put a bit more test the...
  33. @KurtE Just downloaded and tested with that...

    @KurtE

    Just downloaded and tested with that FB_and_clip test sketch. Put it through its paces with DMA on/off and with Screen offset on the T4 and T3.6. Looks like the changes are working...
  34. Will check it out - had a feeling you were going...

    Will check it out - had a feeling you were going to go ahead and make the change

    That's a great addon. Thanks. I want to fix up the constructor as well.

    Will give it a try as soon as I get...
  35. Sorry for the delay been out running errands most...

    Sorry for the delay been out running errands most of the day and still have a couple more things to do. Nope - still having problems with reading pixels for 9341 and 9488. Meant to mention that but...
  36. Replies
    60
    Views
    2,218

    Sticky: @defragster Sorry was out running errands with...

    @defragster

    Sorry was out running errands with the wife. Yes it is posted but easier if I just attach it here:
  37. Replies
    60
    Views
    2,218

    Sticky: @defragster - @Paul I just ran my original...

    @defragster - @Paul

    I just ran my original tempmon sketch, the standalone one, that sets the registers. Ran it until it hit the High Temp of 85 and it seems to working without issue. It tripped...
  38. Replies
    4
    Views
    276

    @Bill G Thanks for the info some of the...

    @Bill G

    Thanks for the info some of the multi-thread problems I recognize from using TeensyThreads.

    Primarily the libraries I am talking about are things like PWMServo, NewPing, MPU-9250 etc. ...
  39. Replies
    60
    Views
    2,218

    Sticky: @defragster Think something else is going on...

    @defragster

    Think something else is going on besides overtempt at 996Mhz. I just ran your tempmon sketch using my ILI9341 buddabrot sketch linked into loop. At 996Mhz I runs for a bit and then...
  40. Replies
    60
    Views
    2,218

    Sticky: @defragster Those are the same coremarks that...

    @defragster

    Those are the same coremarks that I got in post https://forum.pjrc.com/threads/57894-Teensyduino-1-48-Beta-3?p=218007&viewfull=1#post218007. I was able to get 1.008Ghz(996Mhz) without...
  41. Replies
    24
    Views
    642

    Have to find the original doc I used to set 90...

    Have to find the original doc I used to set 90 may be able to raised to 95.
  42. Ok - lets start with your wiring: Display -...

    Ok - lets start with your wiring:


    Display - Pin Desc - T4 (what you have) - T4 what should be
    1,2,5,6,12 - Ground - Black - no problem
    3,4 - 3.3v - Red -...
  43. Replies
    24
    Views
    642

    I'll check it out - you guys are night owls while...

    I'll check it out - you guys are night owls while I am a morning person - so give me a little bit. Still have my original sketch where I can adjust the temps. If I remember right it is currently...
  44. Ok - never seen any display like that before -...

    Ok - never seen any display like that before - where did you find the specs for the pinouts etc?
  45. Replies
    24
    Views
    642

    @defragster Thanks for moding the example. ...

    @defragster

    Thanks for moding the example. When I ran coremark up to 1.008Ghz(1ghz) it ran without issue. When I ran demosauce that was when things started happening with resetting and loosing...
  46. Can you post a link to the exact display you are...

    Can you post a link to the exact display you are using and maybe a schematic/photo of your wiring to the T4. Have to remember that the T4 is not 5v tolerant. The adafruit display I have uses 3.3v...
  47. Replies
    24
    Views
    642

    @PaulStoffregen This seems to be the same...

    @PaulStoffregen

    This seems to be the same issue associated with SCB_AIRCR not resetting the T4. Its like the T4 appears to turn-off instead of resetting. If you reapply power it turns back on.
  48. Yes SDA goes to MOSI. You will need to do some...

    Yes SDA goes to MOSI.

    You will need to do some reconfiguration for your display though. The 7789 example is set up to use SPI and SPI1 as well as a 240x240 displat. If you are using only SPI...
  49. Replies
    24
    Views
    642

    Just ran the Coremark up through 1Ghz, no...

    Just ran the Coremark up through 1Ghz, no problems. Was running Demosauce so a heavier load:
    17827

    Believe @manitou also ran coremarks
  50. Replies
    4
    Views
    113

    You are correct. I2C slave mode isn't supported...

    You are correct. I2C slave mode isn't supported yet on the T4. Currently in the wire lib there are places that identify that.
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4