Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.02 seconds.

  1. Replies
    3,789
    Views
    390,833

    FREQCOUNT LIBRARY @manitou and …. Using ...

    FREQCOUNT LIBRARY

    @manitou and ….

    Using got the FreqCount library working with GPT2 which uses pin 14. If you want to test it out before I do a PR I am attaching the zip file.

    17053
    ...
  2. Replies
    3,789
    Views
    390,833

    Yep - that got it. Now showing 1234 :) Should...

    Yep - that got it. Now showing 1234 :)
    Should have know because I had to do that when playing with FLEXCAN. Argh.
  3. Replies
    3,789
    Views
    390,833

    Not sure but you may want t4-beta branch?...

    Not sure but you may want t4-beta branch? https://github.com/KurtE/ILI9341_t3/tree/T4_Beta
  4. Replies
    3,789
    Views
    390,833

    @manitou - yep it does work on pin 25 gave it a...

    @manitou - yep it does work on pin 25 gave it a try first - Sermon shows 1234, which is what you set up for analogWriteFreq :)

    I was curious so I took a look at the 1060 manual and saw what...
  5. Replies
    3,789
    Views
    390,833

    Hi @manitou Just getting around to play with...

    Hi @manitou

    Just getting around to play with this now again. Was trying to get it to work on GPT2 using your code as the base - GPT2_clk is on pin 14 as alt8 - unless my eyes are getting crossed...
  6. Yeah - was thinking about modifying my display...

    Yeah - was thinking about modifying my display breakout board to accommodate the Pi header but didn't get there yet. Not really familiar with the Pi pinouts but for pwm - saw there are 3 PWM pins...
  7. @MichaelMeissner The first thing I tried...

    @MichaelMeissner

    The first thing I tried before playing with putting back the print's what to add a delay where the Serial.prints were, tried 5ms but no luck so something else going on that's...
  8. @KurtE - @defragster You got me thinking so I...

    @KurtE - @defragster

    You got me thinking so I tried something. I commented out the serial.print but added the code that @defragster added to capture the fault from the sketch that we used in the...
  9. As you said - the issue was even before startup,...

    As you said - the issue was even before startup, saw the same thing on the Sermon when I hooked up Serial4. To be honest I don't think Serial.print necessarily has anything to do with but was just...
  10. Replies
    3,789
    Views
    390,833

    @PaulStoffregen (@KurtE, @defragster. @Frank B) ...

    @PaulStoffregen (@KurtE, @defragster. @Frank B)



    @defragster provided a tone more detail in posts 3701, 3702, 3710 and me in 3703. Also see #3723-3725 @Frank B also provided some info that...
  11. @KurtE - @defragster - @MichaelMeissner I did...

    @KurtE - @defragster - @MichaelMeissner

    I did try to change the SPI clock down to 12Mhz but still exhibited the same behavior. Even tried at lower CPU clocks with no luck. However, playing...
  12. Ok - just a quick update on ST7735 uncannyeyes -...

    Ok - just a quick update on ST7735 uncannyeyes - same code that gives me a problem on the T4 runs without issue on a T3.2. So no idea....
  13. @KurtE Thanks for the input just a couple of...

    @KurtE

    Thanks for the input just a couple of things:
    1. eyeMoveDuration is an int32 so shouldn't be able to hold eyeMoveDuration, if it were int16 then it would be 32,767?

    2. Now this may...
  14. @defragster I noticed that as well but I...

    @defragster

    I noticed that as well but I figure the only thing we haven't really done is a calibration to get the min/max's for the display. Have a feeling that may be the cause of the problem. ...
  15. @KurtE - @defragster Did a little more...

    @KurtE - @defragster

    Did a little more commenting out. If I comment out the eye movement section I can do what I want to config without an issue. This is what I took out:

    /*
    if (dt >=...
  16. @KurtE - @defragster Yes you did and we are...

    @KurtE - @defragster

    Yes you did and we are still at it - but it didn't beat us! :)

    Actually - you know that display breakout board I have - it wouldn't be too hard to hack that one up for...
  17. @KurtE - @defragster Thanks Kurt - never good...

    @KurtE - @defragster

    Thanks Kurt - never good spell.

    Glad you got the corrections up on GitHub.

    Never could have updated the library without you and everything you put together to decode...
  18. @KurtE - @defragster Ok got it. It is now...

    @KurtE - @defragster

    Ok got it. It is now setup to automatically select the correct rotation matrix for the display. Just tested it partially so if you want to give it a try on your displays -...
  19. @KurtE - @defragster Trying to take your code...

    @KurtE - @defragster

    Trying to take your code to identify the display and add it into the lib but it balking as I expected at what I am doing - just not sure how to fix it unless we just redo the...
  20. @defragster The rotation array in the .cpp...

    @defragster

    The rotation array in the .cpp does that mapping for you - so don't worry about it - just tried it on my display and once I remembered to change the mapping it worked fine. (see...
  21. Ok. Now that I am awake think I figured out the...

    Ok. Now that I am awake think I figured out the problem. Make sure that the madctlRotationValues for R1 is uncommented and R2 ones is commented out. It should look like this:

    /* R1 = populated,...
  22. Try.adding tft.setRotation (0).. Working from...

    Try.adding tft.setRotation (0).. Working from phone now, in bed about to crash. We may to add that to the begin function. Will te SD this tomorrow.
  23. @KurtE - @defragster Might just work: R1...

    @KurtE - @defragster

    Might just work:

    R1 populated = 0000
    R2 populated = 7ff8

    EDIT: Looks like we are beginning to break the code on this display - just thinking about all the time we are...
  24. @KurtE - @defragster Since I am stubborn here...

    @KurtE - @defragster

    Since I am stubborn here is what I got for the two sets of rotation values:

    /* R1 = populated, R2 = unpopulated */
    const uint8_t KEDEIRPI35_t3::MADCTLRotionValues[4] =...
  25. @KurtE Old Board: R1 populated, R2 unpopulated...

    @KurtE

    Old Board: R1 populated, R2 unpopulated
    New Board: R1 unpopulated, R2 populated

    The mystery deepens with this board.
  26. @KurtE You may have something. I just did a...

    @KurtE

    You may have something. I just did a comparison between my 2 displays and what you posted. The new display that is causing problems has slightly different miso results:


    New...
  27. @KurtE - @defragster If you can give it a try...

    @KurtE - @defragster

    If you can give it a try and see what happens with your current display. Right now I have both displays that the color is good and matches about what I would expect but the...
  28. @defragster Interesting results and curious. ...

    @defragster

    Interesting results and curious.

    As for the @KurtE's latest startup sketch you should see 3 berries - yep - sort of green and top reddish/purplish on the bottom. I have two...
  29. @KurtE - @defragster I think I mentioned that...

    @KurtE - @defragster

    I think I mentioned that the new display wouldn't work at all with the existing lib - screen stayed white. I changed the startup sequence to match what we have in the...
  30. @KurtE Well as usual your sketch is a lot better...

    @KurtE
    Well as usual your sketch is a lot better than mine :)

    Anyway on startup the raspberries show correctly with a black background. Which is the top of the screen - the color seems match...
  31. @KurtE - @defragster Sorry - been distracted...

    @KurtE - @defragster

    Sorry - been distracted playing with this crazy display. Nothing seems to work to get it to right without negating the colors. I edited the kedei_simple sketch to pull in...
  32. Since I don't have the raw data what you would...

    Since I don't have the raw data what you would have to do is to lcd_cmd(MOSI) and LCD_DAT(MISO)? or do I have it backwards - please teach me master yoda :)

    EDIT:
    Dummy that I am I just converted...
  33. @KurtE It could very well be. I got my third...

    @KurtE

    It could very well be. I got my third display and tested it on T4 - Ran the graphics test sketch and nothing - screen remained white. So I ran the kedei startup sketch and it displayed...
  34. don't think so was sitting for about 15 minutes...

    don't think so was sitting for about 15 minutes or so - if I type on the keyboard I can see the keystrokes on the screen
  35. @KurtE Ok - download just finished - took a...

    @KurtE

    Ok - download just finished - took a couple of hours man...…

    1. Booted up pi 3 with the 6.3 img I downloaded screen looked good - nice black background with nicely colored raspberries :)...
  36. @KurtE Ok. What image did you use and how...

    @KurtE


    Ok. What image did you use and how do you install it - or point me in the right direction - I do have a raspberry pi 3 sitting around I can test it on.
  37. @KurtE Stop showing off :) Didn't even look...

    @KurtE
    Stop showing off :)

    Didn't even look their - was busy checking the conversions. Any loaded it up with the correction and it ran but my colors are still off - screen is white raspberry is...
  38. @KurtE Tried a couple of things but no go - I...

    @KurtE
    Tried a couple of things but no go - I tried to match what you had with what I had as best I good but they look like a match.
  39. @KurtE Tried lining up what you have with what I...

    @KurtE
    Tried lining up what you have with what I was working on in my spreadsheet - a couple things didn't line up but have to finish doing some chores around the house then I will get back to it. ...
  40. @KurtE The nerd that I am I tried to make it...

    @KurtE
    The nerd that I am I tried to make it work without a lot of manual conversion. If do the delay etc and then do a mass copy and past of all 201K lines work load into the T4 - out of memory. ...
  41. Replies
    3,789
    Views
    390,833

    @Frank B Really don't remember the errors but...

    @Frank B
    Really don't remember the errors but would definitely need to be fixed if Paul updated from GCC 5.4 - not sure if he wants to do this at this point in time - a lot of regression testing...
  42. @KurtE I am as bad as you. I did some...

    @KurtE

    I am as bad as you. I did some massaging of the txt file and added a column for lcd_cmd and lcd_dat, a lot of duplicates ( I did in it excel using if statement). Tell me what you think:
    ...
  43. You can try to use this for your interrupt: ...

    You can try to use this for your interrupt:

    #define RFM95_INT digitalPinToInterrupt(2) as opposed to
    #define RFM95_INT 2
  44. Replies
    3,789
    Views
    390,833

    I have a optoresitor in the loop attached to pin...

    I have a optoresitor in the loop attached to pin A2 but I've run the sketch with one display with and without it attached.... besides on compile/upload it should be an issue until it runs - so it...
  45. Oh boy - hope you had some fun. Yes I know you...

    Oh boy - hope you had some fun.

    Yes I know you will massage it but fair warning there are some blocks that don't follow cmd/data blocks - I was doing that earlier. Then there are a whole bunch of...
  46. Replies
    3,789
    Views
    390,833

    @defragster - @Frank B Running into problem...

    @defragster - @Frank B

    Running into problem with GCC6 - Eigen library that runs fine under GCC7 is now throwing errors so sketch can not compile. Not sure if there will be an impact to anything...
  47. Replies
    3,789
    Views
    390,833

    Yep - replaced it with the contents of arm6 ...

    Yep - replaced it with the contents of arm6

    EDIT = make sure you back it up first
  48. Replies
    3,789
    Views
    390,833

    @defragster Change "arm6" to arm and it will...

    @defragster

    Change "arm6" to arm and it will run. I zipped the present toolchain and then copied arm6 over and renamed it to "arm". I also deleted the 5.3.1 folder.
  49. @KurtE I was beginning to do that before you...

    @KurtE

    I was beginning to do that before you got the initial sketch that we started from working so I just left it at that. Don't know if it worth it at this point to spend that much time going...
  50. Replies
    3,789
    Views
    390,833

    @KurtE Tried several SPI freq lowering it down to...

    @KurtE Tried several SPI freq lowering it down to 8Mhz but no change to the distorted image.

    Note that if I do and include debug_tt it the eyes on both screens display normally.

    It looks...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4