Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: Mike Chambers

Search: Search took 0.00 seconds.

  1. Hi Paul! Yes, that's the one, from here:...

    Hi Paul! Yes, that's the one, from here: https://github.com/njh/EtherCard

    I've been just using packet forwarding from Windows through the USB serial interface, which has been working well. I...
  2. Yes, I know how switches work....

    Yes, I know how switches work. Broadcast/multicast and packets directed at its own MAC are what it needs. The Teensy will be running (via emulation) MS-DOS and a DOS-based packet driver, so it just...
  3. I'm still having no luck with this, I need to...

    I'm still having no luck with this, I need to investigate some more. Thanks for the link about the W5100 and raw Ethernet frames! Unfortunately, it still is not suitable because it cannot be placed...
  4. Since 240 / 96 = 2.5, I'll just try throwing 3 or...

    Since 240 / 96 = 2.5, I'll just try throwing 3 or 4 NOPs in there and seeing what it does first.

    I noticed that about the AVR SPI reigsters as well. One of my troubleshooting steps was replacing...
  5. Thanks, yeah that makes sense. I'm actually...

    Thanks, yeah that makes sense. I'm actually running at 240 mhz. (Necessary for this project)

    I did try it at 96 MHz, but did not remove SPI.begin(). I know the enc28j60 library also initializes...
  6. Hmm, so I tried the UIPEthernet library. Compiled...

    Hmm, so I tried the UIPEthernet library. Compiled one of the examples. That doesn't work, either.

    Just to make sure my board hasn't gone bad since it was tested on my Arduino, I hooked it back up...
  7. Sorry about not including code. I've just made a...

    Sorry about not including code. I've just made a simple sketch to demonstrate the problem.

    The firmware value returned is 7 for me. I don't think the wiznet adapter is an option for me, because...
  8. ENC28J60 initializing and reading firmware version, but not receiving packets on T3.6

    I've got an ENC28J60 hooked up to my Teensy 3.6. It initializes properly, but even after setting promiscuous mode, it never receives any packets. I'm using the low-level raw packet functions from the...
Results 1 to 8 of 8