Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.04 seconds.

  1. Replies
    480
    Views
    6,493

    You know never thought about looking up the ascii...

    You know never thought about looking up the ascii character - no wonder I was having a problem - thanks :) So obvious after the fact
  2. Replies
    480
    Views
    6,493

    Nope: hm01b0_testv3:503: error: duplicate case...

    Nope:

    hm01b0_testv3:503: error: duplicate case value
    case 48:
    ^
    hm01b0_testv3:489: error: previously used here
    case '0':
    ^
    only wants single characters - maybe redo...
  3. Replies
    480
    Views
    6,493

    @KurtE Just gave your 'V' mode a try with the...

    @KurtE
    Just gave your 'V' mode a try with the ST7789 and....
    1. Sparkfun config - worked very nicely, however when I exited video mode the TMM was basically hung. Could not enter any other...
  4. Replies
    480
    Views
    6,493

    Afternoon all @KurtE - looks like you been busy...

    Afternoon all
    @KurtE - looks like you been busy this morning and afternoon between the new board design and fixing ST7735 lib. Kind of been a bit distracted with running errands again and in...
  5. Replies
    480
    Views
    6,493

    Good luck @KurtE. Be interesting see how it...

    Good luck @KurtE. Be interesting see how it works.

    Thinking about changing the name of the test sketch in prep for release to: HM01B0-KitchenSink :) Then start breaking some of the code out...
  6. Replies
    480
    Views
    6,493

    The last PR incorporated from @KurtE included the...

    The last PR incorporated from @KurtE included the 'V'ideo command.

    Tested with both Sparkfun and non-Sparkfun. Only thing is for DMA video/continuous it does take a while for the image to synch...
  7. Replies
    480
    Views
    6,493

    Good Morning all Just gave our latest set of...

    Good Morning all
    Just gave our latest set of updates a spin. Tested the same as @defragster and agree all is working well. The only thing not tested was the 'z' command.
  8. Replies
    480
    Views
    6,493

    All Had a strange thought - not sure where it...

    All
    Had a strange thought - not sure where it came from must have been a nightmare. With the lack of PSRAM on the MM board is there a way to use the SDIO pins to simulate having a PSRAM and maybe...
  9. Replies
    480
    Views
    6,493

    Didn't play much today just on and off. As you...

    Didn't play much today just on and off. As you said it was a nice day. Day is pretty much done here now and they are talking rain for tomorrow so probably will play some more tomorrow.

    One thing...
  10. Replies
    480
    Views
    6,493

    Yeah broke down and tested the Sparkfun...

    Yeah broke down and tested the Sparkfun Input/Display Carrier board. The display is 9341 compatible. Did get it working with the 9341 library but had to add a command - invert display on, then it...
  11. Replies
    480
    Views
    6,493

    Merge completed - good timing was doing...

    Merge completed - good timing was doing @defragster's merge. Have to figure out my 9341 - really giving me a hard time working.
  12. Replies
    480
    Views
    6,493

    Downloaded the latest set of changes. No...

    Downloaded the latest set of changes.

    No change to the way normal and DMA versions work. Same as last revision. With the latest fixes for FlexIO it kind of works but only a few rows on top of...
  13. Replies
    480
    Views
    6,493

    PR just merged. Sorry for the delay - had to run...

    PR just merged. Sorry for the delay - had to run out and do a few errands.
  14. Replies
    480
    Views
    6,493

    My turn for Oops - missed that in the PR was...

    My turn for Oops - missed that in the PR was looking at the changes more :) I don't mind the debug stuff.
  15. Replies
    480
    Views
    6,493

    @KurtE Just merged your PR :) EDIT: Just...

    @KurtE
    Just merged your PR :)

    EDIT: Just tested it and something strange going on with continuous mode. For the first bunch of frames the images are totally out of synch then all of sudden it...
  16. Replies
    480
    Views
    6,493

    @PaulStoffregen - Just gave it a quick test spin...

    @PaulStoffregen -
    Just gave it a quick test spin using 'f' and continuous "F" mode. "f" works as well as before however "F" is having issues. The image seems to be loosing synch. Another run had...
  17. Replies
    480
    Views
    6,493

    Noticed - PR already merged :) Just downloaded...

    Noticed - PR already merged :) Just downloaded it and now to play again.
  18. Replies
    480
    Views
    6,493

    @KurtE Once things settle down will have to go...

    @KurtE
    Once things settle down will have to go play with SublimeText and TSET again. Always something going on.
  19. Replies
    480
    Views
    6,493

    Work with v3. The only difference between v2 and...

    Work with v3. The only difference between v2 and v3 is the 'z' command for saving the last buffered image. Just tested it and its seems to be working with 's', 'D' and 'f' snapshots with hard...
  20. Replies
    480
    Views
    6,493

    Nice cheat. Anyway to the point. Just got rid...

    Nice cheat. Anyway to the point. Just got rid of the last use of imageBuffer so deleting that one. As for the sendImageBuf that's really only used for when you are sending images to the Processing...
  21. Replies
    480
    Views
    6,493

    Kurt - ignore this - got myself confused again.

    Kurt - ignore this - got myself confused again.
  22. Replies
    480
    Views
    6,493

    @KurtE - just noticed I am getting a warning...

    @KurtE - just noticed I am getting a warning message:

    D:\Users\Merli\Documents\Arduino\hm01b0_testv2\hm01b0_testv2.ino:360:85: warning: invalid conversion from 'void (*)(void*)' to 'bool...
  23. Replies
    480
    Views
    6,493

    My guess is that its suppose to be on the...

    My guess is that its suppose to be on the imageBuffer since its being used for DMA along with frameBuffer2.
  24. Replies
    480
    Views
    6,493

    Morning all - just having first cup of coffee. ...

    Morning all - just having first cup of coffee.

    Did the merge for v3 test sketch haven't had a chance to check it out yet. After I read the post of tearing in post I can't seem to duplicate it...
  25. Replies
    480
    Views
    6,493

    @PaulStoffregen - @KurtE - @defragster Ok...

    @PaulStoffregen - @KurtE - @defragster
    Ok finally got sorted out on my end (Past my bed time on the east coast) :)

    Anyway just ran the updates using Sparkfun and non-Sparkfun configs at...
  26. Replies
    480
    Views
    6,493

    Just downloaded and am getting an error message:...

    Just downloaded and am getting an error message:

    D:\Users\Merli\Documents\Arduino\libraries\TMM-HM01B0\src\HM01B0.cpp: In member function 'bool HM01B0::startReadFrameDMA(bool (*)(void*), uint8_t*,...
  27. Replies
    480
    Views
    6,493

    Ok - just merged. Saw that but didn't register...

    Ok - just merged. Saw that but didn't register how that worked - now I do.
  28. Replies
    480
    Views
    6,493

    @KurtE Just did the merge - glad I waited on...

    @KurtE
    Just did the merge - glad I waited on downloading your branch :)
  29. Replies
    480
    Views
    6,493

    @KurtE That might be why it would work in single...

    @KurtE
    That might be why it would work in single frame mode but not continuous - how to do you fix it. Try commenting out the line in the sketch for framesize and uncomment Sparkfun. If you do...
  30. Replies
    480
    Views
    6,493

    As usual yes it make sense when you explain it -...

    As usual yes it make sense when you explain it - I just need to do some more homework on the TCD setups. Going to be a long process.
  31. Replies
    480
    Views
    6,493

    No problem - been doing some other things as...

    No problem - been doing some other things as well. Just when I get back on I'm on for a while. Been spending time going down the rabbit hole.

    Funny that's exactly what I am seeing with FlexIO. ...
  32. Replies
    9
    Views
    393

    Looking the schematic I see that you have...

    Looking the schematic I see that you have MISO/MOSI shared between the touch and LCD. Can't remember but you may have a tristate buffer issue. Take a look at step 2 of PJRC's Better SPI Bus Design...
  33. Replies
    480
    Views
    6,493

    @Paul - @KurtE The more I read the more confused...

    @Paul - @KurtE
    The more I read the more confused I get. Was looking at AN12686, pg13 and what @KurtE was DMA stuff. On pg 13 for DMA setup the last 2 bullets:

    • Last destination address...
  34. Replies
    480
    Views
    6,493

    @defragster Going to put the timings back in...

    @defragster
    Going to put the timings back in since I know what to expect now.

    Was driving me crazy when it FPS going down to 16 but think that was display connection issue
  35. Replies
    480
    Views
    6,493

    Set up releases for the library and that code is...

    Set up releases for the library and that code is permanently there as Release v1.0.0. The flexIO changes will be in v1.1 I guess. Just trying to keep what works.
  36. Replies
    480
    Views
    6,493

    @defragster Also think the timing prints were...

    @defragster
    Also think the timing prints were getting me confused. Also playing with some settings for brightness and exposure. With the lights on my image tended to be basically showing glare. ...
  37. Replies
    480
    Views
    6,493

    @defragster Think I was running into the...

    @defragster
    Think I was running into the problems you just described plus issues with the display connections.

    Also I changed the "F" movie function to this


    if ( g_continuous_flex_mode )...
  38. Replies
    480
    Views
    6,493

    As they say keep dreaming :) Just tried it on...

    As they say keep dreaming :)

    Just tried it on the ST7789 and seems to be working there as well. Although trying to use for video don't work too well. Works a bit better on 9341. Think maybe it...
  39. Replies
    480
    Views
    6,493

    Think I agree - doesn't make sense to keep DMA...

    Think I agree - doesn't make sense to keep DMA using GPIO. To be honest I would hold off on trying to get it working with GPIO for the HM01b0
  40. Replies
    480
    Views
    6,493

    @PaulStoffregen Was going through your DMA code...

    @PaulStoffregen
    Was going through your DMA code (you guys are bringing me down another rabbit hole with DMA) :)

    Anyway think this is the function that controls dma h/w trigger:

    // Use a...
  41. Replies
    480
    Views
    6,493

    Thats strange, I only get that when my pin...

    Thats strange, I only get that when my pin assignment is off - know this is going to be a silly question but did you remember (1) to change the pin assignments in the graphicstest, and (2) make sure...
  42. Replies
    480
    Views
    6,493

    Here's what I am using as of this morning after...

    Here's what I am using as of this morning after your changes:

    24424
  43. Replies
    480
    Views
    6,493

    PR was merged. Just downloaded it and see what...

    PR was merged. Just downloaded it and see what you mean. Started reading FlexIO once :) Guess I will have to pull the manual out again.

    For some reason having trouble with @defragsters sketch -...
  44. Replies
    480
    Views
    6,493

    Merge done.

    Merge done.
  45. Replies
    480
    Views
    6,493

    @Paul - @KurtE - @defragster Did a couple more...

    @Paul - @KurtE - @defragster
    Did a couple more tests with FlexIO.
    Test 1: Tried changing the frameRate from 30fps to 60fps. At 30 "F" (flexIO continuous) using @defragster's updated sketch, runs...
  46. Replies
    480
    Views
    6,493

    Morning All Merged the changes into the github...

    Morning All

    Merged the changes into the github repository and just start playing but my display is acting up - wire connections with jumpers Argh!

    Anyway ran 'f'lexio using Sparkfun and...
  47. Was thinking that maybe need to lower the SPI...

    Was thinking that maybe need to lower the SPI Clock setting
  48. Replies
    480
    Views
    6,493

    Was just about to post - but the other one should...

    Was just about to post - but the other one should have worked as well. Going to delete it - probably easier that figuring out the differences.
  49. Replies
    480
    Views
    6,493

    Should just need ILI9341_t3n library. 's' is...

    Should just need ILI9341_t3n library. 's' is pretty standard and seems to have always worked. The latest TMM-HB01B0-Camera is set up for 324x224 but 's' works for Sparkfun or non-Sparkfun configs. ...
  50. Replies
    480
    Views
    6,493

    Probably not the problem but wanted to ask. In...

    Probably not the problem but wanted to ask. In the .h file

    enum {DMABUFFER_SIZE=1280}; // 640x480 so 640*2*2

    the 1280 probably needs to be changed to 324*2*2 = 1296
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4