Forum Rule: Always post complete source code & details to reproduce any issue!

Search:

Type: Posts; User: mjs513

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. @KurtE - @defragster Yes you did and we are...

    @KurtE - @defragster

    Yes you did and we are still at it - but it didn't beat us! :)

    Actually - you know that display breakout board I have - it wouldn't be too hard to hack that one up for...
  2. @KurtE - @defragster Thanks Kurt - never good...

    @KurtE - @defragster

    Thanks Kurt - never good spell.

    Glad you got the corrections up on GitHub.

    Never could have updated the library without you and everything you put together to decode...
  3. @KurtE - @defragster Ok got it. It is now...

    @KurtE - @defragster

    Ok got it. It is now setup to automatically select the correct rotation matrix for the display. Just tested it partially so if you want to give it a try on your displays -...
  4. @KurtE - @defragster Trying to take your code...

    @KurtE - @defragster

    Trying to take your code to identify the display and add it into the lib but it balking as I expected at what I am doing - just not sure how to fix it unless we just redo the...
  5. @defragster The rotation array in the .cpp...

    @defragster

    The rotation array in the .cpp does that mapping for you - so don't worry about it - just tried it on my display and once I remembered to change the mapping it worked fine. (see...
  6. Ok. Now that I am awake think I figured out the...

    Ok. Now that I am awake think I figured out the problem. Make sure that the madctlRotationValues for R1 is uncommented and R2 ones is commented out. It should look like this:

    /* R1 = populated,...
  7. Try.adding tft.setRotation (0).. Working from...

    Try.adding tft.setRotation (0).. Working from phone now, in bed about to crash. We may to add that to the begin function. Will te SD this tomorrow.
  8. @KurtE - @defragster Might just work: R1...

    @KurtE - @defragster

    Might just work:

    R1 populated = 0000
    R2 populated = 7ff8

    EDIT: Looks like we are beginning to break the code on this display - just thinking about all the time we are...
  9. @KurtE - @defragster Since I am stubborn here...

    @KurtE - @defragster

    Since I am stubborn here is what I got for the two sets of rotation values:

    /* R1 = populated, R2 = unpopulated */
    const uint8_t KEDEIRPI35_t3::MADCTLRotionValues[4] =...
  10. @KurtE Old Board: R1 populated, R2 unpopulated...

    @KurtE

    Old Board: R1 populated, R2 unpopulated
    New Board: R1 unpopulated, R2 populated

    The mystery deepens with this board.
  11. @KurtE You may have something. I just did a...

    @KurtE

    You may have something. I just did a comparison between my 2 displays and what you posted. The new display that is causing problems has slightly different miso results:


    New...
  12. @KurtE - @defragster If you can give it a try...

    @KurtE - @defragster

    If you can give it a try and see what happens with your current display. Right now I have both displays that the color is good and matches about what I would expect but the...
  13. @defragster Interesting results and curious. ...

    @defragster

    Interesting results and curious.

    As for the @KurtE's latest startup sketch you should see 3 berries - yep - sort of green and top reddish/purplish on the bottom. I have two...
  14. @KurtE - @defragster I think I mentioned that...

    @KurtE - @defragster

    I think I mentioned that the new display wouldn't work at all with the existing lib - screen stayed white. I changed the startup sequence to match what we have in the...
  15. @KurtE Well as usual your sketch is a lot better...

    @KurtE
    Well as usual your sketch is a lot better than mine :)

    Anyway on startup the raspberries show correctly with a black background. Which is the top of the screen - the color seems match...
  16. @KurtE - @defragster Sorry - been distracted...

    @KurtE - @defragster

    Sorry - been distracted playing with this crazy display. Nothing seems to work to get it to right without negating the colors. I edited the kedei_simple sketch to pull in...
  17. Since I don't have the raw data what you would...

    Since I don't have the raw data what you would have to do is to lcd_cmd(MOSI) and LCD_DAT(MISO)? or do I have it backwards - please teach me master yoda :)

    EDIT:
    Dummy that I am I just converted...
  18. @KurtE It could very well be. I got my third...

    @KurtE

    It could very well be. I got my third display and tested it on T4 - Ran the graphics test sketch and nothing - screen remained white. So I ran the kedei startup sketch and it displayed...
  19. don't think so was sitting for about 15 minutes...

    don't think so was sitting for about 15 minutes or so - if I type on the keyboard I can see the keystrokes on the screen
  20. @KurtE Ok - download just finished - took a...

    @KurtE

    Ok - download just finished - took a couple of hours man...…

    1. Booted up pi 3 with the 6.3 img I downloaded screen looked good - nice black background with nicely colored raspberries :)...
  21. @KurtE Ok. What image did you use and how...

    @KurtE


    Ok. What image did you use and how do you install it - or point me in the right direction - I do have a raspberry pi 3 sitting around I can test it on.
  22. @KurtE Stop showing off :) Didn't even look...

    @KurtE
    Stop showing off :)

    Didn't even look their - was busy checking the conversions. Any loaded it up with the correction and it ran but my colors are still off - screen is white raspberry is...
  23. @KurtE Tried a couple of things but no go - I...

    @KurtE
    Tried a couple of things but no go - I tried to match what you had with what I had as best I good but they look like a match.
  24. @KurtE Tried lining up what you have with what I...

    @KurtE
    Tried lining up what you have with what I was working on in my spreadsheet - a couple things didn't line up but have to finish doing some chores around the house then I will get back to it. ...
  25. @KurtE The nerd that I am I tried to make it...

    @KurtE
    The nerd that I am I tried to make it work without a lot of manual conversion. If do the delay etc and then do a mass copy and past of all 201K lines work load into the T4 - out of memory. ...
  26. Replies
    3,770
    Views
    389,796

    @Frank B Really don't remember the errors but...

    @Frank B
    Really don't remember the errors but would definitely need to be fixed if Paul updated from GCC 5.4 - not sure if he wants to do this at this point in time - a lot of regression testing...
  27. @KurtE I am as bad as you. I did some...

    @KurtE

    I am as bad as you. I did some massaging of the txt file and added a column for lcd_cmd and lcd_dat, a lot of duplicates ( I did in it excel using if statement). Tell me what you think:
    ...
  28. You can try to use this for your interrupt: ...

    You can try to use this for your interrupt:

    #define RFM95_INT digitalPinToInterrupt(2) as opposed to
    #define RFM95_INT 2
  29. Replies
    3,770
    Views
    389,796

    I have a optoresitor in the loop attached to pin...

    I have a optoresitor in the loop attached to pin A2 but I've run the sketch with one display with and without it attached.... besides on compile/upload it should be an issue until it runs - so it...
  30. Oh boy - hope you had some fun. Yes I know you...

    Oh boy - hope you had some fun.

    Yes I know you will massage it but fair warning there are some blocks that don't follow cmd/data blocks - I was doing that earlier. Then there are a whole bunch of...
  31. Replies
    3,770
    Views
    389,796

    @defragster - @Frank B Running into problem...

    @defragster - @Frank B

    Running into problem with GCC6 - Eigen library that runs fine under GCC7 is now throwing errors so sketch can not compile. Not sure if there will be an impact to anything...
  32. Replies
    3,770
    Views
    389,796

    Yep - replaced it with the contents of arm6 ...

    Yep - replaced it with the contents of arm6

    EDIT = make sure you back it up first
  33. Replies
    3,770
    Views
    389,796

    @defragster Change "arm6" to arm and it will...

    @defragster

    Change "arm6" to arm and it will run. I zipped the present toolchain and then copied arm6 over and renamed it to "arm". I also deleted the 5.3.1 folder.
  34. @KurtE I was beginning to do that before you...

    @KurtE

    I was beginning to do that before you got the initial sketch that we started from working so I just left it at that. Don't know if it worth it at this point to spend that much time going...
  35. Replies
    3,770
    Views
    389,796

    @KurtE Tried several SPI freq lowering it down to...

    @KurtE Tried several SPI freq lowering it down to 8Mhz but no change to the distorted image.

    Note that if I do and include debug_tt it the eyes on both screens display normally.

    It looks...
  36. Replies
    3,770
    Views
    389,796

    @Frank B and @defragster @KurtE Hope you don't...

    @Frank B and @defragster @KurtE

    Hope you don't mind but I just downloaded and installed your GCC 6. Ok don't get the that error anymore but without debug_tt the eyes on the two screens are...
  37. @KurtE Had to make a slight change to get...

    @KurtE

    Had to make a slight change to get colors to match and touchpaint to match what you had:

    // Define at most only one of these...
    //#define RGB_COLORS
    //#define BGR_COLORS
    //#define...
  38. Replies
    3,770
    Views
    389,796

    Isn't it though :). Wonder if it shows the same...

    Isn't it though :). Wonder if it shows the same behavior with other optimizations? Oh - it does work on a T3.6 last I looked.
  39. Replies
    3,770
    Views
    389,796

    Yes - writeRect was added later so definitely...

    Yes - writeRect was added later so definitely need KurtE's fork branch that he referenced in post3723.
  40. Oh wasn't clear - none of them worked. Sorry. ...

    Oh wasn't clear - none of them worked. Sorry.

    I did break down and ordered another display just as a test - I screwed up that second one that I bought. Will get it Thursday. Don't know if its...
  41. @KurtE Just gave it a try and the changing the...

    @KurtE
    Just gave it a try and the changing the madtl does change the colors to the correct ones. The only thing that does it is to invert RGB colors. Then it works as you show. Sorry.

    Strange...
  42. @KurtE - @defragster If you do the following...

    @KurtE - @defragster

    If you do the following in the GITHUB .h file:

    #define RGB_COLORS 1
    // Color definitions
    #ifdef RGB_COLORS
    #define KEDEIRPI35_BLACK 0xFFFF-0x0000 /* 0, 0,...
  43. @KurtE - @defragster Ok in the loop if I change...

    @KurtE - @defragster
    Ok in the loop if I change in your kedei_simple sketch

    lcd_fillframe(0, 0, lcd_w, lcd_h, (colors[color]));
    to

    lcd_fillframe(0, 0, lcd_w, lcd_h, 0xFFFFFF...
  44. @KurtE - @defragster Playing around with the...

    @KurtE - @defragster

    Playing around with the simple kedei sketch in post #386 the colors are still off so I put in a wait for input loop so I can try to match the colors to screen. I got this, it...
  45. @KurtE - @defragster Didn't realize there was...

    @KurtE - @defragster

    Didn't realize there was a white box on the far right - when I hit White the sermon shows black, when I hit black it shows White.
  46. @KurtE No worries about the pic. I just...

    @KurtE

    No worries about the pic. I just checked the back of my display and it has the exact same identification that is on your display:
    17003
  47. Replies
    3,770
    Views
    389,796

    @el_supremo Thanks for the code - I was looking...

    @el_supremo
    Thanks for the code - I was looking at this one to port - but much more complicated: https://github.com/marczych/RayTracer/tree/master/src
  48. @KurtE - @defragster @defragster - was just...

    @KurtE - @defragster

    @defragster - was just letting you know what I had to get it to work. Anyway I just retry mine with the latest updates and this is what I am seeing:

    16998

    Not sure why...
  49. @defragster - that looks exactly like my screen...

    @defragster - that looks exactly like my screen with the exception that touchscreen worked :) I don't have to use the full constructor though to get it to work.
  50. Replies
    3,770
    Views
    389,796

    Ok you peaked my interest - starting to play with...

    Ok you peaked my interest - starting to play with 3d graphics and ray tracing for the T4 - what lib did you port? Started discussing here:...
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4