i had a basic joystick sketch working but now the device is not seen at all by windows. the gamepad configuration utility identifies the teensy joystick but shows nothing on the test page. previously this did work. is there some procedure for uninstalling drivers that might be corrupted or anything else i should try? also does not work with my programs that access a joystick which did work a short while ago.

while i am asking, i am also have serious jitter in the analog read. i am analog reading a voltage output by a hall effect sensor. it is rock steady measured on a multimeter or oscope but the voltage is jumping all over the place as shown by a serial print of the analog read value. when the joystick was working and using this analog read value to send a joystick value it also jittered (or course, it was using the same value) i read somewhere a hint at some input smoothing in one of the examples or somewhere else but can not find it now. before writing my own smoothing i would like to try something ready made if i can find it. preferably the jitter problem can be solved so this is not necessary. i have tried an external reference using a 3 volt lithium battery and this does not seem to help. in the arduino code i specified analogReference(EXTERNAL); and connected the 3 volt reference to the ref in pin. anything wrong with this?

any other ideas on the joystick problem or the analog read jitter?