I was working on a fairly simple bit of code using RawHID via Arduino on a 2.0. I pushed it down, the various LEDs lit, etc. I started the usb code on the desktop side. couldn't connect. went back to the code, put in some Serial.Printlns, tried to build -- teensy loader couldn't find the device. Tried the 'hold-the-button-down-while-plugging-in' trick, as well as other ports and machines. USB Prober sees nothing. Oh, well, maybe it caught a spark or something.

Grabbed a 2.0++, rejiggered the simple connections and the Pin #s in the code. Compiled and pushed it down -- same thing, device is no longer communicating.

Did I whack the halfkay somehow? Did the cat jump up and rub across both of them when I wasn't looking?

I ordered a few more, but obviously don't want the same thing to happen.

T3 still works, of course, no RawHID in Arduino for it

I can post the code if anyone thinks that's actually the issue.

Also, FWIW, I built the little bits of code for the buttons/leds first and all was well, then I tried some basic RawHID tests, which also worked well, this was essentially just the grafting together of the two.