Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 8 of 8

Thread: TimerOne Library in Visual Studio 2015

  1. #1

    TimerOne Library in Visual Studio 2015

    I have been using Visual Studio with Arduino 1.6.5 R5, Teensyduino 1.25 , and the one of the latest Visual Micro plugins (Win7 X64). Overall I like the experience and would like to continue using the Visual Studio for my Teensy 3.1 programming.

    One of my projects requires the use of TimerOne library which Visual Studio cannot locate despite it being installed in the same directory as other libraries which it can find just fine. When I try to reinstall the library from the Visual Micro tools menu it says it is already installed. When I try to add library it is not on the list of the installed libraries and also when insert #include <TimerOne.h> line in the code it returns :

    Compiling debug version of 'MedianFilter_03' for 'Teensy 3.2 / 3.1'
    MedianFilter_03.ino:2:22: fatal error: TimerOne.h: No such file or directory
    :#include <TimerOne.h>
    :compilation terminated
    Error compiling project sources

    Upon closer inspection few other libraries are missing on the list : AltSoftSerial, FastCRC, and LowPower.
    I tried putting the TimerOne library in the C:\Users\user123\Documents\Arduino\libraries with other libraries and that did not work.
    Please let me know if anybody has any suggestions.

    Thanks,
    George

  2. #2
    Member tcottle's Avatar
    Join Date
    Dec 2014
    Location
    Longmont, CO
    Posts
    45
    So I ran into the same problem today with TimerOne only I am using the Dec 28th issue of the VM plug in, Arduino 1.6.6 and Teensyduino 1.26.

    My sketch barfs with the same error as yours but complies fine under the arduino IDE so the problem must be at the VM plugin end ...

  3. #3
    That's right in Arduino IDE 1.6.5 it all works fine. I also posted the same message on the VisualMicro forum and I will let you know if I get any good suggestions.

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,123
    If you get any info over on Visual Micro forum, I hope you'll post a link to it from here.

  5. #5
    Hi Paul,

    The thread on Visual Micro forum is:

    http://www.visualmicro.com/forums/Ya...1451585925/0#3

    I got the message from the forum moderator and he has new version of Visual Micro (1601.01) that is supposed to fix this issue. I installed it and the problem did not go away for me. I posted a new message with the trace outputs so hopefully he will get some additional insight from it.

    I encourage other people to try Visual Micro 1601.01 and see if that fixes the problem fro them.

    Thanks

  6. #6
    Member tcottle's Avatar
    Join Date
    Dec 2014
    Location
    Longmont, CO
    Posts
    45
    Still broke for me as well ...

  7. #7

  8. #8
    Yes Visual Micro version 1601.04 fixed the problem fro me. I can include and use TimerOne.h library with Teensy 3.1.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •