Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Teensyduino / Arduino IDE 1.5.2 Support

  1. #1
    Junior Member
    Join Date
    Feb 2013
    Posts
    19

    Teensyduino / Arduino IDE 1.5.2 Support

    Just curious if there are currently any plans to support Arduino IDE 1.5.2 in the near future. The new Arduino Eclipse plugin depends on Arduino IDE 1.5.2 and I wanted to give it a test run with Teensy.

  2. #2
    Junior Member
    Join Date
    Feb 2013
    Posts
    19
    In case anyone is wondering as well, I found the answer here in Paul's reply (from late February):

    http://forum.pjrc.com/threads/18938-...lder-structure

    Quote Originally Posted by PaulStoffregen View Post
    I plan to support 1.5.x, but at the moment the Arduino developers are still making significant changes to the platforms.txt, library search and other important details. I'm waiting for a while, mostly because people seem to be pretty happy with Teensy on 1.0.3 at the moment, but also because I'm not excited about having to redo a lot of work for 1.5.x as the Arduino developers change stuff. Hopefully it will stabilize nicely before more people make the 1.0.3 to 1.5.x switch?

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,304
    Recently I've been focusing on testing, porting and documenting the many Arduino libraries. I've also been working heavily on many small improvements to Teensyduino. This week, I've been putting a lot of work into an automated regression test system, which eventually will let me automatically test nearly all core Arduino functions and many of the supported libraries on all Teensy boards. It still needs quite a bit of effort, but already it's uncovered a few bugs which I've fixed for the upcoming Teensyduino 1.14 release.

    At the moment, I'm only working to support Arduino 1.0.5, which is expected to be released any day now.

    I have a pretty long list of little improvements for Teensyduino before looking at supporting 1.5.x. But eventually, probably this summer, I'm going to transition to primarily supporting 1.5.3 or whatever version it's up to by then.

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,304
    However, fairly high on my priority list is investigating a missing feature in the toolchain which Jantje needs to fully support Teensy on Eclipse. In fact, I'm planning to do that right after Teensyduino 1.14 releases and I've sent off another spin of the regression tester board.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •