Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 31 of 31

Thread: Audio Visualizer with ws2811

  1. #26
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,321
    Quote Originally Posted by chadder_all View Post
    But now i get a major lag in the Processing screen and also the strip lighting up. i will post some code but can someone tell me why this is happening?
    Not without seeing the code...

  2. #27
    Completely forgot to post the code! sorry!

    Processing:

    Code:
    void setup(){
    String portName = "/dev/tty.usbmodem8061";
    myPort = new Serial(this, portName, 57600);
    }
    
    void draw(){
    if (bassAvg > 100) myPort.write(1);
        else myPort.write(0);
    }

    Arduino IDE:
    Code:
    void loop() {
     if (Serial.available()) { // If data is available to read,
     val = Serial.read(); // read it and store it in val
     }
     if (val == 1) { // If hit was received
     colorWipe(PINK); // turn the LED on
     } else {
     colorWipe(0); // Otherwise turn it OFF
     }
     //delay(100); 
     }

  3. #28
    Also... I used the serial library to blink the led on the teensy whenever a 'hit' is registered and it worked fine

  4. #29
    I have fixed the issue with one line of code:


    if (!leds.busy())leds.show();

    And now I have a functional visualizer.
    Last edited by chadder_all; 10-24-2013 at 04:12 AM.

  5. #30
    Good to hear you got it working, upload a video when it starts to look cool.

  6. #31
    Heres a quick video from my phone:

    http://www.youtube.com/watch?v=ZQLKfoieOjo

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •