Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 33 of 33

Thread: Teensyduino 1.18 Release Candidate #1 Available

  1. #26
    Member ARMbasic's Avatar
    Join Date
    Dec 2013
    Location
    Lake Tahoe, CA
    Posts
    60
    Does 1.18 support XP?

    I'm getting a code 28 driver not initialized for the USB serial device, on an HP netbook running XP

    I did the install twice.

    Just checking BASIC on XP, though I really do use that netbook when traveling.

  2. #27
    Member ARMbasic's Avatar
    Join Date
    Dec 2013
    Location
    Lake Tahoe, CA
    Posts
    60
    let me answer my own question 1.18-rc2 does support XP, but -rc1 does not

  3. #28
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,597
    Yes, XP is supported.

    If you run the installer again, you might look for the "reinstall driver" button on the page that tells you the driver is already installed.

    Another thing to try is right clicking in the device manager and using the option to reinstall the driver. Hopefully one of those will do the trick?

  4. #29
    Junior Member
    Join Date
    Jan 2014
    Location
    New Jersey, USA
    Posts
    1
    Hi Paul,
    I have a question about Arduino /Teensyduino version support. I am developing on OS X 10.8.5 on a number of different boards including ATMEGA based boards including Teensy 2.0, the Arduino Due, and the Teensy 3.0 & 3.1. The Arduino Due is not supported in Arduino 1.0.5 software, rather it requires the 1.5.5 Beta. And the Teensyduino software won't install on the 1.5.5 BETA.

    It all works OK but the versions are just another error looking for a place to happen. I know this is not a problem of your making, but... are you planning to support the Arduino 1.5.5. beta? If not, how long after it goes production will you support it?

    I apologize if this was answered somewhere else, and thanks in advance for any plans you can communicate about this.

    Regards,
    Mark

    Thanks,
    Mark

  5. #30
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,597
    Quote Originally Posted by mlewus View Post
    It all works OK but the versions are just another error looking for a place to happen.
    Actually, the Arduino Team has put quite a lot of work into designing the Arduino IDE to allow multiple versions to be installed on the same computer and co-exist nicely.

    I know this is not a problem of your making, but... are you planning to support the Arduino 1.5.5. beta? If not, how long after it goes production will you support it?
    TL;DR = Yes, but not until the library API is stable.

    A more detailed answer is here:

    http://forum.pjrc.com/threads/24855-...ETA-2014-01-10

  6. #31
    Junior Member
    Join Date
    Apr 2014
    Posts
    9

    How to have Arduino 1.05 and 1.5.5 BETA on same computer?

    Paul - or anyone,
    You said :

    [QUOTE=PaulStoffregen;40494]Actually, the Arduino Team has put quite a lot of work into designing the Arduino IDE to allow multiple versions to be installed on the same computer and co-exist nicely.


    I am somewhat nubee, i have arduino pro mini got a 3D printer with Mega 2560, then got a Due board, which has been a pita with libraries, had to install the latest Arduino BETA, and had problems trying to get it to generate i2s timings for external audio dacs, i then saw the Teensy 3.1 with your audio shield and also picked up the vs1063 audio shield to try and 'play' with to see which one i want to use in my project (want to be able to get live mic reverb and possibly shift effects while playing a other SPI streaming audio to the DAC). Anyway, since the TeensyDuino doesn't work with the Arduino Beta, - you have said that Arduino team worked hard on allowing multiple version to be installed at same time. So, I tried to run the install for 1.05 again and it sees the BETA installed and tells me I have to Unistall the BETA before it will let me install the 1.05. So, what am i missing here? I need to have both the BETA and 1.05 running so I can develop for Teensy and Due at the same time. What am i doing wrong if that's what you meant that i should be able to run both at same time. I know, this is more an Arduino forum question, but, your the one who said this is possible, so i'll ask you first, thanks (If i had seen the specs on Teensy 3.1 before i saw the Due, I probably wouldn't have bothered with the Due, and if the Teensy 3.1 works as i hipe it will, then bye bye Due...

  7. #32
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,597
    Quote Originally Posted by unltdsoul View Post
    So, I tried to run the install for 1.05 again and it sees the BETA installed and tells me I have to Unistall the BETA before it will let me install the 1.05. So, what am i missing here?
    Perhaps you're using Windows and running Arduino's installer?

    You need to download the ZIP files, not the installers, from www.arduino.cc. Then you can extract each ZIP file, for 1.0.5 and 1.5.6, to different folders on your computer. Remember where they are, so when you run the Teensyduino installer, you can select the correct location where you extracted the 1.0.5 ZIP file.

  8. #33
    Junior Member
    Join Date
    Apr 2014
    Posts
    9
    You're correct, I'm using Windows. Thanks, I'll do that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •