Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 20 of 20

Thread: Visual Micro help needed

  1. #1
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828

    Visual Micro help needed

    Almost works, with Atmel Studio 6.1.
    I've read all I can find here, and the unfortunately uber-terse info on Visual Micro's web site re Teensy2, 3 config.
    A diary of some Teensy user's success would be so nice. Save so much duplication of effort, since Visual Micro hasn't made it clear.

    When entering the path to the "IDE" as Visual Micro calls it, for Teensy 2,3, what to I choose?
    Would it be this:
    C:\Arduino_152-IsInstalled\hardware\teensy\tools\windows
    or
    C:\Arduino_152-IsInstalled\hardware\teensy
    or other?

    I have Eclipse working (but I don't understand all the config. options for it, including paths for Teensy 2 vs. Teensy 3). I've been using Eclipse for Teensy 3 of late.

  2. #2
    Member
    Join Date
    Oct 2013
    Location
    Bristol, UK
    Posts
    41
    IIRC I think the route to the Arduino IDE is simple the base of it i.e. for you C:\Arduino_152-IsInstalled

    Make sure you add these defines to every project - http://www.visualmicro.com/page/Teen...al-Studio.aspx - I kept forgetting and then wondering why I was getting loads of error messages.

    It's worth getting it working - much simpler overall than trying to set eclipse up, and vastly better than the default Arduino IDE

  3. #3
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    Thanks.. would you mind looking at your setup and see what path you have for Teensy 2 and teensy 3.x ?
    TIA

  4. #4
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    I so far unable get VIsual Studio with Atmel's Studio 6.1 to work for Teensy 3. Sorry to bug you.
    I've tried many things to get the path to the IDE to be what it wants, but it's not clear what it really wants.
    C:\arduino
    is arduino 1.0.5
    C:\arduino\hardware\teensy
    is teensy's standard install

    in Atmel Studio 6.1
    menu tools->options->visualMicro->General
    I've tried many path names here but none let Studio find the Teensy 3 boards file.

    The instructions on the VisualMicro web site, such as they are, don't discuss Teensy 3.

    this is for Win 7, 64 bit.

    Thanks in advance
    Steve

  5. #5
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    replying to my own posting, above...

    With some great help from Time of Visual Micro, I did get Visual Studio with the Arduino add-in working, for Teensy 3.1.
    You can read about my (in hindsight of course) naive fumbling here:
    http://www.visualmicro.com/forums/Ya...1389630981/0#0

    Haven't found how to launch the PJRC uploader from the Visual Studio IDE yet. So I just do it manually.

    I'm looking forward to trying the Visual Micro debugger.
    Last edited by stevech; 01-13-2014 at 06:46 PM.

  6. #6
    Update: how to upload to Teensy

    Clicking "Project>Build" will simply compile the sketch, the docs need more examples!

    Please click the blue arrow on the tool bar in Atmel Studio (Green arrow in Visual Studio) to compile and upload to Teensy.

    Or click "Debug>Start" or "Debug>Start without debugging", you will see that these options also have function keys that perform the same task. For example in Visual Studio, F5 compiles and uploads.

    There are other build options for advanced users. If you are using a solution with multiple Teensy projects open at the same time. Right click "Deploy", "Publish", "Start new Instance". They all compile and upload for Teensy.

    If you have the usb debugger installed then starting with or without debugging perform different functions (obviously).

    Thanks
    Last edited by visual_micro; 01-17-2014 at 10:54 PM.

  7. #7
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    It would be helpful to put tips and how-to's such as the above into a document on the proper web site.
    We're seeing too much good info that gets buried as one post amidst a larger forum of many threads, and this it is lost in the noise for most.

  8. #8
    @stevech,

    Yes agreed we need better documentation! I should have posted links with what we have right now

    visualmicro.com
    getting started
    teensy settings
    compile and upload
    youtube overview
    forum
    wiki
    adding libraries

    Creating the free tool, providing the wiki, youtube and forum takes a huge amount of time. As with any free tool we also hope that users can contribute when time permits. Some users do and have really helped out so I am not complaining!

    I think there will always be posts, outside of visualmicro.com, where useful information that answers a question, can be provided. Such as adding explanation of the methods to compile and upload.

    There are a huge number of fast moving and exciting changes within the Teensy and Arduino camps. As you know Visual Micro attempts to support them all whilst also providing a number of innovative extra features on top. It's great fun but hard work. Any blogs, videos or documents that anyone can produce that will help others will always be very much appreciated.

    Thanks for your support generally in these forums and your good summary (above/below) that I am sure will be very useful for others.
    Last edited by visual_micro; 01-18-2014 at 03:17 AM.

  9. #9
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    Visual Micro... w/Atmel Studio...

    How can I change the default folder (directory path) for new and open-old "sketch" ? The default was set during installation and isn't prudent.

  10. #10
    Duplicate post being discussed in the visualmicro.com forum here http://www.visualmicro.com/forums/Ya...1390608647/0#3

  11. #11
    Thanks for posting about this Steve, I was able to get this working ok with Atmel Studio and it's nice to be able to code in a familiar looking IDE.

    Regards,

    Les

  12. #12
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    Yes, Visual Micro w/Atmel Studio is great for those students/hobbyists that want an IDE with intellisense etc. And Visual Micro's debugger add-on is novel and well worth their modest fee.
    Eclipse would be OK with me but for the Teensy it lacks a practical installation procedure or, in lieu of that, an installer wizard.

  13. #13
    Can you get post build events to work? I am trying to run an exe post build, but it doesn't work here.

    Regards,

    Les

  14. #14
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    I have not added custom post-build actions, but the post build invocation of Teensy.exe to upload to the board works OK.
    (Win 7, 64 bit)

  15. #15
    Quote Originally Posted by stevech View Post
    the post build invocation of Teensy.exe to upload to the board works OK.
    (Win 7, 64 bit)
    Same here but I guess that is hard coded somewhere.

    Regards,

    Les

  16. #16
    Hi there,

    There are plenty of ways to change the build events using the config system, however for standard Teensy upload this should not be required Visual Micro will invoke the standard Teensy uploader (uses the Teensy config files).

    In any event, if this is a bug report or a product change request please use the forum at http://www.visualmicro.com because that is the only place where we can provide support. It is a dedicated forum for the plugin which is not in any way managed via this web site or forum.

    Thanks very much

    Tim Leek
    Last edited by visual_micro; 02-05-2014 at 07:08 PM.

  17. #17
    Senior Member
    Join Date
    Jun 2013
    Location
    So. Calif
    Posts
    2,828
    I think user Pointy was trying to add a post-build action (call a program)l and had not been successful.

  18. #18
    Quote Originally Posted by stevech View Post
    I think user Pointy was trying to add a post-build action (call a program)l and had not been successful.
    Yes correct, the Teensy loader part works fine. I simply wanted to launch my own debug monitor program after the build had finished.

    Regards,

    Les

  19. #19
    A few notes here that might help.

  20. #20
    Quote Originally Posted by visual_micro View Post
    A few notes here that might help.
    Thanks for the link. I don't think either of those examples are an option for me. To be honest i was just curious if I was doing something wrong, this page is where I am adding a command to run an external program. This post suggests it should work, but then he is not using Visual Micro.

    It's not a big deal, more of a minor niggle, and I won't lose any sleep if it doesn't work.

    Regards,

    Les

    PS.

    I apologize for not joining your forum and posting over there, but I have lost count of the number of forums I have joined over the 15 years or so just to make a single post or two, and these days I am just too lazy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •