Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 9 of 9

Thread: Older versions of Teensyduino?

  1. #1

    Older versions of Teensyduino?

    Where can I find older versions of Teensyduino? I need to run Arduino 1.04 due to some Adafruit library issues. Thanks.

  2. #2
    Senior Member
    Join Date
    Jan 2013
    Posts
    966
    A. There was a recent post where that was explained. Use the search function.
    B. Perhaps it is the better approach to post in detail what your Adafruit library issues are and then we can help you...

  3. #3
    Thanks. Interesting. Even though I had "instant email notification" checked for this thread, no email. Hmmm. In any case, I did search before I asked, found plenty of "links" to older versions, but they all point to the same download page, which only has a link to the most resent version, hence my post here AFTER searching. So, checking again, I found buried in a thread what I assume is the explanation you refer to. So, for the benefit of anyone else searching the same info by the keywords "older versions"...

    1. Go to the standard Teensyduino download page.
    2. Right click the download link for your OS, and "Copy Link Location" (or your OS/Browser's equivalent...)
    3. Paste that into the url string of your browser, DON'T HIT ENTER YET.
    4. Change the "td_xxx folder in the url to the version you seek.
    5. Hit ENTER & download

    Note: The above should work until such time as the website folder naming structure/old version policy changes.

    RE: my problem, I need to work out some I2C issues to the best of my ability before I bother anyone else. If I hit a brick wall, rest assured I'll ask for some help :-) I appreciate the offer.

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,054
    Quote Originally Posted by ForestCat View Post
    RE: my problem, I need to work out some I2C issues to the best of my ability before I bother anyone else. If I hit a brick wall, rest assured I'll ask for some help :-) I appreciate the offer.
    If you discover any Adafruit library that truly does not work with the latest 1.18-rc2 code, please post details.

    I do investigate and fix such problems. If the error is on Adafruit's side, usually they will accept a pull request. If the error turns out to be in Teensyduino, of course I'll fix it.

  5. #5
    Hi Paul,

    It's not a Teensyduino issue. As near as I can tell, the most recent Arduino IDE (1.05xx) includes a number of Adafruit libraries that may/may not be current. There are a number of Adafruit I2C LED/Matrix/7-Seg code exampleslibraries that require different versions of certain Adafruit libraries than what is in 1.05xx. The "quick fix" was just revert to the 1.04 IDE (which doesn't work with the current Teensyduino, hence me looking for the Teensyduino that likes 1.04). As an arduino/teensy noob, I wanted to avoid mucking around in the library structure just to test out some display functionality and possibly break something else. But at this point, it's a non-issue for me, since I rolled my sleeves up and "fixed" the 1.05 libraries, since I couldn't find the older Teensyduino version yesterday :-). I'm better off anyway. Other than the LED display booting up in full afterburner and toasting a thin vcc supply trace, it all seems good at this point. Thanks for the reply.

    P.S Any idea why my email notifications of new posts here aren't working?

  6. #6
    Senior Member
    Join Date
    Nov 2012
    Location
    Boston, MA, USA
    Posts
    1,113
    Which library was correct in 1.0.4 and broken in 1.0.5? Its great that you fixed it yourself, but that doesn't help the next person to come across the same error.

  7. #7
    Senior Member
    Join Date
    Nov 2012
    Location
    Boston, MA, USA
    Posts
    1,113
    Bump for info?

  8. #8
    Junior Member
    Join Date
    Jan 2015
    Posts
    2
    I tried changing the download link as directed by the post above. (https://www.pjrc.com/teensy/td_127/T...inoInstall.exe) I need Teensyduino 1.27 - we used it for a prior project and I prefer not to upgrade it right now.

    Funny, because https://www.pjrc.com/teensy/td_128/T...inoInstall.exe works - so they might not have 1.27 up any more.

  9. #9
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    25,054
    The file naming changed with 1.28. Use this link:

    https://www.pjrc.com/teensy/td_127/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •