Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 1 of 1

Thread: Not able to connect Teensy 2.0 soldered to ErgoDox keyboard to USB port

  1. #1

    Not able to connect Teensy 2.0 soldered to ErgoDox keyboard to USB port

    I ordered the ErgoDox keyboard kit on Massdrop ( which uses a Teensy 2.0 and assembled it myself. When I plugged the keyboard with the Teensy soldered to it into my USB port for the first time the LED on the the Teensy board blinked on and off as expected. Unfortunately, I was too excited and didn't read the manual for the assembly carefully enough ( Instead of loading the firmware for the ErgoDox keyboard ( I directly tried to load the qwerty layout onto the board ( Now my OS is unable to connect to the Teensy board when plugging in the USB cable.

    I am running OS X 10.9. When I try to plug it in, I get the following message from the syslog:

    kernel[0]: USBF: 9609.500 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 2 of Hub at 0xfd100000)
    kernel[0]: USBF: 9612.501 The IOUSBFamily was not able to enumerate a device.
    kernel[0]: USBF: 9618.398 The IOUSBFamily gave up enumerating a USB device after 10 retries. (Port 2 of Hub at 0xfd100000)

    I already tried holding the reset button down before plugging in the USB cable and only releasing it after the cable is plugged in, but still get the same error. I also tried it on Ubuntu 13.10, but didn't have any luck connecting it. I assume that the code which is currently on the Teensy is corrupt and disabled/deleted the HalfKay program. Is that possible?

    Is there anything else I could try before desoldering the current Teensy and ordering a new one?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	teensy_ergodox.jpg 
Views:	1010 
Size:	103.9 KB 
ID:	1539  
    Attached Files Attached Files

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts