Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Please help - Issues with Pixelcontroller and WS2801 pixels.

  1. #1

    Please help - Issues with Pixelcontroller and WS2801 pixels.

    I have tried everything to get pixelcontroller to work with ws2801 pixels. I can get them to load the firmware and they are in rainbow mode but when it comes to communication.. I cannot talk to them. What configuration are you using with these? The pixelinvaders config? I have tried the tpm2net settings. nothing, the tpm2serial settings, no repsonse. please help. I probably should have stuck with what was familiar (the lpd6803 pixels) but wanted to upgrade... proving to be a big mistake as im on a timecruch for an art grant project... Any help is appreciated!

    oh my setup is teensy 3.1 > windows 7 > ws2801 pixels
    Last edited by blackrockcity; 07-05-2014 at 12:38 AM.

  2. #2
    Junior Member
    Join Date
    Jan 2013
    Quote Originally Posted by blackrockcity View Post
    oh my setup is teensy 3.1 > windows 7 > ws2801 pixels
    the pixelcontroller firmware works fine for teensy 2.0 - if you want to use it with a teensy 3.x you need to use the latest fastspi lib. use the ws2801 firmware as starting point and replace all old fastspi calls with the new calls.

    let me know if that works, so I can include it with the latest pixelcontroller firmware.


  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    I believe you sent me a private email mentioning not seeing any serial ports, or stuff grayed out, in Arduino's Tools > Serial Port menu. Is that right, or am I confusing this with something else?

    If there's some issue with detecting the COM port, that might be an important issue to resolve before trying to get any special software going that depends upon being able to open a serial port.

  4. #4
    Its not the firmware I updated the library and was able to get the ws2801pixels in rainbow mode aawaiting the data the issue lies in talking to the pixels with pixelcontroller I tried using the pixelinvaders config but they just wontconnect.. when iI try the same setup with lpd6803 they immediately start responding...

  5. #5
    What config settings are you using to get ws2801 to respond? Tpm2net?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts