I made a custom Teensy 3.1 compatible board. It works great, but I'm finding that the compiler barks at me to say RAM is overflowing on sketches that certainly worked on the official dev board. I just realized that I may have used an earlier version of the MINI54, ordered before the 3.1 was available. Could this be the issue here? my MINI54 thinks I'm using the MK20DX128 instead of the MK20DX256? And if so, can I fool it in software without swapping out the chip?

Cheers n thanks