Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: INPUT_PULLUP is not pulling up (Teensy 2++)

  1. #1

    INPUT_PULLUP is not pulling up (Teensy 2++)

    So I got this code:
    void setup() {
        pinMode(PIN_D0, INPUT_PULLUP);
    When measuring pin D0 with a multimeter I get ~1.75 volts, nothing is connected to the teensy and it is powered from USB

    I tried also:
    pinMode(PIN_D0, INPUT);
    digitalWrite(PIN_D0, HIGH);

    Same results.
    writing LOW to PIN_D0 makes the pin float, as expected.

    PIN_D1 gives 4.9V, as expected.

    Any help would be great.


  2. #2
    Tried another teensy, it appears to be HW fault.

    Pual, do you think theres a way to fix it? What should I do?

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Sounds like a defective board. We test every pin on every board, using a bed-of-nails test. But it's possible it got damaged in shipping or some other way?

    If this board new? Did you buy it directly from PJRC, or through a distributor?

  4. #4
    I got it through sparkfun, it was brand new.

    Stuff is becoming even weirder. I tried a new teensy, it worked well. after running my own app code (if you want I can mail it to you) which uses seeedstudio gprs v2 shield for around one day, the pin D0 also stopped pulling up. (tested using the code posted in the first message)

    trying to make my own pull-up using a 10Kohm resistor didn't work as the voltage is still around 2.7v.

  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    That does sound very strange.

    Without code to reproduce the problem, there's nothing I more can do. If you do post code, I can try running it here on a Teensy++ 2.0 to see what happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts