Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 3.2 requires Teensyduino 1.25 or maybe earlier

  1. #1
    Junior Member
    Join Date
    Oct 2012
    Posts
    19

    Teensy 3.2 requires Teensyduino 1.25 or maybe earlier

    My current setup was Arduino 1.0.6 and Teensyduino 1.20. I wasn't able to program a Teensy 3.2. I upgraded to Arduino 1.6.5 and Teensyduino 1.25 and it programs fine. Don't know when the change was made, but I didn't see any mention of it after looking in all the obvious places (3.1 -> 3.2 changes, tech support, announcement forums here).

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,923
    I wondered about that - not seeing it mentioned - and tried 1.24 and it worked on my T_3.2 so I assumed it was backward compatible to T_3.1 for older TeensyLoader usage.

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,678
    Honestly, I don't even remember if I added in for 1.23 or 1.24, or maybe even back at 1.22. Teensy 3.2 was in the planning stages for a very long time. But if you go back to very old versions, like 1.20, they won't support Teensy 3.2.

    If you *really* want to use 1.20 with Teensy 3.2, you could just briefly run a copy of Arduino with 1.25 installed and click Verify once to make it launch the Teensy Loader. Then quit Arduino but leave Teensy Loader running.

    Every version of Teensy Loader (all the way back to the beginning in 2008) checks if there's already an instance running. So when you run the old Arduino with 1.20 installed, it will just use the Teensy Loader you left running from the new version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •