Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 6 of 6

Thread: return policy

  1. #1

    return policy

    I have a teensy 3.2 that was DOA I have ordered several of these boards all are find except for this one. I plug into usb port nothing happens no blinks nothing

  2. #2
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Colmar, France
    Since all Teensys undergo thorough quality checks before leaving PJRC, it’s extremely rare to have a death one in between a series of perfectly working ones. Did you try the recovery procedures described on the PJRC website?

    If all fails, I think it’s best to contact them by email for the RMA procedure.

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Every brand new Teensy should blink when it gets power, even if there's no USB communication.

    As a quick test, can you use a voltmeter to measure if there's power at the VIN pin, and 3.3V pin?

  4. #4
    I have not tried the recovery procedure will try them. I have tried plugging into computer and no lights at all. I another teensy I plugged in the the same usb with the same usb cable and it works. Will try the recovery this week end and let you know Thanks Dave aka Stress Relief

  5. #5
    Well this has to something I did to kill it. when I plug into board the voltage at the usb pad is 5 volt when the strip is cut. If I bridge the strip the voltage drops to 1.7 volts. I think I did something wrong when soldering pins. Thanks for your help. Will order new board.

  6. #6
    Tried everything I could to repair one of my two teensy 4.1 i received a while ago. One of them worked fine the other one only worked once, even then when i could program it ; it was actually real hard to insert the connector, then i got no power the next times, then used my smd rework station and my tools to replace the USB connector ; now got power going thru USB so 5V ok but no 3.3V, also noticed one cap was missing on the back (look between 3v and pin 12 at the bottom) but it is probably a filtering cap for MPU voltage inputs, so it is probably ok to have it missing for now, don't know what value it is anyway. It must has suffered transportation to canada. For us it is cad35 so i hope i can service it.
    Click image for larger version. 

Name:	T41_MissingCapacitor.jpg 
Views:	26 
Size:	323.3 KB 
ID:	20855.
    I also tried to contact robin and paul but I guess they must be very busy atm
    I'll try replacing the 3.3V TLV7533P regulator.
    Last edited by fab672000; 07-04-2020 at 11:12 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts