Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 6 of 6

Thread: Did i kill teensy 3.2 ?

  1. #1
    Member
    Join Date
    Oct 2015
    Location
    Skopje Macedonia
    Posts
    26

    Did i kill teensy 3.2 ?

    I,accidentally touched Teensy3.2 for some seconds reverse polarity.
    When uploading sketch say done ; Teensy did not respond to a USB-based request to automatically reboot.
    Please press the PROGRAM MODE BUTTON on your Teensy to upload your sketch.
    Program button Not Responding
    Can i repair or using for something?
    Thanks

    Battery power source 3.7v Lipo
    Last edited by dzuljo; 12-05-2015 at 03:46 PM. Reason: Power soource

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,775
    How was the battery connected? To VIN and GND?

    Might be worth trying external 3.3V power, on 3.3 and GND. If you're lucky, the reverse voltage might have only taken out the 3.3V regulator.

  3. #3
    Member
    Join Date
    Oct 2015
    Location
    Skopje Macedonia
    Posts
    26
    Yep battery was connected to VIN and GND.
    VIN-VUSB pad connection is not cutted,do i need to cut VIN-VUSB before powering with 3.3V?
    Thanks

  4. #4
    Member
    Join Date
    Oct 2015
    Location
    Skopje Macedonia
    Posts
    26
    Yes,it's working. :-)
    Thats means i can use teensy only with 3.3v input?
    Or 3.3v is tolerant for 3.7 (4.2v) 18650 battery?

    Thanks

  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    24,775
    Quote Originally Posted by dzuljo View Post
    Or 3.3v is tolerant for 3.7 (4.2v) 18650 battery?
    No, do not connect a 3.7V battery to the 3.3V line. Anything above 3.6V risks damage.

  6. #6
    Member
    Join Date
    Oct 2015
    Location
    Skopje Macedonia
    Posts
    26
    Hi,I am lucky because a damaged only regulator 3.3v
    Now i connect directly to 3.3 pin and Teensy working
    I use teensy for pov poi with apa102 ,72 leds
    When i connect 3.3v have some error with last 5-10 leds,its flashing RED color
    How i go up with voltage,number of leds with error going down.
    I give max to 3.58v and error is with 1-3 leds.I understand that 3.6v is max
    How i read teensy 3.2 to work on 16Mhz need 4.5v and up
    Till i waiting for new teensy its some solution to give more voltage or ???
    I Dont like to cut length of the strip

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •