Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Teensy 3.1 + FastLED with USB and external power

  1. #1
    Junior Member
    Join Date
    Jul 2016
    Posts
    3

    Teensy 3.1 + FastLED with USB and external power

    Hi there,

    I'm running into problems when I control a bunch of APA102 LEDs with the FastLED library and have external power and usb connected. It runs smoothly without the USB and stops animating when I connect USB. Of course I have cut the connection between VUSB and 5V apart (as described here https://www.pjrc.com/teensy/external_power.html) but that didn't help. Also tried with a modified USB cable. Still no luck.

    Any ideas what the problem might be?

    Thanks!

    Julian

  2. #2
    Senior Member Ben's Avatar
    Join Date
    Jul 2013
    Location
    Germany
    Posts
    401
    Is the circuit running from an isolated AC/DC power supply? If yes it might be that plugging in USB will suddenly give it a reference to earth potential, resulting in electrostatic discharge.

  3. #3
    Junior Member
    Join Date
    Jul 2016
    Posts
    3
    I'm using an ac/dc power supply which is grounded and plugged into the same socket as the computer.
    The problem also occurs when I use my laptop in battery mode instead of the computer.

  4. #4
    This was/is a problem with the FastLed library. There is a work around now and a solution soon:

    https://github.com/FastLED/FastLED/issues/339

  5. #5
    Junior Member
    Join Date
    Jul 2016
    Posts
    3
    Ah, great, thanks.
    I ended up flashing the teensy from my Macbook (probably with a slightly different version of the library) and I didn't get this problem anymore. Reading through the issue on Github, this now makes total sense.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •