Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 8 of 8

Thread: Noise with ESP8266

  1. #1
    Senior Member Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    4,241

    Noise with ESP8266

    A question,

    on my "FlexiBoard", i have a ESP8266. It is powered by the Teensy.
    Now, when it the ESP8266 is sending or receiving, i can hear sounds like buzzing (sounds like a cellphone) from the attached I2S-DAC (PT8211)
    Near to the ESP is 100uF + 100nF, the PT8211 is decoupled with 47uF+100nF in series with 10 OHM to 3V3 (GND is analog-ground from Teensy) .

    The buzzing is not loud, and i can hear it only when the PT8211 outputs silence /almost silience.

    But, what i can i do to reduce it more ?
    Would it help to use a extra voltage-regulator for the ESP ?
    Last edited by Frank B; 10-30-2016 at 02:29 PM.

  2. #2
    Senior Member johnnyfp's Avatar
    Join Date
    Jan 2014
    Location
    New Zealand
    Posts
    260
    Try and put an inductor inline with the power to the ESP8266. Also where is the Antenna in relation with the rest of the circuit. If you move it away does the buzzing reduce?

  3. #3
    Senior Member Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    4,241
    Hi Johnny !

    Unfortunately, it is soldered to the board, and it will be almost impossible to remove. I'm asking for my next board-revision.. :-)
    The distance between both is ~4cm, i think.


    The DAC is near the blue LED

  4. #4
    Senior Member DD4WH's Avatar
    Join Date
    Oct 2015
    Location
    Central Europe
    Posts
    183
    Could that be the I2C-lines (they run with 400kHz and radiate a lot of RF)? Just some unqualified suggestions:

    - keep I2C lines as short as possible, even cms can make a difference
    - try to put 100Ohm resistors in the SDA and SCL lines
    - try bypass caps (10pF) from SDA to ground and SCL to ground

    Frank

  5. #5
    Senior Member Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany
    Posts
    4,241
    Hm. There is no I2C.

  6. #6
    Senior Member DD4WH's Avatar
    Join Date
    Oct 2015
    Location
    Central Europe
    Posts
    183
    Oh, then forget my comment ;-)

    I read about the I2S-DAC and read that as "I2C", my fault ;-)

  7. #7
    Senior Member bmillier's Avatar
    Join Date
    Apr 2016
    Location
    Halifax, N.S. Canada
    Posts
    108
    I experienced a similar noise problem with a ESP8266-12 module that I was trying to retro-fit to an existing 2M transceiver PCB (Weekend radio project from SE magazine in Slovenia). I had all of the caps/inductors you mentioned, and fed the ESP8266's Vin from a dedicated wire to the 5V regulator output (i.e. I didn't tap into existing Vcc lines on the orig. PCB. I determined that the noise was being inductively coupled into the audio circuitry on the PCB (an LM386 audio amplifier). In my case, if I used the Access point mode of the ESP8266, I heard a constant clicking noise at about 2 Hz, which I assume was the "beacon" as the ESP8266 transmitted its SSID. In Station mode, this 2 Hz clicking disappeared- but there was still noise when the ESP8266 was transmitting (which in my project was seldom).
    You can reduce the power output of the Wi-Fi transmitter in the ESP8266. I found this helped a bit, but not as much as I would expect with the marked reduction in power I had set. I programmed the ESP8266 in C under the Arduino IDE, and can give you the few lines of code needed if you want.
    I took the module, attached with a few wires for power, Tx,Rx etc. and moved it physically around the PCB to see if I could eliminate noise. While there were some orientations that reduced it significantly, none lent themselves to mounting the ESP8266 as a "daughter-board" to the main PCB. Possibly mounting it on the bottom of the main PCB, with an intervening ground plane might have worked, but that would have hampered the ESP8266's receiving capability.
    In the end, I mounted the ESP8266 about 8 cm away from the main PCB, and that worked fine.

  8. #8
    Senior Member johnnyfp's Avatar
    Join Date
    Jan 2014
    Location
    New Zealand
    Posts
    260
    Reminds me of the old days where I would wrap my BBS 1200baud modem in tin foil to reduce electric noise to get better performance and reduced drop outs.

    The question now is, is the noise coming from the ESP8266 RF side or the power side. Try putting a foil shield around the ESP module (maybe tape or laminate the foil to stop shorts) and see if that reduces the noise. As suggested by bmiller, it could well be an RF issue. But because the unit is soldered in maybe for now that is one option you can do, until you get your new board.

    Now where's my foil hat, can't have those peski aliens reading my thoughts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •