Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 12 of 12

Thread: Announcement thread for Teensydunio 1.31 seems to be missing

  1. #1
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,269

    Announcement thread for Teensydunio 1.31 seems to be missing

    I recall Paul posting the release of 1.31 in the announcements section when I was reading the thread at work. Now that I'm at home (where the Teensy stuff is installed), I don't see that thread any more in the announcements section. The normal link for downloads: http://www.pjrc.com/teensy/td_download.html works and it points to Teensydunio 1.31.

    I'm sure Paul already has this on the list, but one of the features of 1.31 is adding support for the two DAC's of the 3.5/3.6 (AudioOutputAnalogStereo) and also AudioInputAnalogStereo. The Audio Design Tool doesn't seem to have added support for these (http://www.pjrc.com/teensy/gui/).

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,767
    Did you see this?

    https://forum.pjrc.com/threads/39059...l=1#post122724

    Quote Originally Posted by PaulStoffregen View Post
    Ok, it's done. Teensyduino 1.31 is finally released.

    http://www.pjrc.com/teensy/td_download.html
    Teensyduino Revision History
    Version 1.31

    Add support for Arduino 1.6.12
    Arduino SD library support 4 bit SDIO on Teensy 3.5 & 3.6 (special thanks WMXZ)
    Fix EEPROM on Teensy 3.6 with CPU speed > 120 MHz (special thanks Defragster)
    Update FlexCAN library for CAN1 on Teensy 3.6 (Pawelsky)
    Update OctoWS2811 to support Teensy 3.5 & 3.6
    Fix USB serial number on Teensy 3.6 with CPU speed > 120 MHz
    Fix audio I2S output on Teensy 3.6 with CPU speed > 120 MHz when also using I2S input
    Support Teensy 3.5 & 3.6 on older versons of Arduino
    Fix SPI1 default SCK1 pin (KurtE)
    Optimize attachInterrupt (tni)
    Improve USB stability on Teensy 3.6 with CPU 180 or 216 MHz
    Add USB MIDI custom name example
    Fix Adafruit_ST7735 on Teensy 3.5 & 3.6 (MichaelMeissner)
    Many library metadata files updated for PlatformIO
    Fix Ethernet library socket receive bug (thanks ElOtroMateo)
    Fix compiler warnings, eg: kinetis_hsrun_enable unused
    Serial buffer sizes override from command line (Frank B)
    Stream find functions use const for pointers
    Add AudioOutputAnalogStereo and AudioInputAnalogStereo
    Add Audio reverb effect (Joao Rossi Filho)
    Add Audio waterfall spectrum example (Nathaniel Quillin)
    Fix USB Audio on Windows when used with USB Serial
    Fix auto-reboot for newer USB types
    Fix serial monitor for newer non-serial USB types
    Many ILI9341_t3 improvements (Frank B, Kurt E, Softegg)
    SerialFlash allows other SPI ports (Martino Facchin)
    Teensy Loader shows correct images for Teensy 3.5 & 3.6
    Improved handling of float INF & NAN (Frank B)
    Bundle libpng12 & libusb10 libraries, missing from some Linux distros.

  3. #3
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,269
    Ahh, I was just looking for a separate thread announcing 1.31, not a post in the 1.31-beta3 thread.

  4. #4
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,767
    That would be a good feature for Paul to add - maybe in TD_1.32?

  5. #5
    Senior Member
    Join Date
    May 2015
    Posts
    385
    Betas seem to get announcement topics but releases don't. I made a suggestion a while back to put release announcemts in a new topic not in a beta thread. A new topic and a closing post with a link to the new release topic in the beta thread would be how I would do it.

  6. #6
    Member
    Join Date
    Jun 2016
    Location
    rural West Virginia
    Posts
    61
    I'm sure Paul already has this on the list, but one of the features of 1.31 is adding support for the two DAC's of the 3.5/3.6 (AudioOutputAnalogStereo) and also AudioInputAnalogStereo. The Audio Design Tool doesn't seem to have added support for these
    Attempting to simply add a second DAC compiles and uploads to a T3.6, but the sketch does not run in the target device. I will experiment further tonight.

  7. #7
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    5,430
    Quote Originally Posted by tubelab.com View Post
    Attempting to simply add a second DAC compiles and uploads to a T3.6, but the sketch does not run in the target device. I will experiment further tonight.
    I was able to get this to build and work, HOWEVER it would only work if you used one or the other, not both. This is due to how the DMA is setup where both used the same source (PDB0). Paul mentioned in other thread one might be able to get it to work with both if you do something like chain the DMA buffers or the like. I think his approach of making a stereo object probably makes more sense.

  8. #8
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,591
    I've updated the design tool for the 3 new objects: adcs, dacs, reverb.

    http://www.pjrc.com/teensy/gui/

    Hopefully this helps.

  9. #9
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,269
    Quote Originally Posted by PaulStoffregen View Post
    I've updated the design tool for the 3 new objects: adcs, dacs, reverb.

    http://www.pjrc.com/teensy/gui/

    Hopefully this helps.
    Great, thanks.

  10. #10
    Member
    Join Date
    Jun 2016
    Location
    rural West Virginia
    Posts
    61
    My synthesizer uses the audio shield for audio output. I have been using DAC0 for an LFO output. I replaced the two separate DAC instances with the new DACS object. The sketch compiles and runs. DAC0 now puts out LFO1 as it always did, but something strange comes out of DAC1. I have a waveform object (LFO2) connected to in1 with no other connections. I don't get the waveform audio at the DAC pin. I seem to get a distorted version of one of my main audio outputs from the audio shield.

    This could be a yet undiscovered wiring error on my hardware, but I'm out of time right now. I'll get back to it later tonight.

  11. #11
    Member
    Join Date
    Jun 2016
    Location
    rural West Virginia
    Posts
    61
    A simple sketch with a pair of waveforms 200 Hz sine, 150 Hz triangle, each wired to one of the inputs to DACS and the same input on I2S works fine. I get the proper tone in the headphones (I2S) and see it on the scope (DACS). What's getting broken in my synth? Tomorrows challenge.

  12. #12
    Member
    Join Date
    Jun 2016
    Location
    rural West Virginia
    Posts
    61
    I loaded up the "guitar" example with the output playing out the I2S port through the audio adapter. I set up two waveform objects to make the 150 Hz triangle and 200 Hz sine routed to the DACS outputs. All worked correctly, so there is obviously something broken in my synth hardware or software. I will begin the divide and conquer technique later today.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •