Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: XPlane 11 and GPS datarefs

  1. #1
    Junior Member
    Join Date
    Apr 2016
    Posts
    7

    XPlane 11 and GPS datarefs

    Hi, I have a sketch which manipulates the 430 and 530 GPS's in xplane 10. It works fantastic. With xplane 11 it does not work at all. The datarefs for the GPS are the same as far as I can tell between 10 and 11. If I write a sketch which uses datarefs or commands outside of the GPS it works great for both xplane 10 and 11. I have contacted Laminar and they think it is a problem with he plugin but I am having a hard time believing that since it works with other datarefs/commands and in xplane 11 we know they re-worked the GPS's. Anyone out there seen this as well? I am using the TeensyControls plugin for xplane and a Teensy 3.2.

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    26,243
    Don't know if this helps, but several days ago there was an Xplane 11 question, where access to non-array datarefs was working with version 11, but not to an array within a particular instrument. Whether it was the plugin, or Xplane 11, or that particular dataref not supporting writes (eg, the simulation model overwriting its value even if the plugin changes it), or even if it's some previously unknown issue on the Teensy side was never figured out. Or at least not that I recall.

    But at least that's one anecdote that writing to non-array datarefs was working for someone with Xplane 11.

    I personally haven't used Xplane 11, or even version 10 for the last couple years.

  3. #3
    Junior Member
    Join Date
    Apr 2016
    Posts
    7
    Yes, I have had luck with non-array refs as well. In fact all the datarefs seem to work (that I have tried) except the ones related to gps operation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •