Forum Rule: Always post complete source code & details to reproduce any issue!
Page 38 of 39 FirstFirst ... 28 36 37 38 39 LastLast
Results 926 to 950 of 963

Thread: MTP Responder Contribution

  1. #926
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    14,431
    If the SD examples work to see the drive and give expected output then the T_3.5 should be in good shape, and that could point to something in the MTP software build.

  2. #927
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    I tried SDInfo and the files examples, and it works so the 3.5 sd is working
    Last edited by Fluxanode; 06-11-2021 at 07:06 PM.

  3. #928
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    14,431
    Quote Originally Posted by Fluxanode View Post
    I tried SDInfo and the files examples, and it works so the 3.5 sd is working
    Good, that also shows that part of the IDE+TD install isn't corrupted ...

    Seems either something T_3.5 build specific, or something missing/wrong with the install for MTP. Always tough to be sure collecting pieces and manual edits of WIP code

  4. #929
    Senior Member
    Join Date
    Feb 2020
    Posts
    106

    Unhappy

    Quote Originally Posted by defragster View Post
    Good, that also shows that part of the IDE+TD install isn't corrupted ...

    Seems either something T_3.5 build specific, or something missing/wrong with the install for MTP. Always tough to be sure collecting pieces and manual edits of WIP code
    Very true. WIP and it is not ready for T-3.5

  5. #930
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by Fluxanode View Post
    Very true. WIP and it is not ready for T-3.5
    For me, it is working with T3.5.
    tried just now mtp-test with both versions: MTP_DISK and MTP_DISK_SERIAL (A1.8.15 - TD1.54b10 - Win10)
    Note: for MTP_DISK (Seremu) one need to press any key to continue setup().

  6. #931
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    Thanks for the reply.
    I am using a new T3.5 with arduino 1.8.15 and Teensyduino-beta9 with the built-in SD. Both with a fresh install. I'm not sure what you mean "if you declare multiple sd devices (as with mtp-test.ino) : sdx[0] MUST exits." I'm only using the one onboard SD with the out of the box install, do I need to change something in the test program?
    What versions did you test with and what example program are you using? I have followed the install directions to the letter and tested using the included MPT-test.ino.

    Is there a specific USB driver to use? I set up on another computer (without any Arduino or Teensyduino software) and at first the teensy was there as Teensy under an unknown device until the device drivers finished loading/installing then it moved to portable devices as MTP USB DEVICE with a yellow ! next to it and the error message "Device driver software was not successfully installed" came up. BTW the serial port only displays in Device Manager when the port is set to serial. Goes away when set to MTP disk and programed.

    Maybe a driver issue?
    Or teensyduino? I just don't know.

  7. #932
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    I just updated to beta 10. Does the teenduino software need to be loaded on the target computer?

  8. #933
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by Fluxanode View Post
    I just updated to beta 10. Does the teenduino software need to be loaded on the target computer?
    No,
    if you program your sketch properly so that it does not need teensymonitor to start program.
    Note: mtp-test is a test program not a production program. You can use it a starting sketch, but you should modify it for your needs.

    I uploaded a mtp-basic example that does not need teensymonitor to be activated
    Last edited by WMXZ; 06-24-2021 at 07:40 PM.

  9. #934
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    Quote Originally Posted by WMXZ View Post
    No,
    if you program your sketch properly so that it does not need teensymonitor to start program.
    Note: mtp-test is a test program not a production program. You can use it a starting sketch, but you should modify it for your needs.
    I will modify it but first I need to figure out why it isn't working for me. Strange I can't just install the lib and run the test program.

  10. #935
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    Question, what is MTP_DISK_SERIAL? I don't see that option under USB type?

  11. #936
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    What should #define USE_SD be set to for the 3.5? 0 or 1 or ?

  12. #937
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    Success! I used your new new mtp-basic.ino and i now see the teensy device under portable devices! I didn't realize it needed to start monitor to run. Now I still don't see a serial port even after making changes to usb_desc and boards.txt

  13. #938
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    I am seeing a compile warning:

    Using board 'teensy35' from platform in folder: C:\Program Files (x86)\Arduino\hardware\teensy\avr
    Using core 'teensy3' from platform in folder: C:\Program Files (x86)\Arduino\hardware\teensy\avr
    Warning: Board teensy:avr:teensy32 doesn't define a 'build.board' preference. Auto-set to: AVR_TEENSY32

    Is this going to be a problem?

  14. #939
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by Fluxanode View Post
    Success! I used your new new mtp-basic.ino and i now see the teensy device under portable devices! I didn't realize it needed to start monitor to run. Now I still don't see a serial port even after making changes to usb_desc and boards.txt
    You will see a serial com port only if you choose MTP Disk SERIAL (Experimental). If you choose MTP Disk (Experimental), there is no com port but Teensy uses SEREMU (serial emulation) which works with Teensy monitor.

    What should #define USE_SD be set to for the 3.5? 0 or 1 or ?
    Let it as 1

    I am seeing a compile warning:

    Using board 'teensy35' from platform in folder: C:\Program Files (x86)\Arduino\hardware\teensy\avr
    Using core 'teensy3' from platform in folder: C:\Program Files (x86)\Arduino\hardware\teensy\avr
    Warning: Board teensy:avr:teensy32 doesn't define a 'build.board' preference. Auto-set to: AVR_TEENSY32

    Is this going to be a problem?
    I have this warning too, this goes to TD154-b10

  15. #940
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by Fluxanode View Post
    Is this going to be a problem?
    MTP_t4 is updated in Github

  16. #941
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    @WMXZ
    Just a few questions:
    1) Is the a way to access the emulated serial port other than with the arduino monitor? Like with an external terminal program (puttty or another)? Or with my own PC program?
    2) In both the basic and test programs is, it there an issue in the following -
    #else
    #ifndef BUILTIN_SCCARD
    #define BUILTIN_SDCARD 254
    #endif
    void usb_mtp_configure(void) {}
    #endif

    Should BUILTIN_SCCARD be BUILTIN_SDCARD?

  17. #942
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    14,431
    Quote Originally Posted by Fluxanode View Post
    @WMXZ
    Just a few questions:
    1) Is the a way to access the emulated serial port other than with the arduino monitor? Like with an external terminal program (puttty or another)? Or with my own PC program?
    2) In both the basic and test programs is, it there an issue in the following -
    ...
    re #1: Search Forum for TyCommander. A great SerMon that should work well and can do uploads as well.

    re #2: not clear the question but " BUILTIN_SDCARD " is the general magic value to say use SDIO SD card on T_3.6 and T_4.1

  18. #943
    Senior Member
    Join Date
    Feb 2020
    Posts
    106
    @defragster, basically i was asking about the spelling of BUILTIN_SDCARD being correct, it is spelled BUILTIN_SCCARD in the program and wonder if the statement is not going to work?

    Do you know how to access the emulated serial port say from my own program?

  19. #944
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    14,431
    Check this out - and perhaps other on @luni github : github.com/luni64/TeensySharp

    Probably other ways if not c# inclined - saw a python connect to RawHid mode posted in recent days.

  20. #945
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    14,431
    Here's a link that shows that and TyCommander in use on a Wiki: github.com/TeensyUser/doc/wiki/Serial#windows,-c#

  21. #946
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by Fluxanode View Post
    @WMXZ

    Should BUILTIN_SCCARD be BUILTIN_SDCARD?
    corrected the typo in all three examples

  22. #947
    I downloaded the MTP_t4 lib yesterday, but had a problem running the script. Now i coppied all needed libraries in the teensy library folder. When opening the MTP-test, or MTP-basic example, i get folowwing error:
    Code:
    D:\Program Files (x86)\Arduino\hardware\teensy\avr\libraries\MTP_t4\src/Storage.h:33:16: fatal error: FS.h: No such file or directory
    i tried looking online for FS.h but can't find it.

    anyone kwons how to fix this?

    Thnx,
    RR

  23. #948
    Senior Member
    Join Date
    Jul 2014
    Posts
    3,259
    Quote Originally Posted by RayanR View Post
    I downloaded the MTP_t4 lib yesterday, but had a problem running the script. Now i coppied all needed libraries in the teensy library folder. When opening the MTP-test, or MTP-basic example, i get folowwing error:
    Code:
    D:\Program Files (x86)\Arduino\hardware\teensy\avr\libraries\MTP_t4\src/Storage.h:33:16: fatal error: FS.h: No such file or directory
    i tried looking online for FS.h but can't find it.

    anyone kwons how to fix this?

    Thnx,
    RR
    upgrade to Arduino 1.8.15 and TD 1.54b10 (latest as I do not know when FS.h was introduced into cores)

    better to get MTP_t4 into local libraries and not Teensyduino (teensy/avr/libraries) as you have done.

  24. #949
    Quote Originally Posted by WMXZ View Post
    upgrade to Arduino 1.8.15 and TD 1.54b10 (latest as I do not know when FS.h was introduced into cores)

    better to get MTP_t4 into local libraries and not Teensyduino (teensy/avr/libraries) as you have done.
    Thnx it worked no problem

  25. #950
    Senior Member
    Join Date
    Feb 2020
    Posts
    106

    Problem Integrating MTP

    @WMXZ I have the MTP_t4 working with the 3.5 and the 3.2 using the basic example program. Works quite well, thanks. Now integrating into my program seems to be a problem, my part will no longer write new files or update files. I have attached my program files (I am an amature prob not the best coding). Is there a problem using SD and SDFAT together?

    Thanks for any help...
    Attached Files Attached Files
    Last edited by Fluxanode; 07-01-2021 at 09:55 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •