Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: WIZ820io with Arduino 1.8.2/Teensyduino 1.3.6 doesn't work.

  1. #1
    Senior Member
    Join Date
    Jun 2013
    Location
    Montréal
    Posts
    467

    WIZ820io with Arduino 1.8.2/Teensyduino 1.3.6 doesn't work.

    Hello,

    I've been using the Ethernet library with Teensy 3.2 + Wiz820IO + the adaptator board for months without issue. I recently updated my software to Arduino 1.8.2 and Teensyduino 1.36 and it doesn't seem to work anymore. I tried several sketches all with the same issue. To reproduce, you can test the DhcpAddressPrinter example sketch. It hangs forever and never gets assigned an address. The lights on the wiz820io never blink.
    If I revert back to the older versions I was using (Arduino 1.6.12 and Teensyduino 1.31) it starts working again. Seems like something broke...

    I also tried with a fixed IP and it prints 0.0.0.0 instead of the fixed IP I choose.
    I tested this both on Mac OS 10.12, Mac OS 10.11.

    Thanks !

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    10,633
    Just to confirm above as I read it: the Ethernet library with Teensy 3.6 + Wiz820IO works with Arduino 1.6.12 and Teensyduino 1.31 but not with Arduino 1.8.2 and Teensyduino 1.36

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,354
    The reset pulse on pin 9 was removed (for compatibility with other libs using pin 9). You now need to pulse pin 9 yourself if using WIZ820. Easy to do.

    See the init code at the end of this page:

    https://www.pjrc.com/store/wiz820_sd_adaptor.html

  4. #4
    Senior Member
    Join Date
    Jun 2013
    Location
    Montréal
    Posts
    467
    Thanks Paul !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •