Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Teensy 3.5: Programming Problem

  1. #1

    Teensy 3.5: Programming Problem

    Hello everybody,

    I spent a lot of time trying to get a hello world on a freshly received teensy 3.5, using linux. Since I failed, I also tried my luck on windows, but still no luck. Since I always had no problems with other teensy versions, I think that huge amount of time is kind of strange. So I wanted to ask kindly, if there is a completely foolproof step by step guide to download a hello world?

    -> On other teensy versions this was just 1 button click...
    -> I have tried to turn the pc off and on again
    -> I have tried a second freshly bought teensy 3.5 board
    -> Now using: win10, arduino 1.8.5, teensyduino 1.40 (Please tell me your combo if you are able to download anything.)

    Would appreciate any information, thanks!

    I want to add that the hardware is probably ok, since the LED blinks when powered.

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Linux: did you install the udev rules?

    What do you see, when you type: lsusb?

    If it is a fresh Teensy, did you try the normal steps:
    Something like: in Arduino IDE, select Teensy3.5 as the board type.
    Load a simple program like blink.
    Use the Verify command. When it completes it brings up the Teensy GUI app.
    Now press the program button on the Teensy 3.5. Does it download the program?

  3. #3
    Senior Member
    Join Date
    Apr 2013
    What error messages do you get when you hit compile in Arduino?

    Also by way of sanity checking windows should also be noticing the presence of the new usb thingie and doing it's beep and new device check regardless of Arduino install success or failure.

  4. #4
    Thanks guys, I now found the problem.

    the two cheap china cables I used did not work... I now found a real usb cable

  5. #5
    Senior Member
    Join Date
    Feb 2016
    Quote Originally Posted by Teensy35user35 View Post
    Thanks guys, I now found the problem.

    the two cheap china cables I used did not work... I now found a real usb cable
    Itís got us all at some point.
    I use the ones pjrc sell now to save headaches.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts