Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Teensy not being recognized as MIDI device (showing up as generic usb audio)

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Posts
    1

    Teensy not being recognized as MIDI device (showing up as generic usb audio)

    I am fairly new to Teensy but I've done 4 projects already using usb type = midi with no problems. Just started my 5th project and for whatever reason, no matter what I do my Teensy is being recognized (in windows 10) as a "Generic USB Audio" device. I did some searching on here and haven't found anything that looks like this problem. To keep things simple I have just been trying the USB Midi example such as the buttons example and name examples, they both do the same thing. I have tried deleting the device from device manager, I have tried two other windows machines and the Teensy is recognized as a "Generic USB Audio" device on those machines as well. I have been using Arduino 1.8.5 and tried downgrading to 1.8.4 which made no difference. I have tried manually uploading the program to the Teensy and nothing seems to make any difference. Any help would be greatly appreciated!

    TIA,
    Uproden....

  2. #2
    Senior Member oddson's Avatar
    Join Date
    Feb 2013
    Location
    Isle in the Salish Sea
    Posts
    1,016
    In Windows USB info is cached and not updated on each load. Reboot your PC between connection attempts.

    At least that's what I recall. No expert at USB

  3. #3
    Junior Member
    Join Date
    Jun 2018
    Posts
    5
    I have the exact problem, with the only difference that it sets as USB Composite Device with a yellow exclamation mark. Uninstalling the device from Device Manager and restart hasnt worked. Any suggestions?
    Last edited by CocoNat; 11-13-2018 at 09:28 PM.

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    18,687
    First, make sure you're using the latest software. In Arduino, click Help > About to check. If it have less than Teensyduino 1.44, upgrade before doing more trials.

    If Windows has messed up, maybe try selecting Tools > USB Type for one of the *other* MIDI options, like MIDIx4. As far as Windows is concerned, each it a completely different USB device. So using one you haven't used before should trigger Windows to do a completely fresh detection.

    DO NOT INTERRUPT the detecting of new hardware. Especially on Windows 7 & XP, this process can be slow. Go get a cup of coffee or something. If you get impatient and interrupt it, or try reprogramming from Arduino again (which reboots your Teensy --- to Windows the same as if you had unplugged the cable) you can really mess up the New Hardware Wizard (which runs slowly in the background on Windows 7 usually without bothering you as it did in XP & Vista). This stuff is greatly improved in Windows 10, but still not at reliable as Mac & Linux. Especially if you're using older Windows, let it do its slow new hardware detection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •