Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: movie2serial

  1. #1


    I am trying to run Paul's movie2serial Processing script. I have already installed the VideoDisplay script on my 3.2. When I run the Processing script, the grey box where the movie is supposed to be appears but nothing else happens (not even playing the movie). If I comment out this line:
    the grey box will appear with the movie but obviously nothing is happening on my LED display. When I go back to the Serial Monitor in Arduino and send a "?" to the Teensy, it responds with the message I would expect regarding my current setup (225,32,0,0,0,0,0,100,100,0,0,0). Am I missing a library in Processing or something? I have tried this on Processing 3 (64 and 32 bit versions).

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Did you install the Video library?

    Also, make sure you close the Arduino Serial Monitor or even quit Arduino before running the sketch in Processing. Windows only allows 1 program to access a COM port, so Processing can't talk to the Teensy if Arduino is using it.

  3. #3
    Yes, I have that library and Arduino is closed.

  4. #4
    Similar to that thread, I am trying to run a MOV file on Windows 10.

  5. #5
    Just for fun, I tried changing the VideoDisplay script in Arduino to make the Teensy think it has 60 LEDs on each of 16 strips. For some reason, it starts working when I do that but, obviously, the picture is way off. Is there a size constraint that is making it get stuck for my 225x32 array?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts