Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: New to Teensy.. no upload LED flicker?

  1. #1

    New to Teensy.. no upload LED flicker?

    Just a quick question.

    With my Arduino, the built-in LED flickers while code is being uploaded. I dont seem to get this with the Teensy. Code uploads and works... there's just no visual feedback about whats happening.

    Is this normal for Teensy? Am I missing a setting somewhere? The flicker was somehow reassuring...

    Thanks in advance

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    6,093
    That is Normal. Teensy code upload is over USB using HID - and the Teensy has USB hardware internal to the Processor - and silently uses an external bootloader/processor to program. The only Teensy LED is the PIN13 output indicator.

    Depending on the Arduino in use - UNO - has a separate USB interface chip that talks to the Processor over its Serial Rx/Tx where they have LEDS showing state on those lines - and that is what Flickers.

    Teensy just works and quickly - Software will let you know if the upload failed. You can add code below on the LED_BUILTIN in Setup that shows LED sign of life when the code starts to know the upload completed and the Teensy is ready to go.

    Code:
    setup() {
    // ...
      pinMode(LED_BUILTIN, OUTPUT);
      digitalWrite(LED_BUILTIN, HIGH);

  3. #3
    Thanks for the Heads Up... good to know all is operating as it should.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •