Quote Originally Posted by PaulStoffregen View Post
I dropped Arduino 1.9 beta support from the final 1.41 release. Clearly 1.9 beta is too buggy for any serious use.

Still not sure how we can better communicate the nature of beta tests to new users. It's unfortunate Jasoroony had such an unpleasant experience, but I'm pretty sure those memory leaks were from Arduino's new beta test code. 1.8.5 is very stable.
...
I would like to figure out what went so very wrong with Jasoroony's experience here on the forum. Does anyone know? It's difficult to figure out, with all his messages now effectively deleted.
In the case of these beta releases. Maybe slightly changing the wording might have helped. I more or less assumed this beta required the Beta 1.9 Arduino to be used...
Since Arduino's 1.9 betas are a moving target, I've included copies of
beta build #34 which this Teensyduino version expects.
So that is what I did... But if you actually look at the exe when it launches it does list several other releases... Maybe mention at least some of the other major releases supported like the 1.8.5...

As for Jasoroony? I am not sure what happened? I know a few of us asked for the normal information, like which display and show the code... After he posted the code, I started to look at it, but was busy with a few other things, when I came back it was gone... I was going to ask a few questions and make a few suggestions, like ask if he tried running standard SPI code, like SPI.transfer to see if the problem he is experiencing shows up there as well. Also checking to see what the timing was at the start, maybe needed delay for device. orr again ask which display it is, such that maybe some of us already have one... But I guess it is too late for that now...