Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 33 of 33

Thread: Teensyduino 1.41 Beta #4

  1. #26
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    5,422
    Quote Originally Posted by PaulStoffregen View Post
    I dropped Arduino 1.9 beta support from the final 1.41 release. Clearly 1.9 beta is too buggy for any serious use.

    Still not sure how we can better communicate the nature of beta tests to new users. It's unfortunate Jasoroony had such an unpleasant experience, but I'm pretty sure those memory leaks were from Arduino's new beta test code. 1.8.5 is very stable.
    ...
    I would like to figure out what went so very wrong with Jasoroony's experience here on the forum. Does anyone know? It's difficult to figure out, with all his messages now effectively deleted.
    In the case of these beta releases. Maybe slightly changing the wording might have helped. I more or less assumed this beta required the Beta 1.9 Arduino to be used...
    Since Arduino's 1.9 betas are a moving target, I've included copies of
    beta build #34 which this Teensyduino version expects.
    So that is what I did... But if you actually look at the exe when it launches it does list several other releases... Maybe mention at least some of the other major releases supported like the 1.8.5...

    As for Jasoroony? I am not sure what happened? I know a few of us asked for the normal information, like which display and show the code... After he posted the code, I started to look at it, but was busy with a few other things, when I came back it was gone... I was going to ask a few questions and make a few suggestions, like ask if he tried running standard SPI code, like SPI.transfer to see if the problem he is experiencing shows up there as well. Also checking to see what the timing was at the start, maybe needed delay for device. orr again ask which display it is, such that maybe some of us already have one... But I guess it is too late for that now...

  2. #27
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,576
    Good point on the wording. It does kinda say 1.9 is expected, when my intention was only to make sure everyone had exactly the same 1.9 which I used for building the installer. Next time (if there is a next time... who knows how long 1.9 beta will go, hopefully not 2+ years like they did for 1.5 beta) I'll be more careful in composing the message.

    I saw he was missing the LiquidCrystal library at some point. At the time I downloaded a fresh copy of Arduino (admittedly the Linux version, not Windows) and couldn't reproduce the problem. I had lots of MIDI code open at the time, so didn't go any further with it.

    Other than that LiquidCrystal issue, everything I can still see looks like he just grew increasingly frustrated with the bugs in Windows version of Arduino 1.9 beta. I see he said he was going to go back to 1.8.5, but looks like he didn't ever do that. It's kind of a shame, since 1.8.5 really is very stable, and these last couple TD betas are the very best we've ever had.


    While I'm not going to go back and pull his messages from the logs, I do feel strongly that once something is said, it can't be unsaid. We really should have been using the time limit for edits all along (and also in hindsight, it could have been locking out one of our worse weaknesses that spammers exploit). Live & learn, I guess...

    Now that 7 of us have capability to edit stuff, I do believe this may be a good moment to make sure none of us are silently making edits. I'll chat with Robin and we'll probably send out an email. But my general feeling when it comes to editing any post is "less is more", and if any of us does edit anything, there needs to be a pretty clear "edited by /name/ and the reason explained".

  3. #28
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,532
    At least as far as I know, it was nobody else but Jasoroony himself who edited his own posts...

  4. #29
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    5,422
    So far I don't believe I have edited anyone else's posts but my own... I have been tempted at times to go in and put in code tags, but have resisted.

    On the other forums which I was a moderator, if a user said something that was not appropriate, unless it was a some form of post that would typically get a user banned, the approach was to send a PM to the user, asking them to clean up their own post.

    I do like the idea of time limits, although it may have some side effects, which may or may not be good. That is for example suppose, one of the senior contributors create a new thread to describe some major library or Teensyduino feature, like i2c_t3t3 or threading or USBHost Joysticks and wish for the first posting in the thread to contain information about the current state of the library/feature, such that they update this post each time they do a major upgrade to that code base... This might now longer work.

  5. #30
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,706
    I SEE a thread in moderation stream . . .

    I see the user member+ designation is new - not sr or MOD?

  6. #31
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,576
    Robin's updating the settings right now. It's supposed to display "Senior Member+". No actual change in forum settings.

  7. #32
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,706
    I too have thought adding a CODE tag would help a great deal to others posts . . . but not touched any but my own posts.

    About 3 times going for a reply with quote - wrongly hit 'Edit' for another's post and had to cancel.

    tonton81 did just note he couldn't make an edit . . . I've habitually updated mine with corrected info since a thread scan might otherwise share the wrong info I had/gave at that point.

    Adding this will put it above the 'TD 1.41 released' - It would be nice if the 'Current Release' ( and Beta ? ) were made STICKY in announcements. Paul - is that something we could do?

  8. #33
    Senior Member
    Join Date
    Aug 2014
    Posts
    140
    I found a strange bug where my parallel strands of neopixel / ws2812b LED no longer work properly. A few of the LED have trouble changing color, so some kind of data corruption? It worked fine before this patch. I have no idea what I need to provide for code because the project is huge, but I use audio and many other library. If I can get it to replicate on a breadboard with small example I can send code, but no idea how to fix it except not use this version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •