Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Teensy 3.X COM port (frequently) disappears after programming

  1. #1
    Junior Member
    Join Date
    Oct 2017

    Teensy 3.X COM port (frequently) disappears after programming

    Frequently (not always) when I reprogram a teensy 3 (several 3.2s and 3.6s tried) on a Windows 10 computer the Teensy will fail to reappear as a COM port. I can replicate this with the DigitalReadSerial example with USB type "Serial" by doing the following:

    1) plug in teensy
    2) press compile and upload
    3) the teensyloader will show that the code uploaded and the teensy rebooted
    4) the COM port will not re-appear (in either the arduino IDE or device manager)

    If I attempt to program the teensy again the teensyloader switches to "...manually enter Program Mode". If I press the program button, it will upload and reboot. Sometimes here the COM port will reappear.

    It seems like if the COM port appears I can upload and the teensyloader will reboot. If the COM port doesn't appear, the teensy has to be manually rebooted. Un-plugging and re-plugging the teensy does seem to always (as far as I can tell) make the COM port appear.

    I tried searching around for this same solution and didn't find anything but please point me towards a post if it already exists.

    I'm unsure if this is windows 10 driver related so if there is a way to confirm that the drivers are correct that might be a first step. Is there a list of what drivers I should expect to be using on windows 10?

    Thanks in advance for any help!

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Please give the latest beta a try. It has new and (hopefully) improved USB device detection.

    In the Tools > Ports menu you should see both "Teensy" and "Serial". Select your board from the new "Teensy" section.

    After uploading, use Teensy Loader's Help > Verbose Info menu. The verbose info window has a Log menu which lets you save all the info to a file, which you can attach to your message here (click "Go Advanced" to get the forum's editor that lets you attach a file).

    This new beta collects much more info about what's really happening with USB on your computer. With 1.41 and earlier we have pretty much no way to know what's going wrong on Windows systems. This new version is meant to give us a way to finally look into all these "strange" Windows (and sometimes Mac) issues, using that verbose info log.

  3. #3
    Junior Member
    Join Date
    Oct 2017

    I installed the beta and arduino 1.8.5 (I was running 1.8.3). I've reprogrammed a teensy 3.6 over 10 times without the issue (before it was happening almost every time). So (fingers crossed) I think you fixed it!

    I'll update this post if I run into the issue again with the log output.

  4. #4
    Senior Member Wozzy's Avatar
    Join Date
    Jan 2013
    Philadelphia, Pennsylvania USA
    This problem also occurs with low quality or non-compliant USB hubs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts