Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 10 of 10

Thread: Teensyduino installation

  1. #1
    Junior Member
    Join Date
    Mar 2018
    Posts
    8

    Teensyduino installation

    Hi,

    I am trying to install teensyduino 1.41. When I select the location of arduino, the "next" option isn't activated. This is what i get.

    Click image for larger version. 

Name:	Screenshot (68).png 
Views:	41 
Size:	32.6 KB 
ID:	13458
    Click image for larger version. 

Name:	Screenshot (69).png 
Views:	36 
Size:	17.3 KB 
ID:	13459

    I had previously installed Arduino 1.8.5 which teensyduino 1.41 is supposed to support. Can someone help me with this?

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,546
    The simplest solution is probably to just reinstall Arduino. Make sure you get the EXE installer, not the Windows Store version.

    If you want to dig into this problem, the next step would involve looking to see what's actually in that C:\Program Files (x86)\Arduino folder. Every copy of Arduino is supposed to have a "lib" folder, and inside that folder should be "version.txt". The installer says it doesn't see that file. Can you see it if you look in that folder?

  3. #3
    Junior Member
    Join Date
    Mar 2018
    Posts
    6
    Hi

    I could install teensyduino. But in arduino -> tools -> boards.
    teensy board is not there

  4. #4
    Junior Member
    Join Date
    Mar 2018
    Posts
    8
    I reinstalled Arduino. Checked the "lib" folder. It contains "version.txt". But i am still facing the same problem. What do i do now?

  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,546
    Maybe try right clicking the installer and run it as admin?

  6. #6
    Senior Member Wozzy's Avatar
    Join Date
    Jan 2013
    Location
    Philadelphia, Pennsylvania USA
    Posts
    354
    Also sometimes turning off your virus scanning helps.

  7. #7
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    5,414
    Also these days, I prefer to download zip file version and install outside the program files area.

    And as mentioned if you are using a virus package it might be interfering with install.

  8. #8
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,546
    Does it make a difference whether to let IE run it automatically after download, versus save and then click on it from Windows Explorer?

    If so (at least one other person reported this recently), maybe I'll need to look into some way to detect the difference and show something more helpful than just not being able to access the lib/versions.txt file.

  9. #9
    Junior Member
    Join Date
    Mar 2018
    Posts
    8
    I was able to successfully install teensyduino. This time I used Arduino 1.8.2 instead of Arduino 1.8.5.
    Now I want to interface ESP8266 with teensy 3.6. But every time I run a code to do so, i get an error stating "espcomm_upload_mem failed". How do i get past this?

  10. #10
    Senior Member Wozzy's Avatar
    Join Date
    Jan 2013
    Location
    Philadelphia, Pennsylvania USA
    Posts
    354
    Quote Originally Posted by Anagha View Post
    ... How do i get past this?
    It's generally a good idea to post details and photos about your project and the code that is giving errors.
    (See the "Forum Rule:" in red at the top of the page)

    It's really the only way anyone can give meaningful help without just guessing at solutions.

    To post formatted code use the # icon and place your code between the markers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •